- Update LLVM/Clang suite to 3.1 release

PR:		168921
Submitted by:	myself
Approved by:	brooks (via pav@, with timeout)
This commit is contained in:
Dima Panov 2012-06-26 10:10:40 +00:00
parent 4079c05aed
commit 59a6890bf5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=299996
9 changed files with 180 additions and 85 deletions

View File

@ -6,15 +6,16 @@
#
PORTNAME= llvm
PORTVERSION= 3.0
PORTVERSION= 3.1
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
.if defined(PACKAGE_BUILDING) || defined(MAINTAINER_MODE)
USE_PYTHON_BUILD= yes
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
.endif
.if defined(MAINTAINER_MODE)
@ -23,17 +24,18 @@ BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
CONFLICTS= llvm-devel-[23]* llvm-etoile-2*
WRKSRC= ${WRKDIR}/${DISTNAME}.src
GNU_CONFIGURE= yes
USE_GCC= 4.2+
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PERL5= yes
USE_PYTHON_BUILD= yes
MAKE_JOBS_SAFE= yes
# Suggested tweaks from http://llvm.org/docs/Packaging.html
CONFIGURE_ARGS+= --enable-shared
MAKE_ARGS+= REQUIRES_RTTI=1
LIBNAME= libLLVM-${DISTVERSION:C/\.r[0-9]*//}.so
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
@ -43,16 +45,19 @@ CONFIGURE_ARGS+= --enable-optimized
CONFIGURE_ARGS+= --enable-bindings=none
OPTIONS= ASSERTS "Enable assertions (thread unsafe)" off
OPTIONS= ASSERTS "Enable assertions (thread unsafe)" off \
LTOPLUGIN "Build LTO plugin (requires gold)" off
.if defined(NOPORTDOCS)
CONFIGURE_ARGS+= --disable-docs
.endif
MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 \
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-diff.1 \
MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 llvm-as.1 \
llvm-bcanalyzer.1 llvm-config.1 llvm-cov.1 llvm-diff.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
llvm-prof.1 llvm-ranlib.1 opt.1 tblgen.1
llvm-prof.1 llvm-ranlib.1 llvm-stress.1 opt.1 tblgen.1
PLIST_SUB+= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
@ -74,7 +79,12 @@ CONFIGURE_ARGS+= --enable-assertions
CONFIGURE_ARGS+= --disable-assertions
.endif
PLIST_SUB+= PORTVERSION=${PORTVERSION}
.ifdef(WITH_LTOPLUGIN)
BUILD_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
CONFIGURE_ARGS+= --with-binutils-include=${LOCALBASE}/include
PLIST_FILES+= lib/LLVMgold.so
.endif
post-patch:
${REINPLACE_CMD} -e 's|\(PROJ_docsdir.*:=\).*$$|\1${DOCSDIR}|g' \
@ -85,15 +95,19 @@ post-patch:
.if defined(NOPORTDOCS)
post-build:
@cd ${WRKSRC}/docs/CommandGuide && ${GMAKE} ${MAN1}
.endif
post-install:
${MV} ${PREFIX}/lib/${LIBNAME} ${PREFIX}/lib/${LIBNAME}.0
${LN} -s ${LIBNAME}.0 ${PREFIX}/lib/${LIBNAME}
.if defined(NOPORTDOCS)
.for man in ${MAN1}
@${INSTALL_MAN} ${WRKSRC}/docs/CommandGuide/${man} \
${MANPREFIX}/man/man1/
.endfor
.endif
TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check-local-lit)'
TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} LD_LIBRARY_PATH=${WRKSRC}/Release/lib ${GMAKE} check-local-lit)'
regression-test: ${BUILD_COOKIE}
if [ `${ID} -u` = 0 ]; then \
${CHOWN} -R nobody ${WRKSRC}/test; \
@ -110,7 +124,6 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/opt \
lib/BugpointPasses.so \
lib/LLVMHello.so \
lib/libEnhancedDisassembly.a \
lib/libLTO.* \
lib/libLLVM* \
lib/libprofile_rt.a \

View File

@ -1,2 +1,2 @@
SHA256 (llvm-3.0.tar.gz) = 519eb11d3499ce99c6ffdb8718651fc91425ed7690eac91c8d6853474f7c0477
SIZE (llvm-3.0.tar.gz) = 10350539
SHA256 (llvm-3.1.src.tar.gz) = 1ea05135197b5400c1f88d00ff280d775ce778f8f9ea042e25a1e1e734a4b9ab
SIZE (llvm-3.1.src.tar.gz) = 11077429

View File

@ -0,0 +1,20 @@
$FreeBSD$
--- utils/llvm-build/llvmbuild/main.py.orig
+++ utils/llvm-build/llvmbuild/main.py
@@ -633,7 +633,13 @@
# We handle a few special cases of target names here for historical
# reasons, as these are the names configure currently comes up with.
- native_target_name = { 'x86' : 'X86',
+ native_target_name = { 'amd64' : 'X86',
+ 'arm' : 'ARM',
+ 'i386' : 'X86',
+ 'mips' : 'Mips',
+ 'powerpc' : 'PowerPC',
+ 'sparc64' : 'Sparc',
+ 'x86' : 'X86',
'x86_64' : 'X86',
'Unknown' : None }.get(opts.native_target,
opts.native_target)

View File

@ -17,8 +17,10 @@ bin/llvm-nm
bin/llvm-objdump
bin/llvm-prof
bin/llvm-ranlib
bin/llvm-readobj
bin/llvm-rtdyld
bin/llvm-size
bin/llvm-stress
bin/llvm-stub
bin/llvm-tblgen
bin/macho-dump
@ -34,9 +36,11 @@ include/llvm-c/Initialization.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm-c/Object.h
include/llvm-c/Target.h
include/llvm-c/TargetMachine.h
include/llvm-c/Transforms/IPO.h
include/llvm-c/Transforms/PassManagerBuilder.h
include/llvm-c/Transforms/Scalar.h
include/llvm-c/Transforms/Vectorize.h
include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
@ -52,6 +56,7 @@ include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
include/llvm/ADT/Hashing.h
include/llvm/ADT/ImmutableIntervalMap.h
include/llvm/ADT/ImmutableList.h
include/llvm/ADT/ImmutableMap.h
@ -80,6 +85,7 @@ include/llvm/ADT/SmallSet.h
include/llvm/ADT/SmallString.h
include/llvm/ADT/SmallVector.h
include/llvm/ADT/SparseBitVector.h
include/llvm/ADT/SparseSet.h
include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
@ -92,7 +98,8 @@ include/llvm/ADT/Triple.h
include/llvm/ADT/Twine.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/ValueMap.h
include/llvm/ADT/VectorExtras.h
include/llvm/ADT/VariadicFunction.h
include/llvm/ADT/edit_distance.h
include/llvm/ADT/ilist.h
include/llvm/ADT/ilist_node.h
include/llvm/Analysis/AliasAnalysis.h
@ -169,9 +176,9 @@ include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/Analysis.h
include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
include/llvm/CodeGen/DFAPacketizer.h
include/llvm/CodeGen/EdgeBundles.h
include/llvm/CodeGen/FastISel.h
include/llvm/CodeGen/FunctionLoweringInfo.h
@ -188,6 +195,7 @@ include/llvm/CodeGen/LinkAllAsmWriterComponents.h
include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
include/llvm/CodeGen/LiveIntervalAnalysis.h
include/llvm/CodeGen/LiveRangeEdit.h
include/llvm/CodeGen/LiveStackAnalysis.h
include/llvm/CodeGen/LiveVariables.h
include/llvm/CodeGen/MachORelocation.h
@ -204,6 +212,7 @@ include/llvm/CodeGen/MachineFunctionAnalysis.h
include/llvm/CodeGen/MachineFunctionPass.h
include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineInstrBundle.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLoopInfo.h
include/llvm/CodeGen/MachineLoopRanges.h
@ -215,7 +224,7 @@ include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/MachineSSAUpdater.h
include/llvm/CodeGen/ObjectCodeEmitter.h
include/llvm/CodeGen/MachineScheduler.h
include/llvm/CodeGen/PBQP/Graph.h
include/llvm/CodeGen/PBQP/HeuristicBase.h
include/llvm/CodeGen/PBQP/HeuristicSolver.h
@ -228,8 +237,10 @@ include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocPBQP.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterScavenging.h
include/llvm/CodeGen/ResourcePriorityQueue.h
include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/ScheduleDAGInstrs.h
include/llvm/CodeGen/ScheduleHazardRecognizer.h
include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/ScoreboardHazardRecognizer.h
@ -249,16 +260,17 @@ include/llvm/Config/llvm-config.h
include/llvm/Constant.h
include/llvm/Constants.h
include/llvm/DebugInfo/DIContext.h
include/llvm/DebugInfoProbe.h
include/llvm/DefaultPasses.h
include/llvm/DerivedTypes.h
include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
include/llvm/ExecutionEngine/IntelJITEventsWrapper.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
include/llvm/ExecutionEngine/JITEventListener.h
include/llvm/ExecutionEngine/JITMemoryManager.h
include/llvm/ExecutionEngine/MCJIT.h
include/llvm/ExecutionEngine/OProfileWrapper.h
include/llvm/ExecutionEngine/RuntimeDyld.h
include/llvm/Function.h
include/llvm/GVMaterializer.h
@ -276,8 +288,8 @@ include/llvm/Intrinsics.gen
include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
include/llvm/IntrinsicsARM.td
include/llvm/IntrinsicsAlpha.td
include/llvm/IntrinsicsCellSPU.td
include/llvm/IntrinsicsHexagon.td
include/llvm/IntrinsicsPTX.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
@ -336,6 +348,7 @@ include/llvm/MC/MCTargetAsmLexer.h
include/llvm/MC/MCTargetAsmParser.h
include/llvm/MC/MCValue.h
include/llvm/MC/MCWin64EH.h
include/llvm/MC/MCWinCOFFObjectWriter.h
include/llvm/MC/MachineLocation.h
include/llvm/MC/SectionKind.h
include/llvm/MC/SubtargetFeature.h
@ -344,6 +357,7 @@ include/llvm/Module.h
include/llvm/Object/Archive.h
include/llvm/Object/Binary.h
include/llvm/Object/COFF.h
include/llvm/Object/ELF.h
include/llvm/Object/Error.h
include/llvm/Object/MachO.h
include/llvm/Object/MachOFormat.h
@ -377,6 +391,7 @@ include/llvm/Support/CrashRecoveryContext.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataExtractor.h
include/llvm/Support/DataFlow.h
include/llvm/Support/DataStream.h
include/llvm/Support/DataTypes.h
include/llvm/Support/Debug.h
include/llvm/Support/DebugLoc.h
@ -403,6 +418,9 @@ include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
include/llvm/Support/LICENSE.TXT
include/llvm/Support/LeakDetector.h
include/llvm/Support/Locale.h
include/llvm/Support/LockFileManager.h
include/llvm/Support/MDBuilder.h
include/llvm/Support/MachO.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/MathExtras.h
@ -431,9 +449,11 @@ include/llvm/Support/Regex.h
include/llvm/Support/Registry.h
include/llvm/Support/RegistryParser.h
include/llvm/Support/SMLoc.h
include/llvm/Support/SaveAndRestore.h
include/llvm/Support/Signals.h
include/llvm/Support/Solaris.h
include/llvm/Support/SourceMgr.h
include/llvm/Support/StreamableMemoryObject.h
include/llvm/Support/StringPool.h
include/llvm/Support/SwapByteOrder.h
include/llvm/Support/SystemUtils.h
@ -449,6 +469,7 @@ include/llvm/Support/TypeBuilder.h
include/llvm/Support/Valgrind.h
include/llvm/Support/ValueHandle.h
include/llvm/Support/Win64EH.h
include/llvm/Support/YAMLParser.h
include/llvm/Support/circular_raw_ostream.h
include/llvm/Support/raw_os_ostream.h
include/llvm/Support/raw_ostream.h
@ -488,11 +509,12 @@ include/llvm/Transforms/Instrumentation.h
include/llvm/Transforms/Scalar.h
include/llvm/Transforms/Utils/AddrModeMatcher.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
include/llvm/Transforms/Utils/BasicInliner.h
include/llvm/Transforms/Utils/BuildLibCalls.h
include/llvm/Transforms/Utils/Cloning.h
include/llvm/Transforms/Utils/CmpInstAnalysis.h
include/llvm/Transforms/Utils/FunctionUtils.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/ModuleUtils.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/SSAUpdater.h
include/llvm/Transforms/Utils/SSAUpdaterImpl.h
@ -500,6 +522,7 @@ include/llvm/Transforms/Utils/SimplifyIndVar.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Transforms/Utils/UnrollLoop.h
include/llvm/Transforms/Utils/ValueMapper.h
include/llvm/Transforms/Vectorize.h
include/llvm/Type.h
include/llvm/Use.h
include/llvm/User.h
@ -507,37 +530,33 @@ include/llvm/Value.h
include/llvm/ValueSymbolTable.h
lib/BugpointPasses.so
lib/LLVMHello.so
lib/libEnhancedDisassembly.a
lib/libLLVM-%%PORTVERSION%%.so
lib/libLLVM-%%PORTVERSION%%.so.0
lib/libLLVMARMAsmParser.a
lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
lib/libLLVMARMDesc.a
lib/libLLVMARMDisassembler.a
lib/libLLVMARMInfo.a
lib/libLLVMAlphaCodeGen.a
lib/libLLVMAlphaDesc.a
lib/libLLVMAlphaInfo.a
lib/libLLVMAnalysis.a
lib/libLLVMArchive.a
lib/libLLVMAsmParser.a
lib/libLLVMAsmPrinter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
lib/libLLVMBlackfinCodeGen.a
lib/libLLVMBlackfinDesc.a
lib/libLLVMBlackfinInfo.a
lib/libLLVMCBackend.a
lib/libLLVMCBackendInfo.a
lib/libLLVMCellSPUCodeGen.a
lib/libLLVMCellSPUDesc.a
lib/libLLVMCellSPUInfo.a
lib/libLLVMCodeGen.a
lib/libLLVMCore.a
lib/libLLVMCppBackend.a
lib/libLLVMCppBackendCodeGen.a
lib/libLLVMCppBackendInfo.a
lib/libLLVMDebugInfo.a
lib/libLLVMExecutionEngine.a
lib/libLLVMHexagonAsmPrinter.a
lib/libLLVMHexagonCodeGen.a
lib/libLLVMHexagonDesc.a
lib/libLLVMHexagonInfo.a
lib/libLLVMInstCombine.a
lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
@ -557,9 +576,11 @@ lib/libLLVMMSP430AsmPrinter.a
lib/libLLVMMSP430CodeGen.a
lib/libLLVMMSP430Desc.a
lib/libLLVMMSP430Info.a
lib/libLLVMMipsAsmParser.a
lib/libLLVMMipsAsmPrinter.a
lib/libLLVMMipsCodeGen.a
lib/libLLVMMipsDesc.a
lib/libLLVMMipsDisassembler.a
lib/libLLVMMipsInfo.a
lib/libLLVMObject.a
lib/libLLVMPTXAsmPrinter.a
@ -577,12 +598,10 @@ lib/libLLVMSparcCodeGen.a
lib/libLLVMSparcDesc.a
lib/libLLVMSparcInfo.a
lib/libLLVMSupport.a
lib/libLLVMSystemZCodeGen.a
lib/libLLVMSystemZDesc.a
lib/libLLVMSystemZInfo.a
lib/libLLVMTableGen.a
lib/libLLVMTarget.a
lib/libLLVMTransformUtils.a
lib/libLLVMVectorize.a
lib/libLLVMX86AsmParser.a
lib/libLLVMX86AsmPrinter.a
lib/libLLVMX86CodeGen.a
@ -605,7 +624,6 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/BitCodeFormat.html
%%PORTDOCS%%%%DOCSDIR%%/html/BranchWeightMetadata.html
%%PORTDOCS%%%%DOCSDIR%%/html/Bugpoint.html
%%PORTDOCS%%%%DOCSDIR%%/html/CFEBuildInstrs.html
%%PORTDOCS%%%%DOCSDIR%%/html/CMake.html
%%PORTDOCS%%%%DOCSDIR%%/html/CodeGenerator.html
%%PORTDOCS%%%%DOCSDIR%%/html/CodingStandards.html
@ -618,7 +636,9 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-as.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-build.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-config.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-cov.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-diff.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
@ -627,6 +647,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-stress.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/manpage.css
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/opt.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/tblgen.html
@ -643,8 +664,10 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStarted.html
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStartedVS.html
%%PORTDOCS%%%%DOCSDIR%%/html/GoldPlugin.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToAddABuilder.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToReleaseLLVM.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToSubmitABug.html
%%PORTDOCS%%%%DOCSDIR%%/html/LLVMBuild.html
%%PORTDOCS%%%%DOCSDIR%%/html/LangRef.html
%%PORTDOCS%%%%DOCSDIR%%/html/Lexicon.html
%%PORTDOCS%%%%DOCSDIR%%/html/LinkTimeOptimization.html
@ -658,8 +681,8 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/SourceLevelDebugging.html
%%PORTDOCS%%%%DOCSDIR%%/html/SystemLibrary.html
%%PORTDOCS%%%%DOCSDIR%%/html/TableGenFundamentals.html
%%PORTDOCS%%%%DOCSDIR%%/html/TestSuiteMakefileGuide.html
%%PORTDOCS%%%%DOCSDIR%%/html/TestingGuide.html
%%PORTDOCS%%%%DOCSDIR%%/html/UsingLibraries.html
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMBackend.html
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMPass.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
@ -696,7 +719,9 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ar.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-as.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-build.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-config.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-cov.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-diff.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-dis.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-extract.ps
@ -705,6 +730,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-nm.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-prof.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ranlib.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-stress.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/opt.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/tblgen.ps
@dirrm include/llvm/Transforms/Utils

View File

@ -6,9 +6,10 @@
#
PORTNAME= clang
PORTVERSION= 3.0
PORTVERSION= 3.1
CATEGORIES= lang devel
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${LLVM_SOURCE}
EXTRACT_ONLY= ${LLVM_SOURCE}
@ -18,12 +19,12 @@ COMMENT= C, Objective-C, and (alpha-quality) C++ compiler
CONFLICTS= clang-devel-[23]*
CLANG_NAME= clang-${PORTVERSION}
CLANG_NAME= clang-${PORTVERSION}.src
CLANG_SOURCE= ${CLANG_NAME}${EXTRACT_SUFX}
LLVM_NAME= llvm-${PORTVERSION}
LLVM_NAME= llvm-${PORTVERSION}.src
LLVM_SOURCE= ${LLVM_NAME}${EXTRACT_SUFX}
WRKSRC= ${WRKDIR}/${LLVM_NAME}.src
WRKSRC= ${WRKDIR}/${LLVM_NAME}
BUILD_WRKSRC= ${WRKSRC}/tools/clang
INSTALL_WRKSRC= ${WRKSRC}/tools/clang
@ -44,13 +45,11 @@ USE_PERL5= yes
USE_PYTHON= yes
MAKE_JOBS_SAFE= yes
MAKE_ARGS= CLANG_TBLGEN=${WRKSRC}/Release/bin/clang-tblgen \
MAKE_ARGS= CLANG_TBLGEN=${WRKSRC}/Release+Asserts/bin/clang-tblgen \
LLVMIncDir=${LOCALBASE}/include \
LLVMToolDir=${LOCALBASE}/bin \
LLVMLibDir=${LOCALBASE}/lib
CONFIGURE_ARGS+= --enable-shared
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
.else
@ -74,7 +73,7 @@ BROKEN= Does not compile on sparc64
post-extract:
cd ${WRKSRC}/tools && \
tar xf ${DISTDIR}/${CLANG_SOURCE} && \
${MV} ${CLANG_NAME}.src clang
${MV} ${CLANG_NAME} clang
post-patch:
${REINPLACE_CMD} -e 's|\(PROJ_docsdir.*:=\).*$$|\1${DOCSDIR}|g' \
@ -90,17 +89,12 @@ post-patch:
${WRKSRC}/tools/clang/tools/scan-view/scan-view
pre-build:
${LN} -sf ${LOCALBASE}/include/llvm/Intrinsics.gen \
${WRKSRC}/include/llvm/
${MKDIR} ${WRKSRC}/Release/lib
${LN} -sf ${LOCALBASE}/lib/libLLVM-${PORTVERSION}.so \
${WRKSRC}/Release/lib/
${LN} -sf ${LOCALBASE}/lib/libLLVMTableGen.a \
${WRKSRC}/Release/lib/
${LN} -sf ${LOCALBASE}/lib/libLLVMSupport.a \
${WRKSRC}/Release/lib/
cd ${WRKSRC}/utils/unittest/UnitTestMain && ${GMAKE}
cd ${WRKSRC}/utils/unittest/googletest && ${GMAKE}
${LN} -sf ${LOCALBASE}/include/llvm/Intrinsics.gen ${WRKSRC}/include/llvm/
${MKDIR} ${WRKSRC}/Release+Asserts/lib
${LN} -sf ${LOCALBASE}/lib/libLLVM-${PORTVERSION}.so ${WRKSRC}/Release+Asserts/lib/
${LN} -sf ${LOCALBASE}/lib/libLLVMTableGen.a ${WRKSRC}/Release+Asserts/lib/
${LN} -sf ${LOCALBASE}/lib/libLLVMSupport.a ${WRKSRC}/Release+Asserts/lib/
cd ${WRKSRC}/utils/unittest && ${GMAKE}
.if defined(NOPORTDOCS)
post-build:

View File

@ -1,4 +1,4 @@
SHA256 (clang-3.0.tar.gz) = b64e72da356d7c3428cfd7ac620d49ec042c84eaee13c26024879f555f4e126d
SIZE (clang-3.0.tar.gz) = 7240578
SHA256 (llvm-3.0.tar.gz) = 519eb11d3499ce99c6ffdb8718651fc91425ed7690eac91c8d6853474f7c0477
SIZE (llvm-3.0.tar.gz) = 10350539
SHA256 (clang-3.1.src.tar.gz) = ff63e215dcd3e2838ffdea38502f8d35bab17e487f3c3799579961e452d5a786
SIZE (clang-3.1.src.tar.gz) = 8158418
SHA256 (llvm-3.1.src.tar.gz) = 1ea05135197b5400c1f88d00ff280d775ce778f8f9ea042e25a1e1e734a4b9ab
SIZE (llvm-3.1.src.tar.gz) = 11077429

View File

@ -1,16 +1,16 @@
$FreeBSD: /tmp/pcvs/ports/lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h,v 1.1 2010-10-08 14:00:31 brooks Exp $
$FreeBSD: /tmp/pcvs/ports/lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h,v 1.2 2012-06-26 10:10:40 fluffy Exp $
--- tools/clang/include/clang/Analysis/Analyses/FormatString.h.orig
+++ tools/clang/include/clang/Analysis/Analyses/FormatString.h
@@ -139,6 +139,10 @@
SArg,
@@ -143,6 +143,10 @@
// ** Printf-specific **
+
+ // FreeBSD specific specifiers
+ bArg,
+ DArg,
+
// Objective-C specific specifiers.
ObjCObjArg, // '@'
ObjCBeg = ObjCObjArg, ObjCEnd = ObjCObjArg,

View File

@ -0,0 +1,20 @@
$FreeBSD$
--- utils/llvm-build/llvmbuild/main.py.orig
+++ utils/llvm-build/llvmbuild/main.py
@@ -633,7 +633,13 @@
# We handle a few special cases of target names here for historical
# reasons, as these are the names configure currently comes up with.
- native_target_name = { 'x86' : 'X86',
+ native_target_name = { 'amd64' : 'X86',
+ 'arm' : 'ARM',
+ 'i386' : 'X86',
+ 'mips' : 'Mips',
+ 'powerpc' : 'PowerPC',
+ 'sparc64' : 'Sparc',
+ 'x86' : 'X86',
'x86_64' : 'X86',
'Unknown' : None }.get(opts.native_target,
opts.native_target)

View File

@ -22,6 +22,7 @@ include/clang/AST/Attr.h
include/clang/AST/AttrImpl.inc
include/clang/AST/Attrs.inc
include/clang/AST/BaseSubobject.h
include/clang/AST/BuiltinTypes.def
include/clang/AST/CXXInheritance.h
include/clang/AST/CanonicalType.h
include/clang/AST/CharUnits.h
@ -32,6 +33,7 @@ include/clang/AST/DeclCXX.h
include/clang/AST/DeclContextInternals.h
include/clang/AST/DeclFriend.h
include/clang/AST/DeclGroup.h
include/clang/AST/DeclLookups.h
include/clang/AST/DeclNodes.inc
include/clang/AST/DeclObjC.h
include/clang/AST/DeclTemplate.h
@ -44,7 +46,9 @@ include/clang/AST/ExprCXX.h
include/clang/AST/ExprObjC.h
include/clang/AST/ExternalASTSource.h
include/clang/AST/GlobalDecl.h
include/clang/AST/LambdaMangleContext.h
include/clang/AST/Mangle.h
include/clang/AST/NSAPI.h
include/clang/AST/NestedNameSpecifier.h
include/clang/AST/OperationKinds.h
include/clang/AST/ParentMap.h
@ -70,12 +74,13 @@ include/clang/AST/TypeNodes.def
include/clang/AST/TypeOrdering.h
include/clang/AST/TypeVisitor.h
include/clang/AST/UnresolvedSet.h
include/clang/AST/UsuallyTinyPtrVector.h
include/clang/AST/VTTBuilder.h
include/clang/AST/VTableBuilder.h
include/clang/Analysis/Analyses/CFGReachabilityAnalysis.h
include/clang/Analysis/Analyses/Dominators.h
include/clang/Analysis/Analyses/FormatString.h
include/clang/Analysis/Analyses/LiveVariables.h
include/clang/Analysis/Analyses/PostOrderCFGView.h
include/clang/Analysis/Analyses/PseudoConstantAnalysis.h
include/clang/Analysis/Analyses/ReachableCode.h
include/clang/Analysis/Analyses/ThreadSafety.h
@ -84,28 +89,29 @@ include/clang/Analysis/AnalysisContext.h
include/clang/Analysis/AnalysisDiagnostic.h
include/clang/Analysis/CFG.h
include/clang/Analysis/CFGStmtMap.h
include/clang/Analysis/CallGraph.h
include/clang/Analysis/DomainSpecific/CocoaConventions.h
include/clang/Analysis/FlowSensitive/DataflowSolver.h
include/clang/Analysis/FlowSensitive/DataflowValues.h
include/clang/Analysis/ProgramPoint.h
include/clang/Analysis/Support/BlkExprDeclBitVector.h
include/clang/Analysis/Support/BumpVector.h
include/clang/Analysis/Support/SaveAndRestore.h
include/clang/Analysis/Visitors/CFGRecStmtDeclVisitor.h
include/clang/Analysis/Visitors/CFGRecStmtVisitor.h
include/clang/Analysis/Visitors/CFGStmtVisitor.h
include/clang/Basic/ABI.h
include/clang/Basic/AddressSpaces.h
include/clang/Basic/AllDiagnostics.h
include/clang/Basic/AttrKinds.h
include/clang/Basic/AttrList.inc
include/clang/Basic/Builtins.def
include/clang/Basic/Builtins.h
include/clang/Basic/BuiltinsARM.def
include/clang/Basic/BuiltinsHexagon.def
include/clang/Basic/BuiltinsPPC.def
include/clang/Basic/BuiltinsPTX.def
include/clang/Basic/BuiltinsX86.def
include/clang/Basic/ConvertUTF.h
include/clang/Basic/DelayedCleanupPool.h
include/clang/Basic/Diagnostic.h
include/clang/Basic/DiagnosticASTKinds.inc
include/clang/Basic/DiagnosticAnalysisKinds.inc
@ -119,6 +125,7 @@ include/clang/Basic/DiagnosticIndexName.inc
include/clang/Basic/DiagnosticLexKinds.inc
include/clang/Basic/DiagnosticParseKinds.inc
include/clang/Basic/DiagnosticSemaKinds.inc
include/clang/Basic/DiagnosticSerializationKinds.inc
include/clang/Basic/ExceptionSpecificationType.h
include/clang/Basic/ExpressionTraits.h
include/clang/Basic/FileManager.h
@ -126,10 +133,12 @@ include/clang/Basic/FileSystemOptions.h
include/clang/Basic/FileSystemStatCache.h
include/clang/Basic/IdentifierTable.h
include/clang/Basic/LLVM.h
include/clang/Basic/Lambda.h
include/clang/Basic/LangOptions.def
include/clang/Basic/LangOptions.h
include/clang/Basic/Linkage.h
include/clang/Basic/MacroBuilder.h
include/clang/Basic/Module.h
include/clang/Basic/OnDiskHashTable.h
include/clang/Basic/OpenCL.h
include/clang/Basic/OpenCLExtensions.def
@ -156,6 +165,7 @@ include/clang/Basic/arm_neon.inc
include/clang/CodeGen/BackendUtil.h
include/clang/CodeGen/CodeGenAction.h
include/clang/CodeGen/ModuleBuilder.h
include/clang/Config/config.h
include/clang/Driver/Action.h
include/clang/Driver/Arg.h
include/clang/Driver/ArgList.h
@ -166,7 +176,6 @@ include/clang/Driver/CC1Options.inc
include/clang/Driver/Compilation.h
include/clang/Driver/Driver.h
include/clang/Driver/DriverDiagnostic.h
include/clang/Driver/HostInfo.h
include/clang/Driver/Job.h
include/clang/Driver/ObjCRuntime.h
include/clang/Driver/OptSpecifier.h
@ -180,17 +189,24 @@ include/clang/Driver/ToolChain.h
include/clang/Driver/Types.def
include/clang/Driver/Types.h
include/clang/Driver/Util.h
include/clang/Edit/Commit.h
include/clang/Edit/EditedSource.h
include/clang/Edit/EditsReceiver.h
include/clang/Edit/FileOffset.h
include/clang/Edit/Rewriters.h
include/clang/Frontend/ASTConsumers.h
include/clang/Frontend/ASTUnit.h
include/clang/Frontend/Analyses.def
include/clang/Frontend/AnalyzerOptions.h
include/clang/Frontend/ChainedDiagnosticConsumer.h
include/clang/Frontend/ChainedIncludesSource.h
include/clang/Frontend/CodeGenOptions.h
include/clang/Frontend/CommandLineSourceLoc.h
include/clang/Frontend/CompilerInstance.h
include/clang/Frontend/CompilerInvocation.h
include/clang/Frontend/DependencyOutputOptions.h
include/clang/Frontend/DiagnosticOptions.h
include/clang/Frontend/DiagnosticRenderer.h
include/clang/Frontend/FrontendAction.h
include/clang/Frontend/FrontendActions.h
include/clang/Frontend/FrontendDiagnostic.h
@ -199,28 +215,19 @@ include/clang/Frontend/FrontendPluginRegistry.h
include/clang/Frontend/HeaderSearchOptions.h
include/clang/Frontend/LangStandard.h
include/clang/Frontend/LangStandards.def
include/clang/Frontend/LayoutOverrideSource.h
include/clang/Frontend/LogDiagnosticPrinter.h
include/clang/Frontend/MigratorOptions.h
include/clang/Frontend/MultiplexConsumer.h
include/clang/Frontend/PreprocessorOptions.h
include/clang/Frontend/PreprocessorOutputOptions.h
include/clang/Frontend/SerializedDiagnosticPrinter.h
include/clang/Frontend/TextDiagnostic.h
include/clang/Frontend/TextDiagnosticBuffer.h
include/clang/Frontend/TextDiagnosticPrinter.h
include/clang/Frontend/Utils.h
include/clang/Frontend/VerifyDiagnosticConsumer.h
include/clang/FrontendTool/Utils.h
include/clang/Index/ASTLocation.h
include/clang/Index/Analyzer.h
include/clang/Index/CallGraph.h
include/clang/Index/DeclReferenceMap.h
include/clang/Index/Entity.h
include/clang/Index/GlobalSelector.h
include/clang/Index/Handlers.h
include/clang/Index/IndexProvider.h
include/clang/Index/Indexer.h
include/clang/Index/Program.h
include/clang/Index/STLExtras.h
include/clang/Index/SelectorMap.h
include/clang/Index/TranslationUnit.h
include/clang/Lex/AttrSpellings.inc
include/clang/Lex/CodeCompletionHandler.h
include/clang/Lex/DirectoryLookup.h
@ -232,6 +239,7 @@ include/clang/Lex/Lexer.h
include/clang/Lex/LiteralSupport.h
include/clang/Lex/MacroInfo.h
include/clang/Lex/ModuleLoader.h
include/clang/Lex/ModuleMap.h
include/clang/Lex/MultipleIncludeOpt.h
include/clang/Lex/PPCallbacks.h
include/clang/Lex/PTHLexer.h
@ -258,6 +266,9 @@ include/clang/Rewrite/Rewriter.h
include/clang/Rewrite/Rewriters.h
include/clang/Rewrite/TokenRewriter.h
include/clang/Sema/AnalysisBasedWarnings.h
include/clang/Sema/AttrParsedAttrKinds.inc
include/clang/Sema/AttrParsedAttrList.inc
include/clang/Sema/AttrTemplateInstantiate.inc
include/clang/Sema/AttributeList.h
include/clang/Sema/CXXFieldCollector.h
include/clang/Sema/CodeCompleteConsumer.h
@ -269,7 +280,6 @@ include/clang/Sema/IdentifierResolver.h
include/clang/Sema/Initialization.h
include/clang/Sema/LocInfoType.h
include/clang/Sema/Lookup.h
include/clang/Sema/MultiInitializer.h
include/clang/Sema/ObjCMethodList.h
include/clang/Sema/Overload.h
include/clang/Sema/Ownership.h
@ -292,11 +302,12 @@ include/clang/Serialization/ASTReader.h
include/clang/Serialization/ASTWriter.h
include/clang/Serialization/AttrPCHRead.inc
include/clang/Serialization/AttrPCHWrite.inc
include/clang/Serialization/ChainedIncludesSource.h
include/clang/Serialization/ContinuousRangeMap.h
include/clang/Serialization/Module.h
include/clang/Serialization/ModuleManager.h
include/clang/Serialization/SerializationDiagnostic.h
include/clang/StaticAnalyzer/Checkers/ClangCheckers.h
include/clang/StaticAnalyzer/Checkers/CommonBugCategories.h
include/clang/StaticAnalyzer/Checkers/DereferenceChecker.h
include/clang/StaticAnalyzer/Checkers/LocalCheckers.h
include/clang/StaticAnalyzer/Core/BugReporter/BugReporter.h
@ -318,11 +329,12 @@ include/clang/StaticAnalyzer/Core/PathSensitive/CoreEngine.h
include/clang/StaticAnalyzer/Core/PathSensitive/Environment.h
include/clang/StaticAnalyzer/Core/PathSensitive/ExplodedGraph.h
include/clang/StaticAnalyzer/Core/PathSensitive/ExprEngine.h
include/clang/StaticAnalyzer/Core/PathSensitive/ExprEngineBuilders.h
include/clang/StaticAnalyzer/Core/PathSensitive/FunctionSummary.h
include/clang/StaticAnalyzer/Core/PathSensitive/MemRegion.h
include/clang/StaticAnalyzer/Core/PathSensitive/ObjCMessage.h
include/clang/StaticAnalyzer/Core/PathSensitive/ProgramState.h
include/clang/StaticAnalyzer/Core/PathSensitive/ProgramStateTrait.h
include/clang/StaticAnalyzer/Core/PathSensitive/ProgramState_Fwd.h
include/clang/StaticAnalyzer/Core/PathSensitive/SValBuilder.h
include/clang/StaticAnalyzer/Core/PathSensitive/SVals.h
include/clang/StaticAnalyzer/Core/PathSensitive/Store.h
@ -330,15 +342,20 @@ include/clang/StaticAnalyzer/Core/PathSensitive/StoreRef.h
include/clang/StaticAnalyzer/Core/PathSensitive/SubEngine.h
include/clang/StaticAnalyzer/Core/PathSensitive/SummaryManager.h
include/clang/StaticAnalyzer/Core/PathSensitive/SymbolManager.h
include/clang/StaticAnalyzer/Core/PathSensitive/TaintManager.h
include/clang/StaticAnalyzer/Core/PathSensitive/TaintTag.h
include/clang/StaticAnalyzer/Core/PathSensitive/WorkList.h
include/clang/StaticAnalyzer/Frontend/CheckerRegistration.h
include/clang/StaticAnalyzer/Frontend/FrontendActions.h
include/clang/Tooling/CompilationDatabase.h
include/clang/Tooling/Tooling.h
lib/clang/%%PORTVERSION%%/include/arm_neon.h
lib/clang/%%PORTVERSION%%/include/emmintrin.h
lib/clang/%%PORTVERSION%%/include/immintrin.h
lib/clang/%%PORTVERSION%%/include/mm3dnow.h
lib/clang/%%PORTVERSION%%/include/mm_malloc.h
lib/clang/%%PORTVERSION%%/include/mmintrin.h
lib/clang/%%PORTVERSION%%/include/module.map
lib/clang/%%PORTVERSION%%/include/nmmintrin.h
lib/clang/%%PORTVERSION%%/include/pmmintrin.h
lib/clang/%%PORTVERSION%%/include/smmintrin.h
@ -353,9 +370,9 @@ lib/libclangAnalysis.a
lib/libclangBasic.a
lib/libclangCodeGen.a
lib/libclangDriver.a
lib/libclangEdit.a
lib/libclangFrontend.a
lib/libclangFrontendTool.a
lib/libclangIndex.a
lib/libclangLex.a
lib/libclangParse.a
lib/libclangRewrite.a
@ -364,14 +381,17 @@ lib/libclangSerialization.a
lib/libclangStaticAnalyzerCheckers.a
lib/libclangStaticAnalyzerCore.a
lib/libclangStaticAnalyzerFrontend.a
lib/libclangTooling.a
%%DATADIR%%/scanview.css
%%DATADIR%%/sorttable.js
%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
%%PORTDOCS%%%%DOCSDIR%%/html/AddressSanitizer.html
%%PORTDOCS%%%%DOCSDIR%%/html/AnalyzerRegions.html
%%PORTDOCS%%%%DOCSDIR%%/html/AutomaticReferenceCounting.html
%%PORTDOCS%%%%DOCSDIR%%/html/DriverInternals.html
%%PORTDOCS%%%%DOCSDIR%%/html/InternalsManual.html
%%PORTDOCS%%%%DOCSDIR%%/html/LanguageExtensions.html
%%PORTDOCS%%%%DOCSDIR%%/html/ObjectiveCLiterals.html
%%PORTDOCS%%%%DOCSDIR%%/html/PCHInternals.html
%%PORTDOCS%%%%DOCSDIR%%/html/PTHInternals.html
%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes.html
@ -389,6 +409,7 @@ lib/libclangStaticAnalyzerFrontend.a
@dirrm lib/clang/%%PORTVERSION%%/include
@dirrm lib/clang/%%PORTVERSION%%
@dirrm lib/clang
@dirrm include/clang/Tooling
@dirrm include/clang/StaticAnalyzer/Frontend
@dirrm include/clang/StaticAnalyzer/Core/PathSensitive
@dirrm include/clang/StaticAnalyzer/Core/BugReporter
@ -400,10 +421,11 @@ lib/libclangStaticAnalyzerFrontend.a
@dirrm include/clang/Rewrite
@dirrm include/clang/Parse
@dirrm include/clang/Lex
@dirrm include/clang/Index
@dirrm include/clang/FrontendTool
@dirrm include/clang/Frontend
@dirrm include/clang/Edit
@dirrm include/clang/Driver
@dirrm include/clang/Config
@dirrm include/clang/CodeGen
@dirrm include/clang/Basic
@dirrm include/clang/Analysis/Visitors