Upgrade to version 0.1.2, which uses World Wind data (instead of
Google Earth data) to draw the surface of the Earth ... Submitted by: Dmitry Marakasov <amdmi3 at mail dot ru>
This commit is contained in:
parent
3115829d19
commit
5948f0227a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179346
@ -6,9 +6,10 @@
|
||||
#
|
||||
|
||||
PORTNAME= gaia
|
||||
PORTVERSION= 0.1.0
|
||||
PORTVERSION= 0.1.2
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= http://gaia.serezhkin.com/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gaia-clean
|
||||
|
||||
MAINTAINER= se@FreeBSD.org
|
||||
COMMENT= Display geographic maps with optional GPS tracking support
|
||||
@ -20,32 +21,33 @@ LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_SCONS= yes
|
||||
SCONS_BUILDENV= ${SCONS_ENV}
|
||||
SCONS_ARGS+= prefix=${PREFIX} use_env=1
|
||||
|
||||
OPTIONS= GPS "Build with GPS support" OFF
|
||||
|
||||
IGNORE= distribution stopped due to complaints by Google (software changes required)
|
||||
OPTIONS= GPS "Build with GPS support" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(WITHOUT_GPS)
|
||||
LIB_DEPENDS+= gps.15:${PORTSDIR}/astro/gpsd
|
||||
.else
|
||||
SCONS_ARGS+= gpsd=0
|
||||
SCONS_ARGS+= gpsd=1
|
||||
.endif
|
||||
|
||||
PLIST_FILES= bin/gaia share/gaia/README share/gaia/font.png
|
||||
PLIST_FILES= bin/gaia share/gaia/font.png
|
||||
PLIST_DIRS= share/gaia
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ; s|%%CXX%%|${CXX}|g ; \
|
||||
s|%%DATADIR%%|${PREFIX}/share/gaia| ; \
|
||||
s|%%CFLAGS%%|${CFLAGS}| ; \
|
||||
s|%%CXXFLAGS%%|${CXXFLAGS}|g' ${WRKSRC}/SConstruct
|
||||
PORTDOCS= README
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/gaia ${TARGETDIR}/bin/
|
||||
${MKDIR} ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/
|
||||
${INSTALL_DATA} ${WRKSRC}/data/font.png ${DATADIR}/
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
-e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/SConstruct
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (gaia-0.1.0.tar.bz2) = 9a9f5a3e5095dae5dbf2e6dd998d1f5d
|
||||
SHA256 (gaia-0.1.0.tar.bz2) = 83931c8e5316d3b156a4b71c1e92ec693133daa24f803c35ef983580fe42e48b
|
||||
SIZE (gaia-0.1.0.tar.bz2) = 64892
|
||||
MD5 (gaia-0.1.2.tar.bz2) = b9bd7fd9b035e843788c6a6f25baf07f
|
||||
SHA256 (gaia-0.1.2.tar.bz2) = 9174671fa3e88f6f10d6e5acfe1d18e8e4d6177fa0e288632b4b70f978864c95
|
||||
SIZE (gaia-0.1.2.tar.bz2) = 60241
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- SConstruct~ Wed Nov 8 01:42:33 2006
|
||||
+++ SConstruct Thu Nov 23 19:46:29 2006
|
||||
@@ -10,8 +10,10 @@
|
||||
#######################################
|
||||
# ENVIRONMENT
|
||||
#######################################
|
||||
-env = Environment( CCFLAGS = [ '-Wall', '-g' ],
|
||||
- CXXFLAGS = [ '-Wall', '-g' ],
|
||||
+env = Environment( CCFLAGS = Split("%%CFLAGS%% -DDATADIR='"'"%%DATADIR%%"'"'"),
|
||||
+ CXXFLAGS = Split("%%CXXFLAGS%% -DDATADIR='"'"%%DATADIR%%"'"'"),
|
||||
+ CC = Split ('%%CC%%'),
|
||||
+ CXX = Split('%%CXX%%'),
|
||||
CPPPATH = [ '/usr/local/include', '/usr/X11R6/include' ],
|
||||
LIBPATH = [ '/usr/X11R6/lib', '/usr/local/lib' ],
|
||||
options = opts )
|
@ -1,7 +1,7 @@
|
||||
Gaia is an open, portable, customizable and extendable Google Earth client,
|
||||
Gaia is an open, portable, customizable and extendable Earth viewer,
|
||||
currently in an early stage of development.
|
||||
|
||||
Optionally, the current position as reported by any GPS device supported
|
||||
by "gpsd" can be tracked and displayed.
|
||||
Optionally, the current position as reported by any GPS device
|
||||
supported by "gpsd" can be tracked and displayed.
|
||||
|
||||
WWW: http://gaia.serezhkin.com/
|
||||
WWW: http://www.sourceforge.net/projects/gaia-clean
|
||||
|
Loading…
Reference in New Issue
Block a user