- Explicitly disable features if they are not set in QT4_OPTIONS [1]
- Prevent QT_NO_WEBKIT from creeping into qconfig.h - Make clear that CUPS support is enabled by default Reported by: avg [1]
This commit is contained in:
parent
bbce14dcec
commit
5914c7c1b4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=313048
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= corelib
|
||||
DISTVERSION= ${QT4_VERSION}
|
||||
PORTREVISION= 1
|
||||
CATEGORIES?= devel
|
||||
PKGNAMEPREFIX= qt4-
|
||||
|
||||
@ -45,6 +46,18 @@ EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
|
||||
|
||||
.include "${.CURDIR}/../../devel/qt4/files/Makefile.options"
|
||||
|
||||
.if empty(QT4_OPTIONS:MCUPS)
|
||||
CONFIGURE_ARGS+= -no-cups
|
||||
.endif
|
||||
|
||||
.if empty(QT4_OPTIONS:MNAS)
|
||||
CONFIGURE_ARGS+= -no-nas-sound
|
||||
.endif
|
||||
|
||||
.if empty(QT4_OPTIONS:MQGTKSTYLE)
|
||||
CONFIGURE_ARGS+= -no-gtkstyle
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig 2012-01-06 12:10:24.748328275 +0100
|
||||
+++ configure 2012-01-06 12:15:25.008280655 +0100
|
||||
@@ -7045,7 +7045,6 @@
|
||||
--- ./configure.orig 2012-11-23 10:11:23.000000000 +0000
|
||||
+++ ./configure 2013-02-26 23:15:08.632185943 +0000
|
||||
@@ -7191,7 +7191,6 @@
|
||||
QT_CONFIG="$QT_CONFIG phonon-backend"
|
||||
fi
|
||||
else
|
||||
@ -8,7 +8,7 @@
|
||||
fi
|
||||
|
||||
# disable accessibility
|
||||
@@ -7102,7 +7101,6 @@
|
||||
@@ -7248,7 +7247,6 @@
|
||||
|
||||
# enable opengl
|
||||
if [ "$CFG_OPENGL" = "no" ]; then
|
||||
@ -16,7 +16,7 @@
|
||||
else
|
||||
QT_CONFIG="$QT_CONFIG opengl"
|
||||
fi
|
||||
@@ -7624,7 +7622,6 @@
|
||||
@@ -7776,7 +7774,6 @@
|
||||
if [ "$CFG_XMLPATTERNS" = "yes" ]; then
|
||||
QT_CONFIG="$QT_CONFIG xmlpatterns"
|
||||
else
|
||||
@ -24,7 +24,15 @@
|
||||
fi
|
||||
|
||||
if [ "$CFG_MULTIMEDIA" = "no" ]; then
|
||||
@@ -8242,10 +8239,8 @@
|
||||
@@ -7817,7 +7814,6 @@
|
||||
fi
|
||||
else
|
||||
rm -f "$outpath/mkspecs/modules/qt_webkit_version.pri"
|
||||
- QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_WEBKIT"
|
||||
fi
|
||||
|
||||
if [ "$CFG_SCRIPT" = "yes" -a "$canBuildQtScript" = "no" ]; then
|
||||
@@ -8399,10 +8395,8 @@
|
||||
[ "$CFG_MNG" != "yes" ] && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_IMAGEFORMAT_MNG"
|
||||
[ "$CFG_ZLIB" != "yes" ] && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_ZLIB"
|
||||
[ "$CFG_S60" != "yes" ] && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_S60"
|
||||
@ -35,7 +43,7 @@
|
||||
|
||||
if [ "$PLATFORM_QWS" != "yes" -a "$PLATFORM_QPA" != "yes" ]; then
|
||||
[ "$CFG_GRAPHICS_SYSTEM" = "raster" ] && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_GRAPHICSSYSTEM_RASTER"
|
||||
@@ -8257,36 +8252,22 @@
|
||||
@@ -8419,36 +8413,22 @@
|
||||
# X11/Unix/Mac only configs
|
||||
[ "$CFG_ICONV" = "no" ] && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_ICONV"
|
||||
[ "$CFG_GLIB" != "yes" ] && QCONFIG_FLAGS="$QCONFIG_FLAGS QT_NO_GLIB"
|
||||
|
@ -1,7 +1,7 @@
|
||||
======================================================================
|
||||
|
||||
Qt 4 can be built with optional support for:
|
||||
- Common UNIX Printing System (CUPS)
|
||||
- Common UNIX Printing System (CUPS) (enabled by default)
|
||||
- Network Audio System (NAS)
|
||||
- Qt style that renders using GTK (QGTKSTYLE)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user