Update to 0.28.2.

Use USES=libtool.
This commit is contained in:
Koop Mast 2014-02-11 21:25:27 +00:00
parent 1f20bf271d
commit 58d91806e3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=343821
4 changed files with 23 additions and 26 deletions

View File

@ -3,8 +3,8 @@
# $MCom: ports/trunk/x11-toolkits/vte/Makefile 18940 2013-12-08 01:12:24Z kwm $
PORTNAME= vte
PORTVERSION= 0.26.2
PORTREVISION?= 5
PORTVERSION= 0.28.2
PORTREVISION?= 0
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@ -12,22 +12,24 @@ DIST_SUBDIR= gnome2
MAINTAINER?= gnome@FreeBSD.org
COMMENT?= Gtk 2 based terminal widget with accessibility and I18N support
USE_BZIP2= yes
USE_XZ= yes
.if !defined(REFERENCE_PORT)
RUN_DEPENDS+= ${LOCALBASE}/libexec/gnome-pty-helper:${PORTSDIR}/x11-toolkits/gnome-pty-helper
USES= bison gettext gmake pathfix pkgconfig
USES= bison gettext gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME?= gnomeprefix gtk20 introspection:build ltverhack referencehack
USE_GNOME?= gnomeprefix gtk20 introspection:build referencehack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
CONFIGURE_ARGS?=--disable-python \
--disable-Bsymbolic \
--disable-freetypetest \
--disable-static \
--with-gtk=2.0 \
--enable-introspection \
--disable-gnome-pty-helper
@ -47,9 +49,6 @@ CONFIGURE_ARGS+= --with-glX
USE_GL= yes
.endif
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libvte.so.9
.include <bsd.port.mk>
.endif

View File

@ -1,2 +1,2 @@
SHA256 (gnome2/vte-0.26.2.tar.bz2) = f02c350340266c9515a98b8f69c72b4bdc53b352cd053624a63a7cb97ddec9bd
SIZE (gnome2/vte-0.26.2.tar.bz2) = 1310863
SHA256 (gnome2/vte-0.28.2.tar.xz) = 86cf0b81aa023fa93ed415653d51c96767f20b2d7334c893caba71e42654b0ae
SIZE (gnome2/vte-0.28.2.tar.xz) = 962340

View File

@ -1,8 +1,8 @@
--- src/vte.c.orig 2010-11-13 06:18:41.000000000 -0600
+++ src/vte.c 2013-03-14 15:59:37.761401135 -0500
@@ -4914,16 +4914,23 @@
--- src/vte.c.orig 2011-08-28 23:31:45.000000000 +0200
+++ src/vte.c 2014-02-11 21:57:19.000000000 +0100
@@ -5164,19 +5164,23 @@
vte_terminal_read_modifiers (VteTerminal *terminal,
GdkEvent *event)
GdkEvent *event)
{
+ GdkKeymap *keymap;
GdkModifierType modifiers;
@ -10,16 +10,19 @@
/* Read the modifiers. */
- if (gdk_event_get_state((GdkEvent*)event, &modifiers)) {
- GdkKeymap *keymap;
- keymap = gdk_keymap_get_for_display (
- gdk_drawable_get_display (((GdkEventAny *)event)->window));
- gdk_keymap_add_virtual_modifiers (keymap, &modifiers);
-#if GTK_CHECK_VERSION (2, 90, 8)
- keymap = gdk_keymap_get_for_display(gdk_window_get_display(((GdkEventAny*)event)->window));
-#else
- keymap = gdk_keymap_get_for_display(gdk_drawable_get_display(((GdkEventAny*)event)->window));
-#endif
- gdk_keymap_add_virtual_modifiers (keymap, &modifiers);
- terminal->pvt->modifiers = modifiers;
- }
+ if (!gdk_event_get_state((GdkEvent*)event, &modifiers))
+ return;
+
+ keymap = gdk_keymap_get_for_display (
+ gdk_window_get_display (((GdkEventAny*)event)->window));
+ gdk_window_get_display (((GdkEventAny*)event)->window));
+
+ gdk_keymap_add_virtual_modifiers (keymap, &modifiers);
+

View File

@ -11,11 +11,7 @@ lib/girepository-1.0/Vte-0.0.typelib
lib/libvte.la
lib/libvte.so
lib/libvte.so.9
lib/vte-0.0/decset
lib/vte-0.0/interpret
lib/vte-0.0/osc
lib/vte-0.0/slowcat
lib/vte-0.0/window
lib/libvte.so.9.2800.2
libdata/pkgconfig/vte.pc
share/gir-1.0/Vte-0.0.gir
share/locale/am/LC_MESSAGES/vte-0.0.mo
@ -107,10 +103,9 @@ share/locale/xh/LC_MESSAGES/vte-0.0.mo
share/locale/zh_CN/LC_MESSAGES/vte-0.0.mo
share/locale/zh_HK/LC_MESSAGES/vte-0.0.mo
share/locale/zh_TW/LC_MESSAGES/vte-0.0.mo
%%DATADIR%%/termcap/xterm
@dirrm %%DATADIR%%/termcap
%%DATADIR%%/termcap-0.0/xterm
@dirrm %%DATADIR%%/termcap-0.0
@dirrm %%DATADIR%%
@dirrm lib/vte-0.0
@dirrm include/vte-0.0/vte
@dirrm include/vte-0.0
@dirrmtry share/locale/zh_HK/LC_MESSAGES