o New port for a GKrellM plugin that display updated info on several

game servers
o Port version 0.3pre5 (0.3.p5)

Submitted by:	Patrick Li <pat@databits.net>
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2001-07-03 00:10:17 +00:00
parent 9ce245f00e
commit 58b5f09377
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44666
8 changed files with 96 additions and 0 deletions

View File

@ -110,6 +110,7 @@
SUBDIR += ghtool
SUBDIR += gicq
SUBDIR += gkrellm_snmp
SUBDIR += gkrellmqst
SUBDIR += gnet
SUBDIR += gnomba
SUBDIR += gnome-vnc

35
net/gkrellmqst/Makefile Normal file
View File

@ -0,0 +1,35 @@
# New ports collection makefile for: gkrellmqst
# Date Created: Thu Jun 28 01:54:57 EDT 2001
# Whom: Patrick Li <pat@databits.net>
# With help from: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gkrellmqst
PORTVERSION= 0.3.p5
CATEGORIES= net games
MASTER_SITES= http://tadpol.org/unxware/
DISTNAME= gkrellm_qst-${PORTVERSION:S/.p/pre_/}
MAINTAINER= pat@databits.net
BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm \
qstat:${PORTSDIR}/games/qstat
WRKSRC= ${WRKDIR}/${PORTNAME:S/mq/m_q/}
USE_X_PREFIX= yes
USE_IMLIB= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
ALL_TARGET= qst.so
EXTRA_PATCHES= ${WRKDIR}/patch-qst.c
pre-patch:
@${SED} -e "s!%%LOCALBASE%%!${LOCALBASE}!" \
-e "s!%%X11BASE%%!${X11BASE}!" \
${FILESDIR}/template-patch-qst.c > \
${WRKDIR}/patch-qst.c
.include <bsd.port.mk>

1
net/gkrellmqst/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (gkrellm_qst-0.3pre_5.tar.gz) = f4fcca5a1101ab778b854f7fb8fe2543

View File

@ -0,0 +1,32 @@
--- Makefile.orig Thu Jun 28 02:19:33 2001
+++ Makefile Thu Jun 28 02:23:38 2001
@@ -1,17 +1,16 @@
-GTK_INCLUDE = `gtk-config --cflags`
-GTK_LIB = `gtk-config --libs`
+GTK_INCLUDE = `$(GTK_CONFIG) --cflags`
+GTK_LIB = `$(GTK_CONFIG) --libs`
IMLIB_INCLUDE = `imlib-config --cflags-gdk`
IMLIB_LIB = `imlib-config --libs-gdk`
-THREAD_LIB = -lpthread
-INSTALLDIR = $(HOME)/.gkrellm/plugins
+INSTALLDIR = $(PREFIX)/libexec/gkrellm/plugins
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE)
-LIBS = $(GTK_LIB) $(IMLIB_LIB) $(THREAD_LIB)
+FLAGS = -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) ${PTHREAD_CFLAGS}
+LIBS = $(GTK_LIB) $(IMLIB_LIB) ${PTHREAD_LIBS}
LFLAGS = -shared
-CC = gcc $(CFLAGS) $(FLAGS)
+CC += $(CFLAGS) $(FLAGS)
OBJS = qst.o
@@ -26,4 +25,4 @@
# %.o: %.c
install: qst.so
- install -c -s -m 644 qst.so $(INSTALLDIR)
+ $(BSD_INSTALL_DATA) qst.so $(INSTALLDIR)

View File

@ -0,0 +1,15 @@
--- qst.c.orig Mon Jul 2 16:19:55 2001
+++ qst.c Mon Jul 2 16:23:26 2001
@@ -25,9 +25,9 @@
/* some defines*/
#define MAX_MAP_NAME_LEN 64
#define NEW_MAP "Have not talked with quake server yet"
-#define QCMD "/usr/bin/quakestat -q3s quake | awk '/^quake/ {print $2 $3;}'"
-#define SCMD "xterm -e quake3 +connect quake &"
-#define TTCMD "/usr/bin/quakestat -P -q3s quake | awk '/frags/'"
+#define QCMD "%%LOCALBASE%%/bin/quakestat -q3s quake | awk '/^quake/ {print $2 $3;}'"
+#define SCMD "%%X11BASE%%/bin/xterm -e quake3 +connect quake &"
+#define TTCMD "%%LOCALBASE%%/bin/quakestat -P -q3s quake | awk '/frags/'"
#define CHCMD "ps ax|grep flxwm|grep -v grep>/dev/null && echo \"We've got quake!\""
static Panel *panel;

View File

@ -0,0 +1 @@
Plugin for Gkrellm that displays updated info on several game servers

10
net/gkrellmqst/pkg-descr Normal file
View File

@ -0,0 +1,10 @@
gkrellmqst is a plugin for Gkrellm that displays information on
several of your favorite game servers. The games that it can support
depends upon qstat's support for that particular game. This plugin
uses qstat to query a game server and displays the current map name
and number of players
WWW: http://tadpol.org/unxware/
Author: Michael Tilstra <tadpol@tadpol.org>
- Patrick Li <pat@databits.net>

1
net/gkrellmqst/pkg-plist Normal file
View File

@ -0,0 +1 @@
libexec/gkrellm/plugins/qst.so