Initial import of topaz version 3.22.

A command driven graph plotting system for scientists and engineers.

PR:		13149
Submitted by:	Issei Suzuki <issei@jp.FreeBSD.ORG>
This commit is contained in:
Steve Price 1999-11-01 02:27:11 +00:00
parent 352ace81c6
commit 58861acc87
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22794
7 changed files with 180 additions and 0 deletions

28
math/topaz/Makefile Normal file
View File

@ -0,0 +1,28 @@
# New ports collection makefile for: topaz
# Version required: 3.22
# Date created: 29 July 1997
# Whom: Issei Suzuki <issei@jp.FreeBSD.ORG>
#
# $FreeBSD$
#
DISTNAME= topaz-3_22-src
PKGNAME= topaz-3.22
CATEGORIES= math
MASTER_SITES= http://hp.vector.co.jp/authors/VA007663/topaz/bin/
MAINTAINER= issei@jp.FreeBSD.ORG
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
ncurses.4:${PORTSDIR}/devel/ncurses
CXX?= c++
MAKEFILE= Makefile.freebsd
USE_XLIB= yes
WRKSRC= ${WRKDIR}/${PKGNAME}
#TOPAZDIR= ${PREFIX}/libexec/topaz
post-install:
${LN} -sf ${PREFIX}/lib/topaz/topaz.sh ${PREFIX}/bin/topaz
.include <bsd.port.mk>

1
math/topaz/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (topaz-3_22-src.tar.gz) = 52628fe00c49ed53ad66d927e3ecaaf2

23
math/topaz/files/patch-aa Normal file
View File

@ -0,0 +1,23 @@
--- topaz/Makefile.freebsd.orig Tue Oct 26 20:29:25 1999
+++ topaz/Makefile.freebsd Sat Oct 30 16:22:05 1999
@@ -2,16 +2,16 @@
clean: cleantopaz cleanview cleanps
# compiler
-CXX=g++
+CXX?=g++
# Where are include files kept
INCLUDE=.
# for FreeBSD
-CFLAGS= -I/usr/local/include -I/usr/local/include/ncurses -I/usr/X11R6/include -O2 -Wall -DTOPAZLINUX -DTOPAZ_NCURSES -DTOPAZ_EUC
-TOPAZLIB= -L/usr/local/lib -lm -lncurses -lgnugetopt
+CFLAGS+= -I$(PREFIX)/include -I$(PREFIX)/include/ncurses -I$(X11BASE)/include -O2 -Wall -DTOPAZLINUX -DTOPAZ_NCURSES -DTOPAZ_EUC
+TOPAZLIB= -L$(PREFIX)/lib -lm -lncurses -lgnugetopt
PSLIB= -lm
-VIEWLIB= -lm -L/usr/X11R6/lib -lX11
+VIEWLIB= -lm -L$(X11BASE)/lib -lX11
# obj
OBJ=topaz.o plobj.o graph.o axis.o frame.o frame2.o valbuff.o script.o funcs.o\

73
math/topaz/files/patch-ab Normal file
View File

@ -0,0 +1,73 @@
--- Makefile.freebsd.orig Tue Oct 26 20:29:25 1999
+++ Makefile.freebsd Sat Oct 30 16:51:41 1999
@@ -1,50 +1,28 @@
-INSTALLDIR=/usr/local/lib/topaz
+INSTALLDIR=$(PREFIX)/lib/topaz
###############################################
# do not change following lines
all:
- cd ./topaz; make -f Makefile.freebsd; cd ..
+ cd ./topaz; ${MAKE} -f Makefile.freebsd; cd ..
.PHONY: clean
clean:
- cd ./topaz; make -f Makefile.freebsd clean; cd ..
+ cd ./topaz; ${MAKE} -f Makefile.freebsd clean; cd ..
.PHONY: install
install:
-#checking $(INSTALLDIR)
- @if test ! -d $(INSTALLDIR) \
- ; then \
- echo "install directory does not exist!!"; \
- exit 1 \
- ; fi
- strip ./topaz/topaz
- strip ./topaz/tpv2ps
- strip ./topaz/tpvview
- cp ./topaz.sh $(INSTALLDIR)
- cp ./head.ps $(INSTALLDIR)
- cp ./HISTORY $(INSTALLDIR)
- cp ./LICENSE $(INSTALLDIR)
- cp ./README.euc $(INSTALLDIR)/README
- cp ./INSTALL.euc $(INSTALLDIR)/INSTALL
- cp ./topaz/topaz $(INSTALLDIR)
- cp ./topaz/tpv2ps $(INSTALLDIR)
- cp ./topaz/tpvview $(INSTALLDIR)
- chmod 755 $(INSTALLDIR)/topaz.sh
- chmod 755 $(INSTALLDIR)/topaz
- chmod 755 $(INSTALLDIR)/tpv2ps
- chmod 755 $(INSTALLDIR)/tpvview
-#checking $(INSTALLDIR)/_topaz
- @if test ! -d $(INSTALLDIR)/_topaz \
- ; then \
- mkdir $(INSTALLDIR)/_topaz \
- ; fi
- cp ./_topaz/* $(INSTALLDIR)/_topaz
- cp ./cuirc.lnx $(INSTALLDIR)/_topaz/cui.rc
- cp ./topazfontmap $(INSTALLDIR)/_topaz
- cp ./topazkfontmap $(INSTALLDIR)/_topaz
- chmod 755 $(INSTALLDIR)/_topaz/*
-#checking $(INSTALLDIR)/sample
- @if test ! -d $(INSTALLDIR)/sample \
- ; then \
- mkdir $(INSTALLDIR)/sample \
- ; fi
- cp ./sample/* $(INSTALLDIR)/sample
-
+ -mkdir -p $(INSTALLDIR)
+ $(BSD_INSTALL_SCRIPT) ./topaz.sh $(INSTALLDIR)
+ $(BSD_INSTALL_DATA) ./head.ps $(INSTALLDIR)
+ $(BSD_INSTALL_DATA) ./HISTORY $(INSTALLDIR)
+ $(BSD_INSTALL_DATA) ./LICENSE $(INSTALLDIR)
+ $(BSD_INSTALL_DATA) ./README.euc $(INSTALLDIR)/README
+ $(BSD_INSTALL_DATA) ./INSTALL.euc $(INSTALLDIR)/INSTALL
+ $(BSD_INSTALL_PROGRAM) ./topaz/topaz $(INSTALLDIR)
+ $(BSD_INSTALL_PROGRAM) ./topaz/tpv2ps $(INSTALLDIR)
+ $(BSD_INSTALL_PROGRAM) ./topaz/tpvview $(INSTALLDIR)
+ -mkdir -p $(INSTALLDIR)/_topaz
+ $(BSD_INSTALL_SCRIPT) ./_topaz/* $(INSTALLDIR)/_topaz
+ $(BSD_INSTALL_DATA) ./cuirc.lnx $(INSTALLDIR)/_topaz/cui.rc
+ $(BSD_INSTALL_DATA) ./topazfontmap $(INSTALLDIR)/_topaz
+ $(BSD_INSTALL_DATA) ./topazkfontmap $(INSTALLDIR)/_topaz
+ -mkdir -p $(PREFIX)/share/examples/topaz
+ cp ./sample/* $(PREFIX)/share/examples/topaz

1
math/topaz/pkg-comment Normal file
View File

@ -0,0 +1 @@
A command driven graph plotting system for scientists and engineers

15
math/topaz/pkg-descr Normal file
View File

@ -0,0 +1,15 @@
Topaz is a graph plotting system for scientists and engineers.
1. Topaz has a powerful graph expression and functions such as least square
method. Topaz provides almost all functions that you need to make
a 2D scattering graph.
2. Topaz has a polished character based user interface.
3. Topaz has powerful macro language of "Topaz script", which is like
Perl. You can expand topaz itself or you can perform batch jobs using
topaz scripts.
Topaz official Web Page.
WWW: http://hp.vector.co.jp/authors/VA007663/topaz/

39
math/topaz/pkg-plist Normal file
View File

@ -0,0 +1,39 @@
bin/topaz
lib/topaz/HISTORY
lib/topaz/INSTALL
lib/topaz/LICENSE
lib/topaz/README
lib/topaz/_topaz/2eps
lib/topaz/_topaz/2ps
lib/topaz/_topaz/2tpv
lib/topaz/_topaz/README
lib/topaz/_topaz/cui.rc
lib/topaz/_topaz/d
lib/topaz/_topaz/g
lib/topaz/_topaz/initaxisx
lib/topaz/_topaz/initaxisy
lib/topaz/_topaz/initdata
lib/topaz/_topaz/initframe
lib/topaz/_topaz/initparams
lib/topaz/_topaz/initparts
lib/topaz/_topaz/inittopaz
lib/topaz/_topaz/opencui
lib/topaz/_topaz/p
lib/topaz/_topaz/topazfontmap
lib/topaz/_topaz/topazkfontmap
lib/topaz/_topaz/updatehistory
lib/topaz/head.ps
lib/topaz/topaz
lib/topaz/topaz.sh
lib/topaz/tpv2ps
lib/topaz/tpvview
share/examples/topaz/fit.tpz
share/examples/topaz/parts.tpz
share/examples/topaz/sample.txt
share/examples/topaz/stdfontset.tpz
share/examples/topaz/step.tpz
share/examples/topaz/symbolfontset.tpz
share/examples/topaz/text.tpz
@dirrm lib/topaz/_topaz
@dirrm lib/topaz
@dirrm share/examples/topaz