fix build on -current by upgrading to 0.3.2

This commit is contained in:
Ying-Chieh Liao 2002-12-03 07:15:21 +00:00
parent dad821b043
commit 58673b5198
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71349
6 changed files with 128 additions and 48 deletions

View File

@ -7,7 +7,7 @@
#
PORTNAME= rascal
PORTVERSION= 0.3.1
PORTVERSION= 0.3.2
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -18,25 +18,33 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_REINPLACE= yes
USE_BISON= yes
USE_GNOME= yes
#USE_GNOME= yes
WRKSRC= ${WRKDIR}/Rascal-${PORTVERSION}
USE_GMAKE= yes
ALL_TARGET= rascal grascal
#ALL_TARGET= rascal grascal
MANCOMPRESSED= yes
MAN1= rascal.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
BROKEN= "Does not compile"
.endif
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
s,g\+\+,${CXX},g ; \
s,doc/,share/doc/,g ; \
s,gnome-config,${GNOME_CONFIG},g ; \
s,CC,CXX,g" ${WRKSRC}/Makefile
.for file in hoc.y rascal.1
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${file}
.endfor
.include <bsd.port.post.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rascal ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/rascal.rc ${PREFIX}/etc
${INSTALL_MAN} ${WRKSRC}/rascal.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/html
.for file in rascal.ps rascal.pdf CHANGES TEST TOOLBOXTEST
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
${INSTALL_DATA} ${WRKSRC}/rascal_html/* ${DOCSDIR}/html
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (rascal-0.3.1.tar.gz) = 569ff6269f68e1bf29bfe5a3c28ef1ee
MD5 (rascal-0.3.2.tar.gz) = 2ac111ac6fdbe9de3496da2e48d58ae1

View File

@ -1,20 +1,28 @@
--- Makefile.orig Thu Jun 28 02:07:37 2001
+++ Makefile Thu Jun 28 02:11:27 2001
@@ -21,4 +21,3 @@
--- Makefile.orig Mon Dec 2 11:51:54 2002
+++ Makefile Mon Dec 2 11:53:24 2002
@@ -19,8 +19,7 @@
VERSION=0.3.2
-CC=g++
-CFLAGS=-O0 -g -DVERSION=\"$(VERSION)\"
-CFLAGS=-O0 -fno-rtti -g -DVERSION=\"$(VERSION)\"
+CFLAGS+=-DVERSION=\"$(VERSION)\" -I%%LOCALBASE%%/include
# With the following options you may generate an optimized version of
@@ -38,3 +37,3 @@
# Rascal, but you will need a lot of time (takes 20min, that is 15*
# longer, on my machine) and physical memory (256 MB physical memory
@@ -38,10 +37,14 @@
RMDIR=rm -rf
INSTDIR=install -d
-LIBS=-lm -lreadline -lcurses
+LIBS=-lm -lreadline -lcurses -L%%LOCALBASE%%/lib -lgnugetopt
OBJS=y.tab.o lex.yy.o symtab.o value.o
@@ -42,2 +41,6 @@
-include value.mak
+
+.SUFFIXES: .o .c
+
+.c.o: ; ${CXX} ${CFLAGS} -c $*.c
all: rascal

View File

@ -1,6 +1,6 @@
--- hoc.y.orig Thu Jun 20 10:22:54 2002
+++ hoc.y Thu Jun 20 10:35:33 2002
@@ -36,6 +36,10 @@
--- hoc.y.orig Tue May 14 06:09:26 2002
+++ hoc.y Tue Dec 3 14:45:21 2002
@@ -38,6 +38,11 @@
#include <math.h>
#include <stdlib.h>
#include <string.h>
@ -8,31 +8,25 @@
+extern "C" {
+#include <getopt.h>
+}
+
int precis=8;
void * set_string_input(char *);
@@ -197,17 +201,17 @@
;
PARSERexpr:
PARSERexpr PARSERwhite { $$ = $1; }
- | PARSERfunction { $$ = new value($1) }
- | PARSERfunction2 { $$ = new value($1) }
- | PARSERat PARSERprocedure { $$ = new value($2) }
- | PARSERuserfunction { $$ = new value($1) }
- | PARSERat PARSERvariable { $$ = new value($2) }
+ | PARSERfunction { $$ = new value($1); }
+ | PARSERfunction2 { $$ = new value($1); }
+ | PARSERat PARSERprocedure { $$ = new value($2); }
+ | PARSERuserfunction { $$ = new value($1); }
+ | PARSERat PARSERvariable { $$ = new value($2); }
| PARSERlbracket PARSERexprlist PARSERrbracket { $$=new value(bracket(cell(($2)->asMATRIX(),1),cell(($2)->asMATRIX(),2))); delete $2; }
| PARSERwhite PARSERexpr %prec PARSERbecomes { $$ = $2; }
| PARSERnumber { $$ = $1; }
| PARSERvariable { $$ = new value($1->var); }
- | PARSERvariable PARSERplusplus { $1->var=$1->var+1; $$ = new value($1->var) }
- | PARSERvariable PARSERminusminus { $1->var=$1->var-1; $$ = new value($1->var) }
+ | PARSERvariable PARSERplusplus { $1->var=$1->var+1; $$ = new value($1->var); }
+ | PARSERvariable PARSERminusminus { $1->var=$1->var-1; $$ = new value($1->var); }
| PARSERvariable PARSERbecomes PARSERexpr { $$ = $3; $1->var=*($3);}
| PARSERprocedure { $$=new value( (*($1->ivalue.procptr))() ); }
| PARSERexpr PARSERlbracket PARSERmatrix PARSERrbracket
@@ -517,7 +522,7 @@
cout << " The content of given files and expressions will be treated as user input" << endl;
cout << " in the order rc-file, given files, expressions." << endl;
cout << endl;
- cout << " The rc-file is searched in /etc/rascal.rc, /usr/local/bin/rascal.rc, rascal.rc" << endl;
+ cout << " The rc-file is searched in %%PREFIX%%/etc/rascal.rc, rascal.rc" << endl;
return 0;
case 'n':
norc=1;
@@ -556,7 +561,7 @@
}
if(norc==0)
- if(load("/etc/rascal.rc") && load("/usr/local/bin/rascal.rc") && load("rascal.rc"))
+ if(load("%%PREFIX%%/etc/rascal.rc") && load("rascal.rc"))
; // no rcfile found
if(doeval!="")

View File

@ -0,0 +1,70 @@
--- rascal.1.orig Tue May 14 06:09:26 2002
+++ rascal.1 Tue Dec 3 14:58:09 2002
@@ -64,7 +64,7 @@
For more information read the extensive user documentation:
.B gv
-.I /usr/local/doc/rascal/rascal.ps
+.I %%PREFIX%%/share/doc/rascal/rascal.ps
.SH EXAMPLE SESSIONS
@@ -114,10 +114,7 @@
[-4 2;3 -1]
.SH FILES
-.I /etc/rascal.rc
-.RS
-.RE
-.I /usr/local/bin/rascal.rc
+.I %%PREFIX%%/etc/rascal.rc
.RS
.RE
.I ./rascal.rc
@@ -126,30 +123,30 @@
i)
.RE
.P
-.I /usr/local/doc/rascal/rascal.ps
+.I %%PREFIX%%/share/doc/rascal/rascal.ps
.RS
.RE
-.I /usr/local/doc/rascal/rascal.pdf
+.I %%PREFIX%%/share/doc/rascal/rascal.pdf
.RS
.RE
-.I /usr/local/doc/rascal/rascal/rascal.html
+.I %%PREFIX%%/share/doc/rascal/html/rascal.html
.RS
User documentation, to view it invoke
.RS
.RE
.B gv
-.I /usr/local/doc/rascal/rascal.ps
+.I %%PREFIX%%/share/doc/rascal/rascal.ps
.RE
.P
-.I /usr/local/doc/rascal/TEST
+.I %%PREFIX%%/share/doc/rascal/TEST
.RS
Test suite, to test Rascal invoke
.RS
.RE
-.BI "rascal " "/usr/local/doc/rascal/TEST"
+.BI "rascal " "%%PREFIX%%/share/doc/rascal/TEST"
.RE
.P
-.I /usr/local/doc/rascal/CHANGES
+.I %%PREFIX%%/share/doc/rascal/CHANGES
.RS
Changelog
@@ -169,7 +166,7 @@
.I "http://rascal.sourceforge.net/"
and attach the output of the test
.RE
-.BI "rascal " "/usr/local/doc/rascal/TEST"
+.BI "rascal " "%%PREFIX%%/share/doc/rascal/TEST"
.SH AUTHOR
Sebastian Ritterbusch <rascal@ritterbusch.de>

View File

@ -1,10 +1,10 @@
bin/rascal
bin/rascal.rc
bin/grascal
etc/rascal.rc
share/doc/rascal/rascal.pdf
share/doc/rascal/rascal.ps
share/doc/rascal/CHANGES
share/doc/rascal/TEST
share/doc/rascal/TOOLBOXTEST
share/doc/rascal/html/img1.gif
share/doc/rascal/html/img2.gif
share/doc/rascal/html/img3.gif