Make rudiments compile on CURRENT again.

Reported by:	linimon
This commit is contained in:
Ed Schouten 2009-03-02 12:55:35 +00:00
parent fe8379f9e9
commit 585cf1f7fa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=229325
2 changed files with 19 additions and 7 deletions

View File

@ -24,10 +24,4 @@ CONFIGURE_ARGS= --with-ssl-includes=-I${OPENSSLINC} \
--disable-pcre
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 800045
BROKEN= does not build
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,18 @@
--- include/rudiments/serialportprofile.h
+++ include/rudiments/serialportprofile.h
@@ -129,9 +129,15 @@
#ifdef TABDLY
enum tabdelay_t {
+ #ifdef TAB0
td_none=TAB0,
+ #endif
+ #ifdef TAB1
td_depends=TAB1,
+ #endif
+ #ifdef TAB2
td_100=TAB2
+ #endif
};
#endif