math/dune-grid-glue: New port: DUNE framework: infrastructure for coupling of unrelated Dune grids

This commit is contained in:
Yuri Victorovich 2021-09-07 09:04:24 -07:00
parent 54918b08b0
commit 5801d31602
6 changed files with 111 additions and 0 deletions

View File

@ -247,6 +247,7 @@
SUBDIR += dune-functions
SUBDIR += dune-geometry
SUBDIR += dune-grid
SUBDIR += dune-grid-glue
SUBDIR += dune-istl
SUBDIR += dune-localfunctions
SUBDIR += dune-metagrid

View File

@ -0,0 +1,44 @@
PORTNAME= dune-grid-glue
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.0.20201113
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
COMMENT= DUNE framework: infrastructure for coupling of unrelated Dune grids
LICENSE= GPLv2
BUILD_DEPENDS= alberta-fem>0:math/alberta \
openmpi>0:net/openmpi \
psurface>0:math/psurface \
vc>0:devel/vc
LIB_DEPENDS= libdunecommon.so:math/dune-common \
libdunegeometry.so:math/dune-geometry \
libdunegrid.so:math/dune-grid \
libduneuggrid.so:math/dune-uggrid \
libopenblas.so:math/openblas \
libtbb.so:devel/onetbb
RUN_DEPENDS= alberta-fem>0:math/alberta # binaries aren't linked with alberta, instead users' binaries are linked with it
RUN_DEPENDS+= psurface>0:math/psurface
USES= cmake compiler:c++17-lang fortran pkgconfig
USE_GITLAB= yes
USE_LDCONFIG= yes
GL_SITE= https://gitlab.dune-project.org
GL_ACCOUNT= extensions
GL_COMMIT= 17bd9898df80a52e2c316fc053119d190c149a2e
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_ARGS= -DTBB_INCLUDE_DIR=${LOCALBASE}/include -DTBB_LIBRARIES=${LOCALBASE}/lib/libtbb.so
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
sphinx-build:textproc/py-sphinx
PORTDOCS= *
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1630995135
SHA256 (extensions-dune-grid-glue-17bd9898df80a52e2c316fc053119d190c149a2e_GL0.tar.gz) = f95c961e378fe9a23476ea52910190cfc365f8eb355b6515825a388260bafe40
SIZE (extensions-dune-grid-glue-17bd9898df80a52e2c316fc053119d190c149a2e_GL0.tar.gz) = 82251

View File

@ -0,0 +1,12 @@
--- CMakeLists.txt.orig 2021-09-07 15:43:33 UTC
+++ CMakeLists.txt
@@ -22,7 +22,9 @@ dune_register_package_flags(LIBRARIES dunegridglue)
add_subdirectory("dune")
add_subdirectory("doc")
+if (FREEBSD_BUILD_EXAMPLES)
add_subdirectory("examples")
+endif()
# finalize the dune project, e.g. generating config.h etc.
finalize_dune_project(GENERATE_CONFIG_H_CMAKE)

View File

@ -0,0 +1,11 @@
The dune-grid-glue module provides infrastructure for the coupling of two
unrelated Dune grids. The coupling may be overlapping or nonoverlapping,
conforming or nonconforming. The two grids are not requested to be of the same
type, and they may even be of different dimensions.
Couplings are described as sets of remote intersections. Conceptually, these
remote intersections are very close to what the regular intersections in the
Dune grid interface are, with the difference that the inside and outside
entities are taken from different grids.
WWW: https://www.dune-project.org/

View File

@ -0,0 +1,40 @@
include/dune/grid-glue/adapter/gridglue.cc
include/dune/grid-glue/adapter/gridglue.hh
include/dune/grid-glue/adapter/gridglueamirawriter.hh
include/dune/grid-glue/adapter/gridgluecommunicate.hh
include/dune/grid-glue/adapter/gridgluevtkwriter.hh
include/dune/grid-glue/adapter/intersection.hh
include/dune/grid-glue/adapter/intersectionindexset.hh
include/dune/grid-glue/adapter/intersectioniterator.hh
include/dune/grid-glue/adapter/rangegenerators.hh
include/dune/grid-glue/common/areawriter.hh
include/dune/grid-glue/common/areawriter_impl.hh
include/dune/grid-glue/common/crossproduct.hh
include/dune/grid-glue/common/projection.hh
include/dune/grid-glue/common/projection_impl.hh
include/dune/grid-glue/common/projectionwriter.hh
include/dune/grid-glue/common/projectionwriter_impl.hh
include/dune/grid-glue/extractors/codim0extractor.hh
include/dune/grid-glue/extractors/codim1extractor.hh
include/dune/grid-glue/extractors/extractor.hh
include/dune/grid-glue/extractors/vtksurfacewriter.hh
include/dune/grid-glue/gridglue.hh
include/dune/grid-glue/merging/computeintersection.cc
include/dune/grid-glue/merging/computeintersection.hh
include/dune/grid-glue/merging/conformingmerge.hh
include/dune/grid-glue/merging/contactmerge.cc
include/dune/grid-glue/merging/contactmerge.hh
include/dune/grid-glue/merging/intersectionlist.hh
include/dune/grid-glue/merging/merger.hh
include/dune/grid-glue/merging/overlappingmerge.cc
include/dune/grid-glue/merging/overlappingmerge.hh
include/dune/grid-glue/merging/simplexintersection.cc
include/dune/grid-glue/merging/standardmerge.hh
lib/cmake/dune-grid-glue/dune-grid-glue-config-version.cmake
lib/cmake/dune-grid-glue/dune-grid-glue-config.cmake
lib/cmake/dune-grid-glue/dune-grid-glue-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/dune-grid-glue/dune-grid-glue-targets.cmake
lib/dunecontrol/dune-grid-glue/dune.module
lib/libdunegridglue.so
libdata/pkgconfig/dune-grid-glue.pc
%%DATADIR%%/config.h.cmake