Library to generate static code representation of the Public suffix list.

The public suffix list is a database of top level domain names. The database
allows an application to determine if if a domain name requires an additional
label to be valid.

The principle use in a web browser is to restrict supercookies being set
although it can also serve secondary purposes in the UI such as domain
highlighting.

WWW: http://www.netsurf-browser.org/
This commit is contained in:
Olivier Duchateau 2016-11-21 14:04:24 +00:00
parent 5166401e18
commit 57ffef978c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=426720
7 changed files with 71 additions and 0 deletions

View File

@ -90,6 +90,7 @@
SUBDIR += libdjbdns
SUBDIR += libidn
SUBDIR += libidn2
SUBDIR += libnspsl
SUBDIR += libpsl
SUBDIR += linux-c6-libasyncns
SUBDIR += linux-c7-libasyncns

29
dns/libnspsl/Makefile Normal file
View File

@ -0,0 +1,29 @@
# Created by: Olivier Duchateau
# $FreeBSD$
PORTNAME= libnspsl
PORTVERSION= 0.1.0
CATEGORIES= dns
MASTER_SITES= http://download.netsurf-browser.org/libs/releases/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= olivierd@FreeBSD.org
COMMENT= NetSurf public suffix list handling
LICENSE= MIT
BUILD_DEPENDS= netsurf-buildsystem>=1.5:devel/netsurf-buildsystem
USES= gmake
USE_LDCONFIG= yes
MAKE_ENV+= COMPONENT_TYPE="lib-shared"
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
PLIST_SUB+= VERSION=${PORTVERSION}
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnspsl.so*
.include <bsd.port.mk>

3
dns/libnspsl/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1479721220
SHA256 (libnspsl-0.1.0-src.tar.gz) = be9030bdffa4135e95861465201e43f18f2cbba24555952aed7fa59b99ce6e74
SIZE (libnspsl-0.1.0-src.tar.gz) = 299718

View File

@ -0,0 +1,13 @@
--- Makefile.orig 2016-11-19 10:09:21 UTC
+++ Makefile
@@ -44,8 +44,8 @@ include $(NSBUILD)/Makefile.top
# Extra installation rules
I := /$(INCLUDEDIR)
INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):include/nspsl.h
-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR)/pkgconfig:lib$(COMPONENT).pc.in
-INSTALL_ITEMS := $(INSTALL_ITEMS) /$(LIBDIR):$(OUTPUT)
+INSTALL_ITEMS := $(INSTALL_ITEMS) /libdata/pkgconfig:lib$(COMPONENT).pc.in
+INSTALL_ITEMS := $(INSTALL_ITEMS) /lib:$(OUTPUT)
# obtain public suffix list database from upstream
public_suffix_list.dat:

View File

@ -0,0 +1,10 @@
--- libnspsl.pc.in.orig 2016-11-19 10:09:21 UTC
+++ libnspsl.pc.in
@@ -1,6 +1,6 @@
prefix=PREFIX
exec_prefix=${prefix}
-libdir=${exec_prefix}/LIBDIR
+libdir=${exec_prefix}/lib
includedir=${prefix}/INCLUDEDIR
Name: libnspsl

10
dns/libnspsl/pkg-descr Normal file
View File

@ -0,0 +1,10 @@
Library to generate static code representation of the Public suffix list.
The public suffix list is a database of top level domain names. The database
allows an application to determine if if a domain name requires an additional
label to be valid.
The principle use in a web browser is to restrict supercookies being set
although it can also serve secondary purposes in the UI such as domain
highlighting.
WWW: http://www.netsurf-browser.org/

5
dns/libnspsl/pkg-plist Normal file
View File

@ -0,0 +1,5 @@
include/nspsl.h
lib/libnspsl.so
lib/libnspsl.so.0
lib/libnspsl.so.%%VERSION%%
libdata/pkgconfig/libnspsl.pc