Conditionalize libgnugetopt dependencies.
PR: ports/47744 Submitted by: Ports Fury
This commit is contained in:
parent
29e9340594
commit
57d5734108
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=74496
@ -18,27 +18,31 @@ EXTRACT_ONLY= wmpuzzle_${PORTVERSION}.orig${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib -lgnugetopt"
|
||||
USE_GMAKE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
||||
MAN6= wmpuzzle.6
|
||||
|
||||
BSDIMAGES= daemon.xpm
|
||||
|
||||
CPPFLAGS+= -I${X11BASE}/include
|
||||
LDFLAGS+= -L${X11BASE}/lib
|
||||
|
||||
.if !exists(/usr/include/getopt.h)
|
||||
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
.for i in ${BSDIMAGES}
|
||||
${CP} ${DISTDIR}/${DIST_SUBDIR}/$i ${WRKSRC}/
|
||||
${CP} ${DISTDIR}/${DIST_SUBDIR}/${i} ${WRKSRC}/
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wmpuzzle ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/wmpuzzle.6 ${PREFIX}/man/man6
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
27
games/wmpuzzle/files/patch-Makefile.in
Normal file
27
games/wmpuzzle/files/patch-Makefile.in
Normal file
@ -0,0 +1,27 @@
|
||||
--- Makefile.in.orig Tue Oct 22 04:56:02 2002
|
||||
+++ Makefile.in Fri Jan 24 03:36:00 2003
|
||||
@@ -8,10 +8,13 @@
|
||||
mandir = @mandir@
|
||||
|
||||
CC = @CC@
|
||||
+CPPFLAGS = @CPPFLAGS@
|
||||
CFLAGS = -I. -Wall @CFLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
||||
INSTALL = @INSTALL@
|
||||
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
+INSTALL_DATA = @INSTALL_DATA@
|
||||
LN_S = @LN_S@
|
||||
|
||||
all: wmpuzzle
|
||||
@@ -23,8 +26,8 @@
|
||||
wmgeneral.o: wmgeneral.c wmgeneral.h
|
||||
|
||||
install: wmpuzzle wmpuzzle.6
|
||||
- $(INSTALL) -D -s -m 755 wmpuzzle $(DESTDIR)$(bindir)/wmpuzzle
|
||||
- $(INSTALL) -D -m 644 wmpuzzle.6 $(DESTDIR)$(mandir)/man6/wmpuzzle.6
|
||||
+ $(INSTALL_PROGRAM) wmpuzzle $(DESTDIR)$(bindir)/wmpuzzle
|
||||
+ $(INSTALL_DATA) wmpuzzle.6 $(DESTDIR)$(mandir)/man6/wmpuzzle.6
|
||||
|
||||
uninstall:
|
||||
rm -f $(DESTDIR)$(bindir)/wmpuzzle
|
Loading…
Reference in New Issue
Block a user