Fix make -j

This commit is contained in:
Tilman Keskinoz 2009-03-25 12:35:49 +00:00
parent 127c2957dc
commit 578a084158
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=230958
3 changed files with 62 additions and 3 deletions

View File

@ -19,7 +19,6 @@ COMMENT= A compiler generator that combines the functionality of lex and yacc
WRKSRC= ${WRKDIR}
ALL_TARGET= all1
MAKE_ENV+= CRFRAMES=${WRKSRC}/frames
USE_GMAKE= yes
CFLAGS+= -I${WRKSRC}/cplus2
PLIST_SUB+= FRAMES=${CRFRAMES}
CRFRAMES?= ${PREFIX}/lib/cocor
@ -34,6 +33,10 @@ pre-patch:
${CHMOD} +x ${WRKSRC}/dos2unix.sh
cd ${WRKSRC} && ./dos2unix.sh unix.mk && ${MAKE} -f unix.mk dos2unix
post-patch:
${REINPLACE_CMD} -e "s,^MAKE,#MAKE," ${WRKSRC}/Makefile
${RM} ${WRKSRC}/taste/unix.mk.orig
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cocor ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/cocor.1 ${PREFIX}/man/man1

View File

@ -0,0 +1,29 @@
--- taste/unix.mk.orig 2009-03-25 13:30:16.000000000 +0100
+++ taste/unix.mk 2009-03-25 13:30:36.000000000 +0100
@@ -27,7 +27,7 @@
$(CC) $(CFLAGS) -otaste taste.o tl.o tc.o\
tastes.o tastep.o
-tastep.o: taste.atg
+tastep.o taste.o: taste.atg
$(COCOR) taste.atg
$(CC) $(CFLAGS) -c taste.c tastep.c tastes.c
@@ -35,7 +35,7 @@
$(CC) $(CFLAGS) -opretty pretty.o prettypr.o \
prettys.o prettyp.o
-prettyp.o: pretty.atg
+prettyp.o pretty.o: pretty.atg
$(COCOR) pretty.atg
$(CC) $(CFLAGS) -c pretty.c prettyp.c prettys.c
@@ -43,7 +43,7 @@
$(CC) $(CFLAGS) -oxref xref.o crossref.o \
xrefs.o xrefp.o
-xrefp.o: xref.atg
+xrefp.o xref.o: xref.atg
$(COCOR) xref.atg
$(CC) $(CFLAGS) -c xref.c xrefp.c xrefs.c

View File

@ -1,5 +1,5 @@
--- taste_cp/unix.mk.orig Sat Jan 18 01:58:29 2003
+++ taste_cp/unix.mk Sat Jan 18 01:59:37 2003
--- taste_cp/unix.mk.orig 2009-03-25 13:31:23.000000000 +0100
+++ taste_cp/unix.mk 2009-03-25 13:33:00.000000000 +0100
@@ -8,17 +8,17 @@
#CC sets the name of the compiler to use (cc, gcc, etc)
@ -21,3 +21,30 @@
$(CC) -c $(CFLAGS) $< -o $@
all: taste pretty xref
@@ -38,7 +38,7 @@
$(CC) $(CFLAGS) -otaste taste.o tl.o tc.o\
tastes.o tastep.o $(LIB)
-tastep.o: taste.atg
+tastep.o taste.o: taste.atg
$(COCOR) taste.atg
$(CC) $(CFLAGS) -c taste.c?? tastep.c?? tastes.c??
@@ -46,7 +46,7 @@
$(CC) $(CFLAGS) -opretty pretty.o prettypr.o \
prettys.o prettyp.o $(LIB)
-prettyp.o: pretty.atg
+prettyp.o pretty.o: pretty.atg
$(COCOR) pretty.atg
$(CC) $(CFLAGS) -c pretty.c?? prettyp.c?? prettys.c??
@@ -54,7 +54,7 @@
$(CC) $(CFLAGS) -oxref xref.o crossref.o \
xrefs.o xrefp.o $(LIB)
-xrefp.o: xref.atg
+xrefp.o xref.o: xref.atg
$(COCOR) xref.atg
$(CC) $(CFLAGS) -c xref.c?? xrefp.c?? xrefs.c??