graphics/openorienteering-mapper: Update to 0.9.1
PR: 242472 Submitted by: Nikolay Korotkiy <sikmir@gmail.com> (maintainer)
This commit is contained in:
parent
d2ddb8e784
commit
5784e53247
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=519238
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= openorienteering-mapper
|
||||
PORTVERSION= 0.9.0
|
||||
PORTVERSION= 0.9.1
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= graphics geography
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1571822907
|
||||
SHA256 (OpenOrienteering-mapper-v0.9.0_GH0.tar.gz) = d545e6d798346a34eb37240d8ed6218039adef42b4edf9384ee34d8eff96cb59
|
||||
SIZE (OpenOrienteering-mapper-v0.9.0_GH0.tar.gz) = 9414101
|
||||
TIMESTAMP = 1575541772
|
||||
SHA256 (OpenOrienteering-mapper-v0.9.1_GH0.tar.gz) = 3e345d7883236b369e860f40b59687e686a96b0a65518bb3b0625659abf0d200
|
||||
SIZE (OpenOrienteering-mapper-v0.9.1_GH0.tar.gz) = 9634841
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- CMakeLists.txt.orig 2018-12-23 20:55:50 UTC
|
||||
--- CMakeLists.txt.orig 2019-12-05 06:33:57 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -73,6 +73,11 @@ option(Mapper_DEBUG_TRANSLATIONS "Debug missing transl
|
||||
@@ -66,6 +66,11 @@ option(Mapper_DEBUG_TRANSLATIONS "Debug missing transl
|
||||
# Used for some Linux distributions which do not provide the polyclipping lib.
|
||||
option(Mapper_BUILD_CLIPPER "Build the Clipper package from source" OFF)
|
||||
|
||||
@ -12,7 +12,7 @@
|
||||
option(Mapper_USE_GDAL "Use the GDAL library" ON)
|
||||
|
||||
if(CMAKE_BUILD_TYPE MATCHES Release|MinSizeRel|RelWithDebInfo)
|
||||
@@ -231,10 +236,20 @@ endif()
|
||||
@@ -247,10 +252,20 @@ endif()
|
||||
|
||||
# Subdirectories
|
||||
|
||||
@ -36,7 +36,7 @@
|
||||
add_subdirectory("3rd-party/qbezier")
|
||||
if(NOT ANDROID)
|
||||
add_subdirectory("3rd-party/qtsingleapplication")
|
||||
@@ -254,7 +269,7 @@ if(CMAKE_CROSSCOMPILING)
|
||||
@@ -271,7 +286,7 @@ if(CMAKE_CROSSCOMPILING)
|
||||
add_custom_target(TEST_WARNING ALL
|
||||
COMMENT "Crosscompiling, skipping all tests")
|
||||
add_dependencies(TEST_WARNING Mapper)
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- packaging/CMakeLists.txt.orig 2018-12-23 20:55:50 UTC
|
||||
--- packaging/CMakeLists.txt.orig 2019-12-05 06:33:57 UTC
|
||||
+++ packaging/CMakeLists.txt
|
||||
@@ -437,7 +437,7 @@ endforeach(_qt_plugin)
|
||||
@@ -426,7 +426,7 @@ endforeach(_qt_plugin)
|
||||
if(UNIX AND NOT APPLE AND NOT ANDROID)
|
||||
install(
|
||||
FILES "${PROJECT_SOURCE_DIR}/doc/man/Mapper.1"
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- packaging/custom_install.cmake.in.orig 2019-10-23 12:42:51.349480000 +0300
|
||||
+++ packaging/custom_install.cmake.in 2019-10-23 12:42:57.488297000 +0300
|
||||
@@ -122,4 +122,4 @@
|
||||
--- packaging/custom_install.cmake.in.orig 2019-12-05 06:33:57 UTC
|
||||
+++ packaging/custom_install.cmake.in
|
||||
@@ -122,4 +122,4 @@ endif()
|
||||
set(runtime "")
|
||||
set(dirs "@MAPPER_LIB_HINTS@")
|
||||
handle_qt_conf()
|
||||
|
@ -1,9 +1,11 @@
|
||||
--- src/CMakeLists.txt.orig 2018-12-23 20:55:50 UTC
|
||||
Add translation files only if the NLS knob is set
|
||||
|
||||
--- src/CMakeLists.txt.orig 2019-12-05 06:33:57 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -286,7 +286,9 @@ target_compile_definitions(Mapper_Common PRIVATE
|
||||
# MAPPER_ENABLE_COMPATIBILITY
|
||||
@@ -287,7 +287,9 @@ target_compile_definitions(Mapper_Common INTERFACE
|
||||
)
|
||||
|
||||
|
||||
-mapper_translations_sources(${Mapper_Common_SRCS} ${Mapper_Common_HEADERS})
|
||||
+if(Mapper_WITH_NLS)
|
||||
+ mapper_translations_sources(${Mapper_Common_SRCS} ${Mapper_Common_HEADERS})
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- src/gdal/CMakeLists.txt.orig 2018-12-23 20:55:50 UTC
|
||||
Add translation files only if the NLS knob is set
|
||||
|
||||
--- src/gdal/CMakeLists.txt.orig 2019-12-05 06:33:57 UTC
|
||||
+++ src/gdal/CMakeLists.txt
|
||||
@@ -35,7 +35,9 @@ set(MAPPER_GDAL_SOURCES
|
||||
@@ -36,7 +36,9 @@ set(MAPPER_GDAL_SOURCES
|
||||
mapper-osmconf.ini
|
||||
)
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/mapper_config.h.in.orig 2018-12-23 20:55:50 UTC
|
||||
--- src/mapper_config.h.in.orig 2019-12-05 06:33:57 UTC
|
||||
+++ src/mapper_config.h.in
|
||||
@@ -30,6 +30,7 @@
|
||||
@@ -32,6 +32,7 @@
|
||||
|
||||
#cmakedefine Mapper_DEBUG_TRANSLATIONS
|
||||
#cmakedefine Mapper_PACKAGE_NAME
|
||||
|
@ -1,8 +1,8 @@
|
||||
Add translation files only if the NLS knob is set
|
||||
|
||||
--- src/sensors/CMakeLists.txt.orig 2019-10-23 13:52:38.938027000 +0300
|
||||
+++ src/sensors/CMakeLists.txt 2019-10-23 13:53:09.513288000 +0300
|
||||
@@ -104,7 +104,9 @@
|
||||
--- src/sensors/CMakeLists.txt.orig 2019-12-05 06:33:57 UTC
|
||||
+++ src/sensors/CMakeLists.txt
|
||||
@@ -104,7 +104,9 @@ endforeach()
|
||||
|
||||
# Translations
|
||||
|
||||
|
@ -2,8 +2,8 @@ bin/Mapper
|
||||
man/man1/Mapper.1.gz
|
||||
share/applications/Mapper.desktop
|
||||
%%DOCSDIR%%/3rd-party/qtsingleapplication.txt
|
||||
%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/Mapper 0.9.0 Manual.qch
|
||||
%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/Mapper 0.9.0 Manual.qhc
|
||||
%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/Mapper 0.9.1 Manual.qch
|
||||
%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/Mapper 0.9.1 Manual.qhc
|
||||
%%DOCSDIR%%/common-licenses/GPL-3.txt
|
||||
%%DOCSDIR%%/licensing.html
|
||||
share/icons/hicolor/128x128/apps/Mapper.png
|
||||
@ -38,26 +38,27 @@ share/mime/packages/openorienteering-mapper.xml
|
||||
%%DATADIR%%/symbol sets/10000/Course_Design_10000.omap
|
||||
%%DATADIR%%/symbol sets/10000/ISMTBOM_10000.omap
|
||||
%%DATADIR%%/symbol sets/10000/ISOM 2017-2_10000.omap
|
||||
%%DATADIR%%/symbol sets/10000/ISOM2000_10000.omap
|
||||
%%DATADIR%%/symbol sets/10000/ISSkiOM_10000.omap
|
||||
%%DATADIR%%/symbol sets/10000/ISSkiOM 2019_10000.omap
|
||||
%%DATADIR%%/symbol sets/12500/ISSkiOM 2019_12500.omap
|
||||
%%DATADIR%%/symbol sets/15000/Course_Design_15000.omap
|
||||
%%DATADIR%%/symbol sets/15000/ISMTBOM_15000.omap
|
||||
%%DATADIR%%/symbol sets/15000/ISOM 2017-2_15000.omap
|
||||
%%DATADIR%%/symbol sets/15000/ISOM2000_15000.omap
|
||||
%%DATADIR%%/symbol sets/15000/ISSkiOM_15000.omap
|
||||
%%DATADIR%%/symbol sets/15000/ISSkiOM 2019_15000.omap
|
||||
%%DATADIR%%/symbol sets/20000/ISMTBOM_20000.omap
|
||||
%%DATADIR%%/symbol sets/4000/Course_Design_4000.omap
|
||||
%%DATADIR%%/symbol sets/4000/ISSOM_4000.omap
|
||||
%%DATADIR%%/symbol sets/5000/Course_Design_5000.omap
|
||||
%%DATADIR%%/symbol sets/5000/ISMTBOM_5000.omap
|
||||
%%DATADIR%%/symbol sets/5000/ISSOM_5000.omap
|
||||
%%DATADIR%%/symbol sets/5000/ISSkiOM_5000.omap
|
||||
%%DATADIR%%/symbol sets/5000/ISSkiOM 2019_5000.omap
|
||||
%%DATADIR%%/symbol sets/7500/ISMTBOM_7500.omap
|
||||
%%DATADIR%%/symbol sets/7500/ISSkiOM 2019_7500.omap
|
||||
%%DATADIR%%/symbol sets/ISOM 2017-2-ISSkiOM 2019.crt
|
||||
%%DATADIR%%/symbol sets/ISOM2000-ISOM 2017-2.crt
|
||||
%%DATADIR%%/symbol sets/ISOM2000-ISSOM.crt
|
||||
%%DATADIR%%/symbol sets/OSM-ISOM 2017-2.crt
|
||||
%%DATADIR%%/symbol sets/OSM-ISOM2000.crt
|
||||
%%DATADIR%%/symbol sets/OSM-ISSOM.crt
|
||||
%%DATADIR%%/symbol sets/OSM-ISSkiOM 2019.crt
|
||||
%%NLS%%%%DATADIR%%/translations/OpenOrienteering_cs.qm
|
||||
%%NLS%%%%DATADIR%%/translations/OpenOrienteering_da.qm
|
||||
%%NLS%%%%DATADIR%%/translations/OpenOrienteering_de.qm
|
||||
|
Loading…
Reference in New Issue
Block a user