Update unicorn and py-unicorn to 1.0.2-rc1

This commit is contained in:
Antoine Brodin 2020-01-18 20:02:00 +00:00
parent 6886cdd463
commit 57414c712e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=523495
8 changed files with 22 additions and 21 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= unicorn
PORTVERSION= 1.0.1
DISTVERSION= 1.0.2-rc1
CATEGORIES= emulators python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1492722479
SHA256 (unicorn-engine-unicorn-1.0.1_GH0.tar.gz) = 3a6a4f2b8c405ab009040ca43af8e4aa10ebe44d9c8b336aa36dc35df955017c
SIZE (unicorn-engine-unicorn-1.0.1_GH0.tar.gz) = 3241225
TIMESTAMP = 1579342823
SHA256 (unicorn-engine-unicorn-1.0.2-rc1_GH0.tar.gz) = d6d71e9854e53b5268792572656d87ccde8ff726e6f9343aab6da46089367983
SIZE (unicorn-engine-unicorn-1.0.2-rc1_GH0.tar.gz) = 3340182

View File

@ -1,8 +1,8 @@
# Do not bundle libunicorn.so
--- setup.py.orig 2017-04-20 06:14:24 UTC
--- setup.py.orig 2019-10-08 02:44:50 UTC
+++ setup.py
@@ -260,11 +260,4 @@ setup(
@@ -268,11 +268,4 @@ setup(
'Programming Language :: Python :: 3',
],
requires=['ctypes'],

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= unicorn
PORTVERSION= 1.0.1
PORTREVISION= 2
DISTVERSION= 1.0.2-rc1
CATEGORIES= emulators
MAINTAINER= antoine@FreeBSD.org
@ -21,10 +20,10 @@ BROKEN_mips64= fails to compile: 'ICACHE' undeclared (first use in this functio
USE_GITHUB= yes
GH_ACCOUNT= unicorn-engine
USES= compiler:c11 gmake python:2.7,build
USES= compiler:c11 gmake python:build
USE_LDCONFIG= yes
BINARY_ALIAS= python=${PYTHON_CMD}
MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
UNICORN_QEMU_FLAGS=--python=${PYTHON_CMD} \
SMP_MFLAGS=-j${MAKE_JOBS_NUMBER} \
V=1
TEST_TARGET= test

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1492722479
SHA256 (unicorn-engine-unicorn-1.0.1_GH0.tar.gz) = 3a6a4f2b8c405ab009040ca43af8e4aa10ebe44d9c8b336aa36dc35df955017c
SIZE (unicorn-engine-unicorn-1.0.1_GH0.tar.gz) = 3241225
TIMESTAMP = 1579342823
SHA256 (unicorn-engine-unicorn-1.0.2-rc1_GH0.tar.gz) = d6d71e9854e53b5268792572656d87ccde8ff726e6f9343aab6da46089367983
SIZE (unicorn-engine-unicorn-1.0.2-rc1_GH0.tar.gz) = 3340182

View File

@ -1,7 +1,7 @@
--- Makefile.orig 2017-04-20 06:14:24 UTC
--- Makefile.orig 2019-10-08 02:44:50 UTC
+++ Makefile
@@ -72,9 +72,9 @@ V ?= 0
MACOS_UNIVERSAL ?= yes
@@ -75,9 +75,9 @@ V ?= 0
MACOS_UNIVERSAL ?= no
ifeq ($(UNICORN_DEBUG),yes)
-CFLAGS += -g
@ -12,7 +12,7 @@
UNICORN_QEMU_FLAGS += --disable-debug-info
endif
@@ -181,7 +181,7 @@ LIBDIRARCH ?= lib
@@ -195,7 +195,7 @@ LIBDIRARCH ?= lib
# Or better, pass 'LIBDIRARCH=lib64' to 'make install/uninstall' via 'make.sh'.
#LIBDIRARCH ?= lib64

View File

@ -1,10 +1,11 @@
--- tests/unit/Makefile.orig 2017-04-20 06:14:24 UTC
--- tests/unit/Makefile.orig 2019-10-08 02:44:50 UTC
+++ tests/unit/Makefile
@@ -1,6 +1,6 @@
@@ -1,7 +1,7 @@
CFLAGS += -Wall -Werror -Wno-unused-function -g
CFLAGS += -D__USE_MINGW_ANSI_STDIO=1
CFLAGS += -L ../../ -I ../../include
-CFLAGS += -L ../../cmocka/src -I ../../cmocka/include
+CFLAGS += -L $(LOCALBASE)/lib -I $(LOCALBASE)/include
ASFLAGS += --32
OBJCOPY = objcopy
UNAME_S := $(shell uname -s)
ifeq ($(UNAME_S), Linux)

View File

@ -2,6 +2,7 @@ include/unicorn/arm.h
include/unicorn/arm64.h
include/unicorn/m68k.h
include/unicorn/mips.h
include/unicorn/platform.h
include/unicorn/sparc.h
include/unicorn/unicorn.h
include/unicorn/x86.h