Initial import for GNU cpio 2.11.

GNU cpio copies files into or out of a cpio or tar archive.  The
archive can be another file on the disk, a magnetic tape, or a pipe.
This commit is contained in:
Christian Weisgerber 2010-03-25 21:54:41 +00:00
parent 0bf43dd57d
commit 572049dc82
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=251510
8 changed files with 138 additions and 0 deletions

View File

@ -30,6 +30,7 @@
SUBDIR += freeze
SUBDIR += gambas2-gb-compress-bzlib2
SUBDIR += gambas2-gb-compress-zlib
SUBDIR += gcpio
SUBDIR += grzip
SUBDIR += gtar
SUBDIR += gzip

40
archivers/gcpio/Makefile Normal file
View File

@ -0,0 +1,40 @@
# New ports collection makefile for: gcpio
# Date created: 2010-03-25
# Whom: Christian Weisgerber <naddy@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= cpio
PORTVERSION= 2.11
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= g
MAINTAINER= naddy@FreeBSD.org
COMMENT= GNU cpio copies files to and from archives
USE_BZIP2= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --program-prefix=g \
--disable-silent-rules \
--with-rmt=/etc/rmt
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ARGS+=--with-libintl-prefix="${LOCALBASE}"
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
INFO= cpio
MAN1= gcpio.1
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
.include <bsd.port.mk>

3
archivers/gcpio/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (cpio-2.11.tar.bz2) = 20fc912915c629e809f80b96b2e75d7d
SHA256 (cpio-2.11.tar.bz2) = bb820bfd96e74fc6ce43104f06fe733178517e7f5d1cdee553773e8eff7d5bbd
SIZE (cpio-2.11.tar.bz2) = 1018483

View File

@ -0,0 +1,11 @@
--- doc/Makefile.in.orig 2010-03-25 22:34:54.000000000 +0100
+++ doc/Makefile.in 2010-03-25 22:35:08.000000000 +0100
@@ -813,7 +813,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
info_TEXINFOS = cpio.texi
-man_MANS = cpio.1 mt.1
+man_MANS = cpio.1
EXTRA_DIST = $(man_MANS) gendocs_template
all: all-am

View File

@ -0,0 +1,32 @@
--- doc/cpio.1.orig 2009-02-14 19:15:50.000000000 +0100
+++ doc/cpio.1 2010-03-25 22:35:50.000000000 +0100
@@ -1,8 +1,8 @@
-.TH CPIO 1L \" -*- nroff -*-
+.TH GCPIO 1L \" -*- nroff -*-
.SH NAME
-cpio \- copy files to and from archives
+gcpio \- copy files to and from archives
.SH SYNOPSIS
-.B cpio
+.B gcpio
{\-o|\-\-create} [\-0acvABLV] [\-C bytes] [\-H format] [\-M message]
[\-O [[user@]host:]archive] [\-F [[user@]host:]archive]
[\-\-file=[[user@]host:]archive] [\-\-format=format] [\-\-message=message]
@@ -11,7 +11,7 @@ cpio \- copy files to and from archives
[\-\-force\-local] [\-\-rsh-command=command] [\-\-help] [\-\-version]
< name-list [> archive]
-.B cpio
+.B gcpio
{\-i|\-\-extract} [\-bcdfmnrtsuvBSV] [\-C bytes] [\-E file] [\-H format]
[\-M message] [\-R [user][:.][group]] [\-I [[user@]host:]archive]
[\-F [[user@]host:]archive] [\-\-file=[[user@]host:]archive]
@@ -24,7 +24,7 @@ cpio \- copy files to and from archives
[\-\-only\-verify\-crc] [\-\-to\-stdout] [\-\-quiet] [\-\-rsh-command=command]
[\-\-help] [\-\-version] [pattern...] [< archive]
-.B cpio
+.B gcpio
{\-p|\-\-pass-through} [\-0adlmuvLV] [\-R [user][:.][group]]
[\-\-null] [\-\-reset-access-time] [\-\-make-directories] [\-\-link] [\-\-quiet]
[\-\-preserve-modification-time] [\-\-unconditional] [\-\-verbose] [\-\-dot]

View File

@ -0,0 +1,11 @@
--- gnu/Makefile.in.orig 2010-03-25 22:13:33.000000000 +0100
+++ gnu/Makefile.in 2010-03-25 22:14:21.000000000 +0100
@@ -1720,7 +1720,7 @@ inttypes.h: inttypes.in.h $(WARN_ON_USE_
# avoid installing it.
all-local: charset.alias ref-add.sed ref-del.sed
-install-exec-local: install-exec-localcharset
+install-exec-local:
install-exec-localcharset: all-local
if test $(GLIBC21) = no; then \
case '$(host_os)' in \

17
archivers/gcpio/pkg-descr Normal file
View File

@ -0,0 +1,17 @@
GNU cpio copies files into or out of a cpio or tar archive. The
archive can be another file on the disk, a magnetic tape, or a pipe.
GNU cpio supports the following archive formats: binary, old ASCII,
new ASCII, crc, HPUX binary, HPUX old ASCII, old tar, and POSIX.1
tar. The tar format is provided for compatibility with the tar
program. By default, cpio creates binary format archives, for
compatibility with older cpio programs. When extracting from
archives, cpio automatically recognizes which kind of archive it
is reading and can read archives created on machines with a different
byte-order.
Note that this port will install these utilities with a 'g' prefix,
e.g. gcpio, but the texinfo documentation will refer to them without
the 'g' prefix.
WWW: http://www.gnu.org/software/cpio/

23
archivers/gcpio/pkg-plist Normal file
View File

@ -0,0 +1,23 @@
@comment $FreeBSD$
bin/gcpio
%%NLS%%share/locale/da/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/de/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/es/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/fi/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/fr/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/ga/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/gl/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/hu/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/id/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/ko/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/nl/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/pl/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/ro/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/ru/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/sv/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/tr/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/uk/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/vi/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/cpio.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/cpio.mo