devel/py-fabric: Copy to devel/py-fabric1
Make way for devel/py-fabric to be updated to its latest version (2.x) Updates dependents that require fabric < 2 to devel/py-fabric1 Reviewed by: koobs (maintainer) Approved by: koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D21304
This commit is contained in:
parent
ac2904823c
commit
571c399a5c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=511378
@ -4396,6 +4396,7 @@
|
||||
SUBDIR += py-extremes
|
||||
SUBDIR += py-ezpyinline
|
||||
SUBDIR += py-fabric
|
||||
SUBDIR += py-fabric1
|
||||
SUBDIR += py-fabric3
|
||||
SUBDIR += py-fam
|
||||
SUBDIR += py-fastcache
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= cuisine
|
||||
PORTVERSION= 0.7.13
|
||||
PORTREVISION= 1
|
||||
#PORTEPOCH= 0
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
@ -12,7 +13,7 @@ COMMENT= Chef-like functionality for Fabric
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fabric>=1.7,1:devel/py-fabric@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fabric1>=1.7,1:devel/py-fabric1@${PY_FLAVOR}
|
||||
|
||||
USES= python:2.7
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
35
devel/py-fabric1/Makefile
Normal file
35
devel/py-fabric1/Makefile
Normal file
@ -0,0 +1,35 @@
|
||||
# Created by: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= fabric
|
||||
PORTVERSION= 1.14.1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
PKGNAMESUFFIX= 1
|
||||
DISTNAME= Fabric-${DISTVERSION}
|
||||
|
||||
MAINTAINER= koobs@FreeBSD.org
|
||||
COMMENT= High level SSH command execution
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.10:security/py-paramiko@${PY_FLAVOR} # <3.0
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}fudge>0:devel/py-fudge@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR}
|
||||
|
||||
USES= python:2.7
|
||||
USE_PYTHON= distutils concurrent autoplist
|
||||
|
||||
CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}fabric
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
do-test:
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v \
|
||||
--exclude=test_nested_execution_with_explicit_ports
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/py-fabric1/distinfo
Normal file
3
devel/py-fabric1/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1554010618
|
||||
SHA256 (Fabric-1.14.1.tar.gz) = 66097883bb3e5beecacae92b82b2bd489d10a8fd4f06ce1cb27019de2e6d76a8
|
||||
SIZE (Fabric-1.14.1.tar.gz) = 220463
|
11
devel/py-fabric1/files/patch-setup.py
Normal file
11
devel/py-fabric1/files/patch-setup.py
Normal file
@ -0,0 +1,11 @@
|
||||
--- setup.py.orig 2016-05-08 21:11:49 UTC
|
||||
+++ setup.py
|
||||
@@ -45,7 +45,7 @@ setup(
|
||||
url='http://fabfile.org',
|
||||
packages=find_packages(),
|
||||
test_suite='nose.collector',
|
||||
- tests_require=['nose<2.0', 'fudge<1.0', 'jinja2<3.0'],
|
||||
+ tests_require=['nose', 'fudge', 'jinja2'],
|
||||
install_requires=install_requires,
|
||||
entry_points={
|
||||
'console_scripts': [
|
8
devel/py-fabric1/pkg-descr
Normal file
8
devel/py-fabric1/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
Fabric is a high level Python library designed to execute shell commands
|
||||
remotely over SSH, yielding useful Python objects in return.
|
||||
|
||||
It builds on top of Invoke (subprocess command execution and command-line
|
||||
features) and Paramiko (SSH protocol implementation), extending their APIs
|
||||
to complement one another and provide additional functionality.
|
||||
|
||||
WWW: https://www.fabfile.org
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= ezjailremote
|
||||
PORTVERSION= 0.2.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= sysutils python
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
@ -13,13 +13,15 @@ COMMENT= Remote control and convenience wrapper for ezjail
|
||||
LICENSE= BSD2CLAUSE
|
||||
|
||||
RUN_DEPENDS= ezjail-admin:sysutils/ezjail \
|
||||
${PYTHON_PKGNAMEPREFIX}fabric>0:devel/py-fabric@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}fabric1>0:devel/py-fabric1@${PY_FLAVOR}
|
||||
|
||||
USES= python:2.7
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= tomster
|
||||
GH_PROJECT= ezjail-remote
|
||||
|
||||
USES= python:2.7
|
||||
USE_PYTHON= distutils autoplist
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= ploy_fabric
|
||||
DISTVERSION= 1.1.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -14,9 +15,11 @@ LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ploy>=1.0.0:sysutils/py-ploy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}fabric>=1.4.0,1:devel/py-fabric@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}fabric1>=1.4.0,1:devel/py-fabric1@${PY_FLAVOR}
|
||||
|
||||
USES= python:-2.7 zip
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
Loading…
Reference in New Issue
Block a user