- Update to 3.0.2

This commit is contained in:
Andrew Pantyukhin 2007-08-13 13:11:02 +00:00
parent ca7421cceb
commit 57130e5913
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=197575
9 changed files with 66 additions and 75 deletions

View File

@ -5,32 +5,38 @@
# $FreeBSD$
#
PORTNAME= cantus_3
PORTVERSION= 3.0.0
PORTREVISION= 5
PORTNAME= cantus
PORTVERSION= 3.0.2
DISTVERSIONSUFFIX= -testing.src
CATEGORIES= audio
MASTER_SITES= http://dl.debain.org/${PORTNAME}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for tagging and renaming MP3 and OGG/Vorbis files
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtkmm20 \
glademm-2.0.1:${PORTSDIR}/devel/libglademm \
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
ogg.5:${PORTSDIR}/audio/libogg \
sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
vorbis.4:${PORTSDIR}/audio/libvorbis
CONFLICTS= cantus-1*
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libglade2
USE_XLIB= yes
USE_GNOME= gnomehack gnomeprefix libglade2 glib20
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --program-transform-name="" --disable-static
WRKSRC= ${WRKDIR}/${DISTNAME:S/.src//}
BASH?= ${LOCALBASE}/bin/bash
do-build:
@cd ${WRKSRC} && ${BASH} build.sh --prefix '${PREFIX}'
do-install:
@cd ${WRKSRC} && ${BASH} build.sh --install --prefix '${PREFIX}'
post-patch:
@${REINPLACE_CMD} -Ee 's|-ldld||g;s|-ldl||g;/ALL_LINGUAS=/s|=(.*)|="\1"|'\
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/source/cantus/Makefile.in
@${REINPLACE_CMD} -e 's|PACKAGE_LIB_DIR "cantus-3.glade"|PACKAGE_DATA_DIR "/cantus/glade/cantus.glade"|'\
${WRKSRC}/source/cantus/gui_controller.cc
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (cantus_3-3.0.0-1.tar.gz) = 4bce0d2682ae2d03da2ff710d186bb78
SHA256 (cantus_3-3.0.0-1.tar.gz) = 945f71979721c7212befcaf84e462a9101138798baf46b1c0474779ff6bd4ee0
SIZE (cantus_3-3.0.0-1.tar.gz) = 185810
MD5 (cantus-3.0.2-testing.src.tar.gz) = f1380ed6a4e772310b185ff89245635b
SHA256 (cantus-3.0.2-testing.src.tar.gz) = 0ea294dfd684142400fe179c5da9bd9ffc8716c01f60216cd55be5731d663c16
SIZE (cantus-3.0.2-testing.src.tar.gz) = 511104

View File

@ -1,17 +0,0 @@
--- build.sh.orig Wed Apr 21 20:26:52 2004
+++ build.sh Mon Mar 7 12:11:44 2005
@@ -164,12 +164,8 @@
INST_LIBDIR="$INST_PREFIX/lib/$EXECUTABLE"
INST_LOCALEDIR="$INST_PREFIX/share/locale"
INST_PIXMAPDIR="$INST_PREFIX/lib/$EXECUTABLE"
-INST_DOCDIR="$INST_PREFIX/doc/$EXECUTABLE"
-if [ -d "/usr/share/gnome/help/" ]; then
- INST_GNOMEDOCDIR="/usr/share/gnome/help/$EXECUTABLE/C"
-else
- INST_GNOMEDOCDIR="/usr/local/share/gnome/help/$EXECUTABLE/C"
-fi
+INST_DOCDIR="$INST_PREFIX/share/doc/$EXECUTABLE"
+INST_GNOMEDOCDIR="$INST_PREFIX/share/gnome/help/$EXECUTABLE/C"
# Preprocessor macros:
MACROS="PACKAGE_LIB_DIR=$INST_LIBDIR/\

View File

@ -1,5 +1,5 @@
--- src/libs/lib_charset.c.orig Tue May 18 14:25:50 2004
+++ src/libs/lib_charset.c Tue May 18 14:25:59 2004
+++ source/cantus/charset.c Tue May 18 14:25:59 2004
@@ -207,7 +207,7 @@
outptr = out;

View File

@ -1,5 +1,5 @@
--- src/plugins/cantushashvalue.c.orig 2007-08-03 14:31:22.000000000 +0200
+++ src/plugins/cantushashvalue.c 2007-08-03 14:35:10.000000000 +0200
+++ source/cantus/cantushashvalue.c 2007-08-03 14:35:10.000000000 +0200
@@ -81,7 +81,7 @@
g_assert(hvalue != NULL);
switch (type) {

View File

@ -1,11 +0,0 @@
--- src/plugins/lib_charset.c.orig Tue May 18 14:17:18 2004
+++ src/plugins/lib_charset.c Tue May 18 14:17:34 2004
@@ -191,7 +191,7 @@
outptr = out;
retry:
- if (iconv(cd, (char**)&input, &length, &outptr, &outleft) == -1) {
+ if (iconv(cd, (const char**)&input, &length, &outptr, &outleft) == -1) {
int used;
switch (errno) {
case E2BIG:

View File

@ -1,5 +1,5 @@
--- src/ui-gtk2/gui_preferences.cc.orig 2007-08-12 19:50:46.000000000 +0200
+++ src/ui-gtk2/gui_preferences.cc 2007-08-12 19:51:17.000000000 +0200
+++ source/cantus/gui_preferences.cc 2007-08-12 19:51:17.000000000 +0200
@@ -81,7 +81,7 @@
}
Gtk::CheckButton *check = dynamic_cast<Gtk::CheckButton*>(widget);

View File

@ -4,4 +4,4 @@ generate a tag out of the filename, filter definitions for renaming, recursive
actions, CDDB (Freedb) lookup (no CD needed), copy between ID3V1 and ID3V2 tags,
and a lot more.
WWW: http://www.debain.org/software/cantus/
WWW: http://cantus.sourceforge.net/

View File

@ -1,23 +1,36 @@
bin/cantus_3
lib/cantus_3/id3v1.so
lib/cantus_3/vorbis.so
lib/cantus_3/id3copier.so
lib/cantus_3/tag2filename.so
lib/cantus_3/mpegheader.so
lib/cantus_3/id3v2.so
lib/cantus_3/cantus-3.glade
lib/cantus_3/general.png
lib/cantus_3/cantus_tag.png
share/gnome/help/cantus_3/C/figures/cantus_start_window.png
share/gnome/help/cantus_3/C/legal.xml
share/gnome/help/cantus_3/C/cantus_3.xml
share/gnome/help/cantus_3/C/cantus_start_window.png
share/locale/de/LC_MESSAGES/cantus_3.mo
share/locale/es/LC_MESSAGES/cantus_3.mo
share/locale/fr/LC_MESSAGES/cantus_3.mo
share/locale/pl/LC_MESSAGES/cantus_3.mo
@dirrm share/gnome/help/cantus_3/C/figures
@dirrm share/gnome/help/cantus_3/C
@dirrm share/gnome/help/cantus_3/
@dirrm share/doc/cantus_3
@dirrm lib/cantus_3/
bin/cantus
lib/libcantusplugin_id3copier.la
lib/libcantusplugin_id3copier.so
lib/libcantusplugin_id3copier.so.3
lib/libcantusplugin_id3v1.la
lib/libcantusplugin_id3v1.so
lib/libcantusplugin_id3v1.so.3
lib/libcantusplugin_id3v2.la
lib/libcantusplugin_id3v2.so
lib/libcantusplugin_id3v2.so.3
lib/libcantusplugin_mpegheader.la
lib/libcantusplugin_mpegheader.so
lib/libcantusplugin_mpegheader.so.3
lib/libcantusplugin_tag2filename.la
lib/libcantusplugin_tag2filename.so
lib/libcantusplugin_tag2filename.so.3
lib/libcantusplugin_vorbis.la
lib/libcantusplugin_vorbis.so
lib/libcantusplugin_vorbis.so.3
share/gnome/cantus/glade/cantus.glade
share/gnome/cantus/glade/cantus.gladep
share/gnome/cantus/glade/strings.c
share/gnome/pixmaps/cantus/general/general.png
share/gnome/pixmaps/cantus/logo/cantus.svg
share/gnome/pixmaps/cantus/logo/cantus_tag.png
share/locale/de/LC_MESSAGES/cantus.mo
share/locale/es/LC_MESSAGES/cantus.mo
share/locale/fr/LC_MESSAGES/cantus.mo
share/locale/it/LC_MESSAGES/cantus.mo
share/locale/nl/LC_MESSAGES/cantus.mo
share/locale/pl/LC_MESSAGES/cantus.mo
@dirrm share/gnome/cantus/glade
@dirrm share/gnome/cantus
@dirrm share/gnome/pixmaps/cantus/general
@dirrm share/gnome/pixmaps/cantus/logo
@dirrm share/gnome/pixmaps/cantus