Update cubicsdr snapshot version from github

major changes appears to be FreeBSD related diffs were accepted
and newer version of liquid-dsp lib is needed.
This commit is contained in:
Diane Bruce 2020-01-13 02:37:22 +00:00
parent 29a472d2b3
commit 570910e4ca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=522844
8 changed files with 7 additions and 112 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= cubicsdr
DISTVERSION= 0.2.5
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= comms hamradio
MAINTAINER= hamradio@FreeBSD.org
@ -11,8 +11,6 @@ COMMENT= SDR receiver using liquidsdr
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= fails to build
RUN_DEPENDS= ${PYNUMPY} \
${LOCALBASE}/lib/libEGL.so:graphics/mesa-libs \
${LOCALBASE}/libdata/pkgconfig/dri.pc:graphics/mesa-dri
@ -38,11 +36,11 @@ CMAKE_ARGS+= -DUSE_HAMLIB=1
.endif
CMAKE_ARGS+= -DwxWidgets_CONFIG_EXECUTABLE=${LOCALBASE}/bin/wxgtk3u-3.1-config
# if Only I could just do
#USE_WX= 3.1
#WX_COMPS= wx
USE_WX= 3.1
WX_COMPS= wx
USE_GITHUB= yes
GH_ACCOUNT= cjcliffe
GH_PROJECT= CubicSDR
GH_TAGNAME= 9c32b97
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1551114984
SHA256 (cjcliffe-CubicSDR-0.2.5_GH0.tar.gz) = 5cb44c110fcbbb70a468b7fa402cf35f84d8901b3dd42d471a90ac3f5db00f4d
SIZE (cjcliffe-CubicSDR-0.2.5_GH0.tar.gz) = 36911106
TIMESTAMP = 1578325251
SHA256 (cjcliffe-CubicSDR-0.2.5-9c32b97_GH0.tar.gz) = 46eb12b942c7e38dbfe8a84448a3721b5d9c7c1fd8878f8cad7bd37806352dbf
SIZE (cjcliffe-CubicSDR-0.2.5-9c32b97_GH0.tar.gz) = 35466535

View File

@ -1,20 +0,0 @@
--- src/AppFrame.cpp.orig 2019-02-25 02:52:05 UTC
+++ src/AppFrame.cpp
@@ -34,7 +34,7 @@
#include <wx/numformatter.h>
#include <stddef.h>
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
#include "CubicSDR.xpm"
#endif
@@ -79,7 +79,7 @@ std::vector<std::string> str_explode(const std::string
AppFrame::AppFrame() :
wxFrame(NULL, wxID_ANY, CUBICSDR_TITLE), activeDemodulator(nullptr) {
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
SetIcon(wxICON(cubicsdr));
#endif

View File

@ -1,30 +0,0 @@
--- src/CubicSDRDefs.h.orig 2018-06-08 03:58:55 UTC
+++ src/CubicSDRDefs.h
@@ -2,6 +2,7 @@
// SPDX-License-Identifier: GPL-2.0+
#pragma once
+#include <sys/param.h>
#define CUBICSDR_TITLE "" CUBICSDR_BUILD_TITLE
@@ -16,7 +17,11 @@
#ifdef __APPLE__
#include <machine/endian.h>
#else
- #include <endian.h>
+ #ifdef __FreeBSD__
+ #include <sys/endian.h>
+ #else
+ #include <endian.h>
+ #endif
#endif
#endif
#endif
@@ -62,4 +67,4 @@ const char filePathSeparator =
//The maximum number of listed sample rates for a device, to be able to handle
//devices returning an insane amount because they have quasi-continuous ranges (UHD...)
-#define DEVICE_SAMPLE_RATES_MAX_NB 25
\ No newline at end of file
+#define DEVICE_SAMPLE_RATES_MAX_NB 25

View File

@ -1,11 +0,0 @@
--- src/DemodLabelDialog.cpp.orig 2019-02-25 02:53:22 UTC
+++ src/DemodLabelDialog.cpp
@@ -83,7 +83,7 @@ void DemodLabelDialog::OnChar(wxKeyEvent& event) {
}
else {
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
dialogText->OnChar(event);
event.Skip();
#else

View File

@ -1,11 +0,0 @@
--- src/FrequencyDialog.cpp.orig 2019-02-25 02:39:08 UTC
+++ src/FrequencyDialog.cpp
@@ -218,7 +218,7 @@ void FrequencyDialog::OnChar(wxKeyEvent& event) {
if (allowed.find_first_of(c) != std::string::npos || c == WXK_DELETE || c == WXK_BACK || c == WXK_NUMPAD_DECIMAL
|| (c >= WXK_NUMPAD0 && c <= WXK_NUMPAD9)) {
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
dialogText->OnChar(event);
event.Skip();
#else

View File

@ -1,20 +0,0 @@
--- src/util/GLExt.cpp.orig 2018-08-20 16:53:40 UTC
+++ src/util/GLExt.cpp
@@ -9,7 +9,7 @@
#include <OpenGL/OpenGL.h>
#endif
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
#include <dlfcn.h>
#endif
@@ -60,7 +60,7 @@ void initGLExtensions() {
CGLSetParameter (CGLGetCurrentContext(), kCGLCPSwapInterval, &interval);
#endif
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
dlopen("libglx.so",RTLD_LAZY);
void (*glxSwapIntervalEXTFunc) (Display *dpy, GLXDrawable drawable, int interval) = 0;

View File

@ -1,11 +0,0 @@
--- src/util/MouseTracker.cpp.orig 2019-02-25 12:54:38 UTC
+++ src/util/MouseTracker.cpp
@@ -30,7 +30,7 @@ void MouseTracker::OnMouseMoved(wxMouseEvent& event) {
if (isMouseDown || isMouseRightDown) {
#ifndef __APPLE__
-#ifndef __linux__
+#if !defined(__linux__) && !defined(__FreeBSD__)
if (horizDragLock && vertDragLock) {
target->WarpPointer(originMouseX * ClientSize.x, (1.0 - originMouseY) * ClientSize.y);
mouseX = originMouseX;