net-p2p/ethash: New port: C/C++ implementation of Ethash and ProgPoW
This commit is contained in:
parent
8c62d72d9f
commit
56b72f9ebb
@ -31,6 +31,7 @@
|
||||
SUBDIR += eiskaltdcpp-data
|
||||
SUBDIR += eiskaltdcpp-gtk
|
||||
SUBDIR += eiskaltdcpp-lib
|
||||
SUBDIR += ethash
|
||||
SUBDIR += frost
|
||||
SUBDIR += go-ethereum
|
||||
SUBDIR += go-prysm
|
||||
|
22
net-p2p/ethash/Makefile
Normal file
22
net-p2p/ethash/Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
PORTNAME= ethash
|
||||
PORTVERSION= 0.8.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= net-p2p
|
||||
|
||||
MAINTAINER= nc@FreeBSD.org
|
||||
COMMENT= C/C++ implementation of Ethash and ProgPoW
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= libbenchmark.so:devel/benchmark \
|
||||
libgtest.so:devel/googletest
|
||||
|
||||
USES= cmake
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= chfast
|
||||
|
||||
CMAKE_OFF= HUNTER_ENABLED
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
3
net-p2p/ethash/distinfo
Normal file
3
net-p2p/ethash/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1642107104
|
||||
SHA256 (chfast-ethash-v0.8.0_GH0.tar.gz) = c53a39cd7b4687f1fcc6e4a561a0aaaab9ec0438ae818860dd4e98bb4ad2f153
|
||||
SIZE (chfast-ethash-v0.8.0_GH0.tar.gz) = 103991
|
11
net-p2p/ethash/files/patch-lib_ethash_endianness.hpp
Normal file
11
net-p2p/ethash/files/patch-lib_ethash_endianness.hpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib/ethash/endianness.hpp.orig 2021-11-09 08:29:42 UTC
|
||||
+++ lib/ethash/endianness.hpp
|
||||
@@ -24,7 +24,7 @@
|
||||
#endif
|
||||
#endif
|
||||
|
||||
-#if __has_builtin(__builtin_bswap64) || defined(__GNUC__)
|
||||
+#if (__has_builtin(__builtin_bswap64) || defined(__GNUC__)) && !defined(__FreeBSD__)
|
||||
#define bswap32 __builtin_bswap32
|
||||
#define bswap64 __builtin_bswap64
|
||||
#elif defined(_MSC_VER)
|
3
net-p2p/ethash/pkg-descr
Normal file
3
net-p2p/ethash/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
C/C++ implementation of Ethash - the Ethereum Proof of Work algorithm.
|
||||
|
||||
WWW: https://github.com/chfast/ethash
|
17
net-p2p/ethash/pkg-plist
Normal file
17
net-p2p/ethash/pkg-plist
Normal file
@ -0,0 +1,17 @@
|
||||
include/ethash/ethash.h
|
||||
include/ethash/ethash.hpp
|
||||
include/ethash/global_context.h
|
||||
include/ethash/global_context.hpp
|
||||
include/ethash/hash_types.h
|
||||
include/ethash/hash_types.hpp
|
||||
include/ethash/keccak.h
|
||||
include/ethash/keccak.hpp
|
||||
include/ethash/progpow.hpp
|
||||
include/ethash/version.h
|
||||
lib/cmake/ethash/ethashConfig.cmake
|
||||
lib/cmake/ethash/ethashConfigVersion.cmake
|
||||
lib/cmake/ethash/ethashTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/ethash/ethashTargets.cmake
|
||||
lib/libethash-global-context.a
|
||||
lib/libethash.a
|
||||
lib/libkeccak.a
|
Loading…
Reference in New Issue
Block a user