Dupmerge reads a list of files from standard input (eg., as produced by

"find . -print") and looks securely for identical files. When it finds
two or more identical files, all but one are unlinked to reclaim the
disk space and recreated as hard links to the remaining copy.

WWW: http://sourceforge.net/projects/dupmerge
This commit is contained in:
Dirk Meyer 2009-01-13 15:42:55 +00:00
parent dd78d99ddf
commit 56a22e7a56
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=225975
5 changed files with 53 additions and 0 deletions

View File

@ -161,6 +161,7 @@
SUBDIR += dump9660
SUBDIR += dupfind
SUBDIR += duplicity
SUBDIR += dupmerge
SUBDIR += durep
SUBDIR += dvd+rw-tools
SUBDIR += dvdbackup

View File

@ -0,0 +1,33 @@
# New ports collection makefile for: dupmerge
# Date created: 12 Jan 2009
# Whom: dirk.meyer@dinoex.sub.org
#
# $FreeBSD$
#
PORTNAME= dupmerge
PORTVERSION= 1.73
CATEGORIES= sysutils
MASTER_SITES= SF
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Searches for files with equal content
USE_ZIP= yes
MAKE_FLAGS=
MAKEFILE=
LDFLAGS+= -lroken -lcrypt
MAKE_ENV+= LDFLAGS="${LDFLAGS}"
ALL_TARGET= dupmerge
PLIST_FILES= bin/dupmerge
PORTDOCS= readme.txt
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dupmerge ${PREFIX}/bin/
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}/
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (dupmerge_1.73.zip) = 0c50ce2877be34ced391ec32b30324a6
SHA256 (dupmerge_1.73.zip) = c8bea34351b12f9aa053298c3b6555f89aa7d4a2f6ad97ac8782a16ffeea4386
SIZE (dupmerge_1.73.zip) = 25107

View File

@ -0,0 +1,10 @@
--- dupmerge.c.orig 2008-03-01 17:46:41.000000000 +0100
+++ dupmerge.c 2009-01-13 15:15:07.000000000 +0100
@@ -125,6 +125,7 @@
#include <sys/wait.h> // vfork
#include <time.h> // localtime
+#include <roken.h>
#define mc_MIN(a, b) ((a) < (b) ? (a) : (b))
#define mc_MAX(a, b) ((a) > (b) ? (a) : (b))

View File

@ -0,0 +1,6 @@
Dupmerge reads a list of files from standard input (eg., as produced by
"find . -print") and looks securely for identical files. When it finds
two or more identical files, all but one are unlinked to reclaim the
disk space and recreated as hard links to the remaining copy.
WWW: http://sourceforge.net/projects/dupmerge