- Fix plist and portlint compliance
- Fix IPv6 support - Remove WANT_GNOME because the Gtkfrontend is buggy and unmaintained - ECHO -> ECHO_CMD PR: ports/38654 Submitted by: maintainer
This commit is contained in:
parent
3cd54bb5bb
commit
5686b99047
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60904
@ -12,20 +12,22 @@ MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
|
||||
ftp://ftp.bitchx.org/pub/BitchX/source/ \
|
||||
ftp://ftp.cyberpunkz.org/pub/BitchX/source/ \
|
||||
ftp://ftp.cyberpunkz.org/pub/BitchX/tcl-o/:tcl
|
||||
DISTNAME= ircii-pana-1.0c19
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
|
||||
.if defined(WITH_TCL)
|
||||
DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl
|
||||
.if !defined(WITH_TCL)
|
||||
DISTNAME= ircii-pana-${PORTVERSION}
|
||||
.else
|
||||
DISTFILES= ircii-pana-${PORTVERSION}${EXTRACT_SUFX} \
|
||||
freebsd4-tcl83-bx1.0c19-tcl.o:tcl
|
||||
EXTRACT_ONLY= ircii-pana-${PORTVERSION}${EXTRACT_SUFX}
|
||||
.endif
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= freebsdports@arved.de
|
||||
|
||||
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
|
||||
|
||||
WRKSRC= ${WRKDIR}/BitchX
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOCONF= yes
|
||||
AUTOCONF= ${LOCALBASE}/bin/autoconf
|
||||
USE_GMAKE= yes
|
||||
WANT_ESOUND= yes
|
||||
WANT_GNOME= yes
|
||||
CONFIGURE_ARGS= --exec-prefix="${PREFIX}/share" \
|
||||
--bindir="${PREFIX}/bin" \
|
||||
--datadir="${PREFIX}/share" \
|
||||
@ -37,14 +39,16 @@ MAN1= BitchX.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GNOME)
|
||||
.if defined(WITH_GNOME)
|
||||
USE_GNOME= yes
|
||||
CONFIGURE_ARGS+=--with-gtk
|
||||
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${X11BASE}/include/gnome-1.0/"
|
||||
PLIST_SUB+= NOGNOME:="@comment " GNOME:=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-gtk
|
||||
PLIST_SUB+= GNOME:="@comment " NOGNOME:=""
|
||||
.endif
|
||||
.if (defined(HAVE_ESOUND) && defined(HAVE_GNOME))
|
||||
.if (defined(HAVE_ESOUND) && defined(WITH_GNOME))
|
||||
USE_ESOUND= yes
|
||||
CONFIGURE_ARGS+=--enable-sound
|
||||
.endif
|
||||
@ -55,17 +59,15 @@ CONFIGURE_ARGS+=--enable-ipv6
|
||||
.if defined(WITH_TCL)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
|
||||
CONFIGURE_ARGS+=--with-tcl \
|
||||
--with-tcl-includes=${LOCALBASE}/include/tcl8.3 \
|
||||
--with-tcl-libs=${LOCALBASE}/lib
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3"
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3" \
|
||||
CFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3"
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SOCKS5)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
|
||||
CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PLUGINS)
|
||||
CONFIGURE_ARGS+=--with-plugins
|
||||
PLIST_SUB+= PLUGINS:=""
|
||||
@ -81,24 +83,26 @@ pre-patch:
|
||||
@${PERL} -pi -e "s!bzip2!true!g" ${WRKSRC}/Makefile.in
|
||||
|
||||
pre-extract:
|
||||
@${ECHO} "Available switches:"
|
||||
@${ECHO} "-------------------"
|
||||
@${ECHO_CMD} "Available switches:"
|
||||
@${ECHO_CMD} "-------------------"
|
||||
.if !defined(WITH_PLUGINS)
|
||||
@${ECHO} "WITH_PLUGINS - Build the plugins"
|
||||
@${ECHO_CMD} "WITH_PLUGINS - Build the plugins"
|
||||
.endif
|
||||
.if !defined(WITH_LATIN)
|
||||
@${ECHO} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
|
||||
@${ECHO_CMD} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
|
||||
.endif
|
||||
.if !defined(WITH_TCL)
|
||||
@${ECHO} "WITH_TCL - Build BitchX with TCL scripting"
|
||||
@${ECHO_CMD} "WITH_TCL - Build BitchX with TCL scripting"
|
||||
.endif
|
||||
.if !defined(WITH_SOCKS5)
|
||||
@${ECHO} "WITH_SOCKS5 - Build BitchX with SOCKS5 support"
|
||||
@${ECHO_CMD} "WITH_SOCKS5 - Build BitchX with SOCKS5 support"
|
||||
.endif
|
||||
.if !defined(WITH_IPV6)
|
||||
@${ECHO} "WITH_IPV6 - Build BitchX with IPV6 support"
|
||||
@${ECHO_CMD} "WITH_IPV6 - Build BitchX with IPV6 support"
|
||||
.endif
|
||||
.if !defined(WITH_GNOME)
|
||||
@${ECHO_CMD} "WITH_GNOME - Build BitchX with Gtk-Frontend"
|
||||
.endif
|
||||
|
||||
.if defined(WITH_TCL)
|
||||
|
||||
post-extract:
|
||||
|
@ -1,82 +0,0 @@
|
||||
--- configure.orig Sun Mar 24 11:30:49 2002
|
||||
+++ configure Fri Apr 19 15:27:15 2002
|
||||
@@ -868,6 +868,8 @@
|
||||
--with-ssl Enable SSL support
|
||||
--with-tgetent Use tgetent (termcap) instead of setupterm (ncurses)
|
||||
--with-tcl Enable Tcl support
|
||||
+ --with-tcl-includes=PFX Prefix where tcl.h is installed (optional)
|
||||
+
|
||||
--with-maildir=PATH Enable QMAIL support
|
||||
--with-default-server=SERVERNAME:PORT:PASSWORD:NICK:SERVERNETWORK
|
||||
Connect to SERVERNAME by default
|
||||
@@ -11120,6 +11122,17 @@
|
||||
#define WANT_TCL 1
|
||||
_ACEOF
|
||||
|
||||
+# Check whether --with-tcl-includes was given.
|
||||
+if test "${with_tcl_includes+set}" = set; then
|
||||
+ withval="$with_tcl_includes"
|
||||
+ TCL_INCLUDE=-I$withval
|
||||
+else
|
||||
+ TCL_INCLUDE=-I/usr/local/include
|
||||
+fi;
|
||||
+
|
||||
+cat >>confdefs.h <<\ACEOF
|
||||
+#define WANT_TCL 1
|
||||
+ACEOF
|
||||
|
||||
echo "$as_me:$LINENO: checking for dlopen in -ldl" >&5
|
||||
echo $ECHO_N "checking for dlopen in -ldl... $ECHO_C" >&6
|
||||
@@ -11518,13 +11531,13 @@
|
||||
|
||||
|
||||
|
||||
- echo "$as_me:$LINENO: checking for Tcl_SetVar in -ltcl" >&5
|
||||
-echo $ECHO_N "checking for Tcl_SetVar in -ltcl... $ECHO_C" >&6
|
||||
-if test "${ac_cv_lib_tcl_Tcl_SetVar+set}" = set; then
|
||||
+ echo "$as_me:$LINENO: checking for Tcl_SetVar in -ltcl83" >&5
|
||||
+echo $ECHO_N "checking for Tcl_SetVar in -ltcl83... $ECHO_C" >&6
|
||||
+if test "${ac_cv_lib_tcl83_Tcl_SetVar+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-ltcl $LIBS"
|
||||
+LIBS="-ltcl83 $LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line $LINENO "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -11562,19 +11575,19 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_lib_tcl_Tcl_SetVar=yes
|
||||
+ ac_cv_lib_tcl83_Tcl_SetVar=yes
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
cat conftest.$ac_ext >&5
|
||||
-ac_cv_lib_tcl_Tcl_SetVar=no
|
||||
+ac_cv_lib_tcl83_Tcl_SetVar=no
|
||||
fi
|
||||
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
|
||||
LIBS=$ac_check_lib_save_LIBS
|
||||
fi
|
||||
-echo "$as_me:$LINENO: result: $ac_cv_lib_tcl_Tcl_SetVar" >&5
|
||||
-echo "${ECHO_T}$ac_cv_lib_tcl_Tcl_SetVar" >&6
|
||||
-if test $ac_cv_lib_tcl_Tcl_SetVar = yes; then
|
||||
- TCL_LIBS="-ltcl"
|
||||
+echo "$as_me:$LINENO: result: $ac_cv_lib_tcl83_Tcl_SetVar" >&5
|
||||
+echo "${ECHO_T}$ac_cv_lib_tcl83_Tcl_SetVar" >&6
|
||||
+if test $ac_cv_lib_tcl83_Tcl_SetVar = yes; then
|
||||
+ TCL_LIBS="-ltcl83"
|
||||
else
|
||||
echo "$as_me:$LINENO: checking for alternate libtcl" >&5
|
||||
echo $ECHO_N "checking for alternate libtcl... $ECHO_C" >&6
|
||||
@@ -14776,7 +14789,7 @@
|
||||
fi
|
||||
|
||||
|
||||
-INCLUDES="-I. -I\$(topdir)/include -I\$(top_srcdir)/include -I\$(srcdir) -I\$(srcdir)/include"
|
||||
+INCLUDES="-I. -I\$(topdir)/include -I\$(top_srcdir)/include -I\$(srcdir) -I\$(srcdir)/include $TCL_INCLUDE"
|
||||
|
||||
|
||||
|
58
irc/bitchx/files/patch-configure
Normal file
58
irc/bitchx/files/patch-configure
Normal file
@ -0,0 +1,58 @@
|
||||
--- configure.in.orig Sun Mar 24 10:30:49 2002
|
||||
+++ configure.in Tue May 28 10:06:37 2002
|
||||
@@ -685,48 +685,16 @@
|
||||
|
||||
AC_MSG_CHECKING(whether to enable IPv6 support)
|
||||
AC_ARG_ENABLE(ipv6,
|
||||
-[ --enable-ipv6 Enable IPv6 support (Linux only)],
|
||||
+[ --enable-ipv6 Enable ipv6 support],
|
||||
[ case "$enableval" in
|
||||
yes)
|
||||
- case "$(uname -s)" in
|
||||
- Linux)
|
||||
- if test -d "/usr/inet6/include"; then
|
||||
- CFLAGS="$CFLAGS -I/usr/inet6/include"
|
||||
- LIBS="-L/usr/inet6/lib -linet6 $LIBS"
|
||||
- AC_MSG_RESULT(yes (libinet6))
|
||||
- AC_DEFINE(IPV6, 1, Define this if you want IPV6 support.)
|
||||
- else
|
||||
- if test -d "/usr/local/v6/lib"; then
|
||||
- LIBS="-L/usr/local/v6/lib -linet6 $LIBS"
|
||||
- AC_MSG_RESULT(yes (freebsd+kame))
|
||||
- AC_DEFINE(IPV6, 1, Define this if you want IPV6 support.)
|
||||
- else
|
||||
- AC_TRY_RUN([
|
||||
- int main()
|
||||
- {
|
||||
- #if !defined(__GLIBC__) || (__GLIBC__ < 2)
|
||||
- #define NO_GLIBC_2 1
|
||||
- #endif
|
||||
-
|
||||
- if (NO_GLIBC_2)
|
||||
- exit(0);
|
||||
- else
|
||||
- exit(1);
|
||||
- }],[ AC_MSG_RESULT(yes (glibc2))
|
||||
- AC_DEFINE(IPV6, 1, Define this if you want IPV6 support.)
|
||||
- ], [AC_MSG_RESULT(no)], [AC_MSG_WARN(cross-compiling: assuming no ipv6)])
|
||||
- fi
|
||||
- fi
|
||||
- ;;
|
||||
- *)
|
||||
- AC_MSG_RESULT(no (ipv6 support can currently be enabled on Linux only))
|
||||
- ;;
|
||||
- esac
|
||||
- ;;
|
||||
- no)
|
||||
- AC_MSG_RESULT(no)
|
||||
- ;;
|
||||
- esac ],
|
||||
+ AC_MSG_RESULT(yes (notchecked))
|
||||
+ AC_DEFINE(IPV6, 1, Define this if you want IPV6 support.)
|
||||
+ ;;
|
||||
+ *)
|
||||
+ AC_MSG_RESULT(no)
|
||||
+ ;;
|
||||
+ esac],
|
||||
AC_MSG_RESULT(no)
|
||||
)
|
@ -918,7 +918,6 @@ share/bx/help/functions
|
||||
share/bx/help/out
|
||||
%%PLUGINS:%%share/bx/plugins/BitchX.hints
|
||||
%%PLUGINS:%%share/bx/plugins/acro.so
|
||||
%%PLUGINS:%%share/bx/plugins/amp.so
|
||||
%%PLUGINS:%%share/bx/plugins/autobot.so
|
||||
%%PLUGINS:%%share/bx/plugins/blowfish.so
|
||||
%%PLUGINS:%%share/bx/plugins/encrypt.so
|
||||
|
Loading…
Reference in New Issue
Block a user