MFH: r475483

lang/ruby2[4|5]: Use internal RUBY_DLDFLAGS right way, get rid of unescaped macro '$@' in the pkg-config template

lang/ruby23 is already fixed same way, port it to newer releases

By the way, this unbreak ninja builds with any port relied on libruby.so

PR:		229898
Submitted by:	fluffy
Reviewed by:	ruby (miwi)
Approved by:	ruby (miwi)
Exp-run by:	antoine
Differential Revision:	D16341

Approved by:	ports-secteam (miwi)
This commit is contained in:
Dima Panov 2018-07-28 03:37:53 +00:00
parent 28f7ccc2bb
commit 56658facca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q3/; revision=475488
3 changed files with 40 additions and 2 deletions

View File

@ -165,7 +165,7 @@ RUBY23= "" # PLIST_SUB helpers
# Ruby 2.4
#
RUBY_RELVERSION= 2.4.4
RUBY_PORTREVISION= 0
RUBY_PORTREVISION= 1
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 0
RUBY24= "" # PLIST_SUB helpers
@ -175,7 +175,7 @@ RUBY24= "" # PLIST_SUB helpers
# Ruby 2.5
#
RUBY_RELVERSION= 2.5.1
RUBY_PORTREVISION= 0
RUBY_PORTREVISION= 1
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 0
RUBY25= "" # PLIST_SUB helpers

View File

@ -0,0 +1,19 @@
--- configure.in.orig 2018-03-02 20:59:11.000000000 +0800
+++ configure.in 2018-07-19 14:22:04.753721000 +0800
@@ -3423,7 +3423,6 @@
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
else
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
fi
@@ -3896,6 +3895,8 @@
[freebsd*|dragonfly*], [
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'
+ RUBY_APPEND_OPTIONS(DLDFLAGS, ['-Wl,-soname,${LIBRUBY_SO}' "$LDFLAGS_OPTDIR"])
+ RUBY_APPEND_OPTIONS(LIBRUBY_DLDFLAGS, ['-Wl,-soname,${LIBRUBY_SO}' "$LDFLAGS_OPTDIR"])
if test "$rb_cv_binary_elf" != "yes" ; then
LIBRUBY_SO="$LIBRUBY_SO.\$(TEENY)"
LIBRUBY_ALIASES=''

View File

@ -0,0 +1,19 @@
--- configure.ac.orig 2018-01-04 02:12:16.000000000 +0800
+++ configure.ac 2018-07-19 14:45:11.636321000 +0800
@@ -3245,7 +3245,6 @@
: ${LDSHARED='$(CC) -shared'}
AS_IF([test "$rb_cv_binary_elf" = yes], [
LDFLAGS="$LDFLAGS -rdynamic"
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
], [
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
])
@@ -3724,6 +3723,8 @@
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).$(SOEXT).$(MAJOR)$(MINOR)'
LIBRUBY_SONAME='$(LIBRUBY_SO)'
+ RUBY_APPEND_OPTIONS(DLDFLAGS, ['-Wl,-soname,${LIBRUBY_SO}' "$LDFLAGS_OPTDIR"])
+ RUBY_APPEND_OPTIONS(LIBRUBY_DLDFLAGS, ['-Wl,-soname,${LIBRUBY_SO}' "$LDFLAGS_OPTDIR"])
AS_IF([test "$rb_cv_binary_elf" != "yes" ], [
LIBRUBY_SO="$LIBRUBY_SO.\$(TEENY)"
LIBRUBY_ALIASES=''