- Update to 0.6

- Add option to enable password generator
- Respect NOPORTDOCS
- Fix pkg-descr to be more accurate

PR:		ports/138530
Submitted by:	Rafael Ostertag <rafi@guengel.ch> (maintainer)
This commit is contained in:
Wesley Shields 2009-09-04 17:07:44 +00:00
parent 3618940813
commit 564997a667
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=240873
7 changed files with 36 additions and 133 deletions

View File

@ -6,15 +6,10 @@
#
PORTNAME= yapet
PORTVERSION= 0.4
PORTREVISION= 1
PORTVERSION= 0.6
CATEGORIES= security
MASTER_SITES= http://www.guengel.ch/myapps/yapet/downloads/ http://homepage.hispeed.ch/rostertag/yapet/
PATCH_SITES= http://www.guengel.ch/myapps/yapet/downloads/patches/ http://homepage.hispeed.ch/rostertag/yapet/patches/
PATCHFILES= yapet_cfgfile-0.4.diff yapet_csv2yapet-0.4.diff
PATCH_DIST_STRIP= -p1
MAINTAINER= rafi@guengel.ch
COMMENT= A curses based password manager
@ -23,20 +18,29 @@ MANCOMPRESSED= no
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:262 automake:110 aclocal:110
ACLOCAL_ARGS= -I m4
OPTIONS= TTITLE "Enable Terminal Title" ON \
PWGEN "Enable Password Generator" ON \
CSV2YAPET "Build csv2yapet" ON
.include <bsd.port.pre.mk>
# --enable-silent-rules: will make the build quiet
# --disable-install-doc: I take care of installing docs
CONFIGURE_ARGS+= --enable-silent-rules --disable-install-doc
.if defined(WITH_TTITLE)
CONFIGURE_ARGS+= --enable-terminal-title
.else
CONFIGURE_ARGS+= --disable-terminal-title
.endif
.if defined(WITH_PWGEN)
CONFIGURE_ARGS+= --enable-pwgen
.else
CONFIGURE_ARGS+= --disable-pwgen
.endif
.if defined(WITH_CSV2YAPET)
CONFIGURE_ARGS+= --enable-csv2yapet
MAN1+= csv2yapet.1
@ -48,9 +52,10 @@ PLIST_SUB+= CSV2YAPET="@comment "
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB+= NLS=""
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
.else
@ -59,13 +64,21 @@ PLIST_SUB+= NLS="@comment "
.endif
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS+= --enable-install-doc
PLIST_SUB+= NOPORTDOCS=""
.else
CONFIGURE_ARGS+= --disable-install-doc
PLIST_SUB+= NOPORTDOCS="@comment "
.undef MAN1
.undef MANCOMPRESSED
.endif
# Taking care of installing docs due to --disable-install-doc
# configure switch.
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/AUTHORS ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/DESIGN ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/THANKS ${DOCSDIR}
.endif
.include <bsd.port.post.mk>

View File

@ -1,9 +1,3 @@
MD5 (yapet-0.4.tar.gz) = 9efad0e6b5337b0171d77ee2bf9cecc9
SHA256 (yapet-0.4.tar.gz) = ae758cd0778e6f55e0dca63f22ce8bca3a77860646324d43ff09539d667d3ae2
SIZE (yapet-0.4.tar.gz) = 535666
MD5 (yapet_cfgfile-0.4.diff) = 961fd692fb3554de2e7947e0bdb2afae
SHA256 (yapet_cfgfile-0.4.diff) = 38f14e88702a07264231924a9831e363332909c7cc0daa6af1f12e752e98250e
SIZE (yapet_cfgfile-0.4.diff) = 15064
MD5 (yapet_csv2yapet-0.4.diff) = 80e8bd649174334b5748b2f9e70a4ce4
SHA256 (yapet_csv2yapet-0.4.diff) = f71f5a51551f7e7d8fc69393b15e8a7157d71dae89ac617a9fb9b6ce423de86e
SIZE (yapet_csv2yapet-0.4.diff) = 157466
MD5 (yapet-0.6.tar.gz) = 30ee2bf2d4658e667b8eea4a62704b76
SHA256 (yapet-0.6.tar.gz) = 78a57878d7085bd2f2fe503c392c3955eef1304ad2678a5646342d92995a70fb
SIZE (yapet-0.6.tar.gz) = 2921149

View File

@ -1,22 +0,0 @@
--- Makefile.am 2009-07-11 21:13:35.000000000 +0200
+++ Makefile.am 2009-07-19 16:59:36.228663464 +0200
@@ -1,7 +1,7 @@
#
AUTOMAKE_OPTIONS = check-news dist-bzip2
-DISTCHECK_CONFIGURE_FLAGS = --enable-csv2yapet --enable-terminal-title --disable-source-doc
+DISTCHECK_CONFIGURE_FLAGS = --enable-csv2yapet --enable-terminal-title --disable-source-doc --enable-install-doc
EXTRA_DIST = config.rpath m4/ChangeLog README.Cygwin MAINTAINER DESIGN LICENSE \
INSTALL.generic Makefile.cvs yapet.desktop.in intl.h gettext.h BUGS
@@ -15,8 +15,10 @@
desktopfile_DATA = yapet.desktop
desktopfiledir = $(datadir)/applications
+if !DISABLEINSTALLDOC
textdoc_DATA = README COPYING AUTHORS DESIGN LICENSE
textdocdir = $(docdir)
+endif # !DISABLEINSTALLDOC
editfile = $(SED) -e 's|@PACKAGE_STRING[@]|$(PACKAGE_STRING)|g' \
-e 's|@PACKAGE_VERSION[@]|$(PACKAGE_VERSION)|g' \

View File

@ -1,33 +0,0 @@
--- configure.ac 2009-07-11 21:26:00.000000000 +0200
+++ configure.ac 2009-07-19 16:49:39.328663575 +0200
@@ -51,6 +51,14 @@
[AS_HELP_STRING([--enable-build-doc],[enable the rebuild of the documentation (Requires xsltproc, lynx; Default: no)])],
[my_builddoc=$enableval],
[my_builddoc=no])
+AC_ARG_ENABLE([install-doc],
+ [AS_HELP_STRING([--disable-install-doc],[disable the installation of the documentation (man pages, text and html files; Default: no)])],
+ [if test x$enableval = xno ; then
+ my_disableinstalldoc=yes
+ else
+ my_disableinstalldoc=no
+ fi],
+ [my_disableinstalldoc=no])
AC_ARG_ENABLE([source-doc],
[AS_HELP_STRING([--enable-source-doc],[enable the build of the source code documentention (Requires doxygen; default: no)])],
[my_buildsourcedoc=$enableval],
@@ -180,6 +188,7 @@
AM_CONDITIONAL([HAVEXSLTPROC], [test x$XSLTPROC != xno -a x$LYNX != xno])
AM_CONDITIONAL([USE_INCLUDED_LIBINTL], [test x$USE_INCLUDED_LIBINTL = xyes])
AM_CONDITIONAL([BUILDCSV2YAPET], [test x$my_buildcsv2yapet = xyes])
+AM_CONDITIONAL([DISABLEINSTALLDOC], [test x$my_disableinstalldoc = xyes])
AC_CONFIG_FILES([Makefile
intl/Makefile
po/Makefile.in
@@ -207,6 +216,7 @@
echo "Docbook XSL : $DOCBOOKXSL"
echo ""
echo "Build Documentation : $my_builddoc"
+echo "Disable install Doc.: $my_disableinstalldoc"
echo "Build Source Doc. : $my_buildsourcedoc"
echo "Set Terminal Title : $my_settitle"
echo "Build csv2yapet : $my_buildcsv2yapet"

View File

@ -1,39 +0,0 @@
--- doc/Makefile.am 2009-07-12 12:55:26.000000000 +0200
+++ doc/Makefile.am 2009-07-19 16:57:52.880643243 +0200
@@ -1,16 +1,18 @@
#
+if !DISABLEINSTALLDOC
htmldoc_DATA = README.html DESIGN.html yapet.html
if BUILDCSV2YAPET
htmldoc_DATA += csv2yapet.html
-endif
+endif # BUILDCSV2YAPET
htmldocdir = $(docdir)/html
dist_man1_MANS = yapet.1
if BUILDCSV2YAPET
dist_man1_MANS += csv2yapet.1
-endif
+endif # BUILDCSV2YAPET
+endif # !DISABLEINSTALLDOC
sed_files = README.sgml.in INSTALL.sgml.in DESIGN.sgml.in yapet.sgml.in \
csv2yapet.sgml.in README.Cygwin.sgml.in
@@ -91,6 +93,7 @@
endif # HAVEDOXYGEN
+if !DISABLEINSTALLDOC
if BUILDDOC
if BUILDSOURCEDOC
@@ -106,6 +109,7 @@
endif #BUILDSOURCEDOC
endif # BUILDDOC
+endif # !DISABLEINSTALLDOC
maintainer-clean-local:
rm -rf source-doc

View File

@ -1,5 +1,4 @@
YAPET is a curses based password encryption tool using the Blowfish
encryption algorithm to store the password records encrypted on
disk.
YAPET is a curses based password manager using the Blowfish encryption
algorithm to store passwords encrypted on disk.
WWW: http://www.guengel.ch/myapps/yapet/

View File

@ -2,21 +2,12 @@ bin/yapet
%%CSV2YAPET%%bin/csv2yapet
share/applications/yapet.desktop
%%NOPORTDOCS%%%%DOCSDIR%%/AUTHORS
%%NOPORTDOCS%%%%DOCSDIR%%/COPYING
%%NOPORTDOCS%%%%DOCSDIR%%/DESIGN
%%NOPORTDOCS%%%%DOCSDIR%%/README
%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
%%NOPORTDOCS%%%%DOCSDIR%%/html/DESIGN.html
%%NOPORTDOCS%%%%DOCSDIR%%/html/README.html
%%NOPORTDOCS%%%%DOCSDIR%%/html/yapet.html
%%NOPORTDOCS%%%%CSV2YAPET%%%%DOCSDIR%%/html/csv2yapet.html
%%NLS%%share/locale/de_AT/LC_MESSAGES/yapet.mo
%%NLS%%share/locale/de_CH/LC_MESSAGES/yapet.mo
%%NLS%%share/locale/de_DE/LC_MESSAGES/yapet.mo
@dirrmtry share/locale/de_DE/LC_MESSAGES
@dirrmtry share/locale/de_DE
@dirrmtry share/locale/de_CH/LC_MESSAGES
@dirrmtry share/locale/de_CH
%%NOPORTDOCS%%@dirrm %%DOCSDIR%%/html
%%NOPORTDOCS%%%%DOCSDIR%%/README
%%NOPORTDOCS%%%%DOCSDIR%%/THANKS
%%NLS%%share/locale/de/LC_MESSAGES/yapet.mo
@dirrmtry share/locale/de/LC_MESSAGES
@dirrmtry share/locale/de
%%NOPORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications