games/burrtools: minor improvements
- Unbundle lua 5.1 - Adjust category and fix icon path in .desktop file - Avoid overlinking FLTK dependencies - Integrate DragonFly fix - Drop unnecessary patch - Drop unused xmlwrapp dependency - Convert to USES=localbase - Pacify stage-qa (shared libs) - Pacify portlint (regen patches)
This commit is contained in:
parent
c2aa416155
commit
562522c625
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416148
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= burrtools
|
||||
PORTVERSION= 0.6.3
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF
|
||||
|
||||
@ -15,31 +15,33 @@ LICENSE= GPLv3
|
||||
BUILD_DEPENDS= netpbm>0:graphics/netpbm
|
||||
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
|
||||
libpng.so:graphics/png \
|
||||
libxmlwrapp.so:textproc/xmlwrapp \
|
||||
libfltk.so:x11-toolkits/fltk
|
||||
|
||||
USES= gmake
|
||||
USE_XORG= x11 xt xext xmu xi
|
||||
USE_GL= glu
|
||||
USES= gmake localbase lua:51
|
||||
USE_GL= gl glu
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= ac_cv_lib_ICE_IceConnectionNumber="no" \
|
||||
ac_cv_search_glutInit="none required"
|
||||
CONFIGURE_ARGS= --disable-silent-rules
|
||||
MAKE_ARGS= am_lua_liblua_a_OBJECTS='lua/luaclass.$$(OBJEXT)'
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
|
||||
LDFLAGS+= -Wl,--as-needed # fltk deps
|
||||
LIBS+= -llua-${LUA_VER} -lboost_system # _ZN5boost6system15system_categoryEv
|
||||
|
||||
PORTDOCS= *
|
||||
PORTEXAMPLES= *
|
||||
PLIST_FILES= bin/burrTxt bin/burrTxt2 bin/burrGui \
|
||||
share/pixmaps/burricons.png
|
||||
|
||||
DESKTOP_ENTRIES="BurrGui" "" "${PREFIX}/pixmaps/burricons.png" "burrGui" "" ""
|
||||
DESKTOP_ENTRIES="BurrGui" "" "burricons" "burrGui" "Game;LogicGame;" ""
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/GL_X_LIBS/d' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|g++ |$$(CXX) | ; \
|
||||
s|-O2 |$$(CXXFLAGS) |' ${WRKSRC}/src/Makefile.in
|
||||
s|-O2 |$$(CXXFLAGS) $$(LDFLAGS) |' ${WRKSRC}/src/Makefile.in
|
||||
|
||||
post-build:
|
||||
(cd ${WRKSRC} && ${CAT} burricons.ico | winicontoppm -bestqual | \
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/halfedge/polyhedron.cpp.orig 2011-07-23 21:04:15.000000000 +0400
|
||||
+++ src/halfedge/polyhedron.cpp 2014-02-19 09:19:56.242568734 +0400
|
||||
@@ -206,12 +206,12 @@
|
||||
--- src/halfedge/polyhedron.cpp.orig 2013-05-08 19:02:06 UTC
|
||||
+++ src/halfedge/polyhedron.cpp
|
||||
@@ -206,12 +206,12 @@ void Polyhedron::finalize(void)
|
||||
// add the edge, to make sure we don't process it again
|
||||
handeled.insert(idx);
|
||||
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- ./src/help/data2c.cpp.orig 2010-10-09 07:48:30.000000000 -0400
|
||||
+++ ./src/help/data2c.cpp 2010-11-11 20:19:35.000000000 -0500
|
||||
@@ -48,6 +48,9 @@
|
||||
fprintf(out, "\\x%02x", c);
|
||||
}
|
||||
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <libgen.h>
|
||||
+#else
|
||||
#if defined(WIN32) || defined(__APPLE__)
|
||||
const char * basename(const char * n) {
|
||||
|
||||
@@ -62,6 +65,7 @@
|
||||
return n;
|
||||
}
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
|
||||
/* first param: output file name
|
@ -1,23 +1,14 @@
|
||||
--- ./src/lib/stl.cpp.orig 2010-10-09 07:48:31.000000000 -0400
|
||||
+++ ./src/lib/stl.cpp 2010-11-11 20:19:35.000000000 -0500
|
||||
@@ -40,6 +40,9 @@
|
||||
* The concrete classes do the grid dependend stuff and add lots of triangles to the file
|
||||
*/
|
||||
--- src/lib/stl.cpp.orig 2013-05-08 19:02:06 UTC
|
||||
+++ src/lib/stl.cpp
|
||||
@@ -54,6 +54,8 @@ const char * basename(const char * name)
|
||||
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <libgen.h>
|
||||
+#else
|
||||
#if defined(WIN32) || defined(__APPLE__)
|
||||
const char * basename(const char * name) {
|
||||
const char * res1 = strchr(name, '/');
|
||||
@@ -55,6 +58,7 @@
|
||||
return res;
|
||||
}
|
||||
+#else
|
||||
+#include <libgen.h>
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
|
||||
void stlExporter_c::write(const char * fname, const voxel_c & v, const faceList_c & holes)
|
||||
@@ -62,7 +64,7 @@ void stlExporter_c::write(const char * f
|
||||
FILE * f;
|
||||
unsigned long triangleCount = 0;
|
||||
|
Loading…
Reference in New Issue
Block a user