- Retire net/tintin++-devel
PR: ports/146736 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet AT sunpoet.net> (maintainer)
This commit is contained in:
parent
c0a263541f
commit
55eb538034
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=259884
@ -1056,7 +1056,6 @@
|
||||
SUBDIR += throttled
|
||||
SUBDIR += tightvnc
|
||||
SUBDIR += tintin++
|
||||
SUBDIR += tintin++-devel
|
||||
SUBDIR += tinyfugue
|
||||
SUBDIR += tinyldap
|
||||
SUBDIR += tn5250
|
||||
|
@ -1,44 +0,0 @@
|
||||
# New ports collection makefile for: tintin++
|
||||
# Date created: 15 Nov 1994
|
||||
# Whom: ache
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= tintin++
|
||||
PORTVERSION= 2.00.1
|
||||
CATEGORIES+= net games
|
||||
MASTER_SITES= GOOGLE_CODE
|
||||
DISTNAME= tintin-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sunpoet@sunpoet.net
|
||||
COMMENT= A client program to help playing MUDs
|
||||
|
||||
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
|
||||
|
||||
CONFIGURE_ARGS+=--includedir=${LOCALBASE}/include --libdir=${LOCALBASE}/lib \
|
||||
--prefix=${PREFIX}
|
||||
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
GNU_CONFIGURE= yes
|
||||
PLIST_FILES= bin/tt++
|
||||
PORTDOCS= ${DOCS:T}
|
||||
USE_GMAKE= yes
|
||||
WRKSRC= ${WRKDIR}/tt/src
|
||||
|
||||
DOCS= CREDITS FAQ README SCRIPTS TODO \
|
||||
docs/chat_protocol.txt docs/tintin19.txt
|
||||
PROJECTHOST= tintin-mud-client
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${INSTALL} -d ${DOCSDIR}
|
||||
@cd ${WRKSRC}/.. && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (tintin-2.00.1.tar.gz) = 5bc8d0f4df124f7fe01a5904084ae01b
|
||||
SHA256 (tintin-2.00.1.tar.gz) = 0dc1f6805a2e408e6733504310d006bc2f98bd7ff23ff365c570cdb1ac016bef
|
||||
SIZE (tintin-2.00.1.tar.gz) = 241875
|
@ -1,18 +0,0 @@
|
||||
--- ./configure.orig 2009-07-22 10:02:23.000000000 -0400
|
||||
+++ ./configure 2009-07-22 10:02:40.000000000 -0400
|
||||
@@ -6176,11 +6176,11 @@
|
||||
{ { $as_echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
$as_echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
{ (exit 1); exit 1; }; }
|
||||
-if test -r "/dev/ptmx"; then
|
||||
- ac_cv_file__dev_ptmx=yes
|
||||
-else
|
||||
+#if test -r "/dev/ptmx"; then
|
||||
+# ac_cv_file__dev_ptmx=yes
|
||||
+#else
|
||||
ac_cv_file__dev_ptmx=no
|
||||
-fi
|
||||
+#fi
|
||||
fi
|
||||
{ $as_echo "$as_me:$LINENO: result: $ac_cv_file__dev_ptmx" >&5
|
||||
$as_echo "$ac_cv_file__dev_ptmx" >&6; }
|
@ -1,9 +0,0 @@
|
||||
TinTin++ is a console MUD client for Windows, Linux, and Mac OS X. Its main
|
||||
assets are an easy to learn and use scripting language, full telnet support,
|
||||
a split screen interface to separate mud output from client input, and
|
||||
keyboard macros that work on all systems.
|
||||
|
||||
TinTin++ projet is now hosted on Google Code sine version 1.99.6b1.
|
||||
|
||||
WWW: http://tintin.sourceforge.net/
|
||||
http://code.google.com/p/tintin-mud-client
|
Loading…
Reference in New Issue
Block a user