autozen is a GTK+ based program to adjust brain waves with sound.

Spooky, eh? :)

PR:		21311
Submitted by:	Trevor Johnson <trevor@jpj.net>
This commit is contained in:
Ade Lovett 2000-09-16 17:29:55 +00:00
parent d5b5af0c11
commit 55dfa65e52
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32704
8 changed files with 93 additions and 0 deletions

View File

@ -5,6 +5,7 @@
SUBDIR += amp
SUBDIR += ascd
SUBDIR += aumix
SUBDIR += autozen
SUBDIR += bladeenc
SUBDIR += btc
SUBDIR += cam

42
audio/autozen/Makefile Normal file
View File

@ -0,0 +1,42 @@
# New ports collection makefile for: autozen
# Date created: 2000-09-16
# Whom: Trevor Johnson <trevor@jpj.net>
#
# $FreeBSD$
#
PORTNAME= autozen
PORTVERSION= 1.2.1
CATEGORIES= audio
MASTER_SITES= http://www.linuxlabs.com/software/download/
DISTNAME= AutoZen-${PORTVERSION}
MAINTAINER= trevor@jpj.net
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
USE_X_PREFIX= yes
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
MAKE_ENV= GTK_CONFIG=${GTK_CONFIG}
WRKSRC= ${WRKDIR}/${PORTNAME}-1.2
DOC_FILES= CHANGES COPYING
DATA_FILES= deep-relax.seq relax.seq test.seq test2.seq test3.seq
post-patch:
@${PERL} -pi -e "s=X11BASE=${X11BASE}=g" ${WRKSRC}/autozen.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/autozen ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/seq2wav ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/autozen
.for i in ${DATA_FILES}
${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/autozen
.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/autozen
.for i in ${DOC_FILES}
${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/autozen
.endfor
.endif
.include <bsd.port.mk>

1
audio/autozen/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (AutoZen-1.2.1.tar.gz) = eee6e6513181a6837fa2b33bfc06cdce

View File

@ -0,0 +1,11 @@
--- Makefile.orig Sun Sep 10 22:57:32 2000
+++ Makefile Sat Sep 16 13:47:33 2000
@@ -7,7 +7,7 @@
autozen: autozen.c *.xpm
- $(CC) -D_REENTRANT $(CFLAGS) -I/usr/local/lib/glib/include/ `gtk-config --cflags` `gtk-config --libs` -pthread autozen.c -o autozen $(DEBUG_LIBS)
+ $(CC) -D_REENTRANT $(CFLAGS) -I/usr/local/lib/glib/include/ `$(GTK_CONFIG) --cflags` `$(GTK_CONFIG) --libs` -pthread autozen.c -o autozen $(DEBUG_LIBS)
seq2wav: seq2wav.c
$(CC) seq2wav.c -o seq2wav -lm

View File

@ -0,0 +1,11 @@
--- autozen.c.orig Sat Sep 16 14:01:23 2000
+++ autozen.c Sat Sep 16 14:07:48 2000
@@ -199,7 +199,7 @@
/* Lets set the filename, as if this were a save dialog, and we are giving
a default filename */
gtk_file_selection_set_filename (GTK_FILE_SELECTION(filew),
- "*.seq");
+ "X11BASE/share/autozen/*.seq");
gtk_widget_show(filew);
}

View File

@ -0,0 +1 @@
Adjust brain waves with sound

15
audio/autozen/pkg-descr Normal file
View File

@ -0,0 +1,15 @@
adapted from the Web page:
AutoZen generates sounds meant to cause the user's brain waves to
shift to a different dominant frequency, resulting in an altered
state of consciousness. If you are under treatment for any
psychiatric or neurological disorder, you might want to approach
this with caution. You must use headphones for AutoZen to work at
all. The effect depends on each ear receiving a different tone,
and the combination of the inputs in the brain. If you are deaf
in one ear, it will not work.
WWW: http://www.linuxlabs.com/software/AutoZen.html
Trevor Johnson
trevor@jpj.net

11
audio/autozen/pkg-plist Normal file
View File

@ -0,0 +1,11 @@
bin/autozen
bin/seq2wav
share/autozen/deep-relax.seq
share/autozen/relax.seq
share/autozen/test.seq
share/autozen/test2.seq
share/autozen/test3.seq
share/doc/autozen/CHANGES
share/doc/autozen/COPYING
@dirrm share/doc/autozen
@dirrm share/autozen