MFH: r520212 textproc/py-genshi: Update to 0.7.3

Genshi 0.7 doesn't support Python 3.5+, but the port currently allows it
to be built with any Python version. This doesn't affect the build, but
produces a broken runtime, including for all Genshi dependents:

Genshi (0.7) tests:

  2.7: Ran 854 tests in 3.623s - FAILED (failures=1)
  3.5: Ran 858 tests in 3.607s - FAILED (failures=4, errors=34)
  3.6: Ran 858 tests in 3.610s - FAILED (failures=4, errors=34)
  3.7: Ran 858 tests in 3.313s - FAILED (failures=11, errors=91)
  3.8: Ran 858 tests in 3.094s - FAILED (failures=32, errors=359)

Genshi added 3.5+ support in subsequent versions [1]:

  0.7.2: Add support for Python 3.8.
  0.7.1: Add support for Python 3.5, 3.6 and 3.7

Given Genshi 0.7 -> 0.7.3 involves only additional Python version support
and bugfix-only changes, this change updates the port to 0.7.3, instead of
restricting (correctly) its use to USES=python:-3.4, and is intended to be
merged to the quarterly branch accordingly.

While I'm here:

  - Add test target to encourage and ease future QA
  - Strip speedup shared library on Python versions it builds in
  - Remove backported patch to setup.py (now in this release)
  - Use CHEESESHOP and update COMMENT according to Python policies

Genshi (0.7.3) QA tests:

  2.7: Ran 861 tests in 3.626s - OK
  3.5: Ran 867 tests in 3.561s - OK
  3.6: Ran 867 tests in 3.540s - OK
  3.7: Ran 867 tests in 3.268s - OK
  3.8: Ran 867 tests in 3.267s - OK

[1] https://github.com/edgewall/genshi/blob/0.7.3/ChangeLog

Approved by:	portmgr (blanket(s): runtime bugfix, ports (python) compliance)

Approved by:	ports-secteam (blanket(s): runtime bugfix, bugfix release)
This commit is contained in:
Kubilay Kocak 2019-12-20 10:21:47 +00:00
parent 53f70e684d
commit 55c3fef16a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q4/; revision=520496
3 changed files with 24 additions and 29 deletions

View File

@ -2,24 +2,35 @@
# $FreeBSD$
PORTNAME= Genshi
PORTVERSION= 0.7
PORTREVISION= 2
#PORTEPOCH= 0
PORTVERSION= 0.7.3
CATEGORIES= textproc www python
MASTER_SITES= http://ftp.edgewall.com/pub/${PORTNAME:tl}/
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Python toolkit for stream-based generation of output for the web
COMMENT= Toolkit for generation of output for the web
LICENSE= BSD3CLAUSE
OPTIONS_DEFINE= BABEL
BABEL_DESC= I18n support through the Babel plugin
LICENSE_FILE= ${WRKSRC}/COPYING
USES= python
USE_PYTHON= distutils autoplist
BABEL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0.9.6:devel/py-babel@${PY_FLAVOR}
OPTIONS_DEFINE= BABEL
BABEL_DESC= I18n support through the Babel plugin
.include <bsd.port.mk>
BABEL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0.8:devel/py-babel@${PY_FLAVOR}
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.pre.mk>
.if ${PYTHON_VER} < 3.3
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/genshi/*.so
.else
NO_ARCH= yes
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +1,3 @@
SHA256 (Genshi-0.7.tar.gz) = 1d154402e68bc444a55bcac101f96cb4e59373100cc7a2da07fbf3e5cc5d7352
SIZE (Genshi-0.7.tar.gz) = 491579
TIMESTAMP = 1576467154
SHA256 (Genshi-0.7.3.tar.gz) = 7933c95151d7dd2124a2b4c8dd85bb6aec881ca17c0556da0b40e56434b313a0
SIZE (Genshi-0.7.3.tar.gz) = 271238

View File

@ -1,17 +0,0 @@
--- setup.py.orig 2013-01-27 15:48:03 UTC
+++ setup.py
@@ -65,9 +65,13 @@ available.""")
if Feature:
+ # Optional C extension module for speeding up Genshi:
+ # Not activated by default on:
+ # - PyPy (where it harms performance)
+ # - CPython >= 3.3 (the new Unicode C API is not supported yet)
speedups = Feature(
"optional C speed-enhancements",
- standard = not is_pypy,
+ standard = not is_pypy and sys.version_info < (3, 3),
ext_modules = [
Extension('genshi._speedups', ['genshi/_speedups.c']),
],