- Update to 2.3.0
- Add my LOCAL to MASTER_SITES - Use USE_GNOME=gnomehack - Use REINPLACE_CMD for patches - Cleanup Makefile Changes: - Rough WebM support - Removed the shout-config script
This commit is contained in:
parent
8e60487fda
commit
55bd5d7605
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=295686
@ -1,16 +1,16 @@
|
||||
# New ports collection makefile for: libshout
|
||||
# Date created: 06 Jun 2000
|
||||
# Whom: Zach Zurflu <zach@pabst.bendnet.com>
|
||||
# Date created: 06 Jun 2000
|
||||
# Whom: Zach Zurflu <zach@pabst.bendnet.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libshout2
|
||||
PORTVERSION= 2.2.2
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 2.3.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= audio net
|
||||
MASTER_SITES= http://downloads.xiph.org/releases/libshout/
|
||||
MASTER_SITES= http://downloads.xiph.org/releases/libshout/ \
|
||||
LOCAL/sunpoet
|
||||
DISTNAME= libshout-${PORTVERSION}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
@ -20,21 +20,22 @@ LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
|
||||
theora.0:${PORTSDIR}/multimedia/libtheora \
|
||||
vorbis.4:${PORTSDIR}/audio/libvorbis
|
||||
|
||||
CONFLICTS= libshout-[0-9]*
|
||||
|
||||
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
|
||||
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
|
||||
USE_LDCONFIG= yes
|
||||
USE_GMAKE= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
USE_GNOME+= pkgconfig
|
||||
GNU_CONFIGURE= yes
|
||||
CONFLICTS= libshout-1.0.7
|
||||
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
|
||||
MAKE_JOBS_SAFE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack pkgconfig
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/libshout
|
||||
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} -e "s|-ffast-math||g" ${WRKSRC}/configure
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e "s|pkgconfigdir =.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g" \
|
||||
${WRKSRC}/Makefile
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-ffast-math||g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|^Requires: |Requires.private: |' ${WRKSRC}/shout.pc.in
|
||||
@${REINPLACE_CMD} -e '/^AM_CPPFLAGS = / s|^\(.*\) \(@XIPH_CPPFLAGS@\) \(.*\)$$|\1 \3 \2|' ${WRKSRC}/examples/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|#ifdef IPV6_V6ONLY|#if defined(__BSD_VISIBLE) \&\& defined(IPV6_V6ONLY)|' ${WRKSRC}/src/net/sock.c
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (libshout-2.2.2.tar.gz) = 912a1fdb12d31af757e7881db49321e5b5240bd8bd4199e9fb0ce16d66568160
|
||||
SIZE (libshout-2.2.2.tar.gz) = 476564
|
||||
SHA256 (libshout-2.3.0.tar.gz) = a4ed39f3eeaa0bbf1ead0a96d6b072e989acef32a2d00f1798649878c48ca176
|
||||
SIZE (libshout-2.3.0.tar.gz) = 462223
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- examples/Makefile.in.orig Sun Apr 3 23:38:30 2005
|
||||
+++ examples/Makefile.in Sun Apr 3 23:38:52 2005
|
||||
@@ -222,7 +222,7 @@
|
||||
nonblocking_SOURCES = nonblocking.c
|
||||
nonblocking_LDADD = $(top_builddir)/src/libshout.la
|
||||
AM_CFLAGS = @XIPH_CFLAGS@
|
||||
-AM_CPPFLAGS = @XIPH_CPPFLAGS@ -I$(top_builddir)/include
|
||||
+AM_CPPFLAGS = -I$(top_builddir)/include @XIPH_CPPFLAGS@
|
||||
all: all-am
|
||||
|
||||
.SUFFIXES:
|
@ -1,10 +0,0 @@
|
||||
--- shout.pc.in.orig 2007-12-11 14:35:45.000000000 +0100
|
||||
+++ shout.pc.in 2007-12-11 14:35:56.000000000 +0100
|
||||
@@ -10,6 +10,6 @@
|
||||
Name: Shout
|
||||
Description: Audio streaming library for icecast encoders
|
||||
Version: @VERSION@
|
||||
-Requires: @SHOUT_REQUIRES@
|
||||
+Requires.private: @SHOUT_REQUIRES@
|
||||
Libs: -L${libdir} -lshout
|
||||
Cflags: -I${includedir} @PTHREAD_CPPFLAGS@ @SHOUT_CFLAGS@
|
@ -1,22 +0,0 @@
|
||||
--- src/Makefile.am.orig 2006-01-03 20:22:17.000000000 +0100
|
||||
+++ src/Makefile.am 2006-05-28 18:37:22.000000000 +0200
|
||||
@@ -26,7 +26,7 @@
|
||||
AM_CFLAGS = @XIPH_CFLAGS@
|
||||
|
||||
libshout_la_LIBADD = net/libicenet.la timing/libicetiming.la avl/libiceavl.la\
|
||||
- httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS)
|
||||
+ httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(SPEEX_LIBS) $(VORBIS_LIBS)
|
||||
|
||||
INCLUDES = -I$(top_builddir)/include
|
||||
|
||||
--- src/Makefile.in.orig 2006-01-03 20:24:29.000000000 +0100
|
||||
+++ src/Makefile.in 2006-05-28 18:37:56.000000000 +0200
|
||||
@@ -261,7 +261,7 @@
|
||||
libshout_la_SOURCES = shout.c util.c ogg.c vorbis.c mp3.c $(MAYBE_THEORA) $(MAYBE_SPEEX)
|
||||
AM_CFLAGS = @XIPH_CFLAGS@
|
||||
libshout_la_LIBADD = net/libicenet.la timing/libicetiming.la avl/libiceavl.la\
|
||||
- httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS)
|
||||
+ httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(SPEEX_LIBS) $(VORBIS_LIBS)
|
||||
|
||||
INCLUDES = -I$(top_builddir)/include
|
||||
all: all-recursive
|
Loading…
Reference in New Issue
Block a user