irc/hexchat: update to 2.14.3, change maintainer to my FreeBSD.org address, regenerate patches, add USES=localbase
Changelog: fix various incorrect parsing of IRC messages relating to trailing parameters fix SASL negotiation combined with multi-line cap fix input box theming with Yaru theme python: Work around Python 3.7 regression causing crash on unload sysinfo: Add support for /etc/os-release sysinfo: Ignore irrelevant mounts when calculating storage size
This commit is contained in:
parent
970160af3c
commit
559a7050dc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=520626
@ -2,12 +2,11 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= hexchat
|
||||
PORTVERSION= 2.14.2
|
||||
PORTVERSION= 2.14.3
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= irc gnome
|
||||
|
||||
MAINTAINER= pkubaj@anongoth.pl
|
||||
MAINTAINER= pkubaj@FreeBSD.org
|
||||
COMMENT= IRC chat program with GTK and Text Frontend
|
||||
|
||||
LICENSE= GPLv2+
|
||||
@ -21,7 +20,8 @@ LIB_DEPENDS= libproxy.so:net/libproxy \
|
||||
RUN_DEPENDS= ${LOCALBASE}/share/xml/iso-codes/iso_639.xml:misc/iso-codes
|
||||
|
||||
USES= compiler:c++11-lang desktop-file-utils gettext-tools gnome \
|
||||
libtool meson ninja pkgconfig python:3.5+ shebangfix ssl xorg
|
||||
libtool localbase meson ninja pkgconfig python:3.5+ shebangfix \
|
||||
ssl xorg
|
||||
USE_GNOME= cairo gtk20 intltool libxml2
|
||||
USE_XORG= x11
|
||||
USE_GITHUB= yes
|
||||
@ -30,8 +30,7 @@ MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true -Dwith-python=python-${PYTHON_VER}
|
||||
INSTALLS_ICONS= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib -lX11
|
||||
LIBS+= -lX11
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1535716329
|
||||
SHA256 (hexchat-hexchat-v2.14.2_GH0.tar.gz) = 4f2c2137020913513ea559f788c41039ca6230764d8158862d5d1ee8785592d9
|
||||
SIZE (hexchat-hexchat-v2.14.2_GH0.tar.gz) = 2759172
|
||||
TIMESTAMP = 1577021248
|
||||
SHA256 (hexchat-hexchat-v2.14.3_GH0.tar.gz) = 3e32b120a0fde6a3949cc9d2b87b00534e11c150b3249830736e7f86b050343a
|
||||
SIZE (hexchat-hexchat-v2.14.3_GH0.tar.gz) = 2759502
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- meson.build.orig 2018-03-14 02:26:31 UTC
|
||||
--- meson.build.orig 2019-12-21 06:38:06 UTC
|
||||
+++ meson.build
|
||||
@@ -16,11 +16,21 @@ cc = meson.get_compiler('c')
|
||||
libgio_dep = dependency('gio-2.0', version: '>= 2.34.0')
|
||||
@ -23,7 +23,7 @@
|
||||
endif
|
||||
|
||||
config_h = configuration_data()
|
||||
@@ -49,7 +59,7 @@ config_h.set('GLIB_VERSION_MIN_REQUIRED'
|
||||
@@ -49,7 +59,7 @@ config_h.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSIO
|
||||
config_h.set('HAVE_MEMRCHR', cc.has_function('memrchr'))
|
||||
config_h.set('HAVE_STRINGS_H', cc.has_header('strings.h'))
|
||||
|
||||
@ -32,7 +32,7 @@
|
||||
config_h.set('HAVE_X509_GET_SIGNATURE_NID',
|
||||
cc.has_function('X509_get_signature_nid', dependencies: libssl_dep)
|
||||
)
|
||||
@@ -131,9 +141,6 @@ global_ldflags = []
|
||||
@@ -129,9 +139,6 @@ global_ldflags = []
|
||||
test_ldflags = [
|
||||
'-Wl,-z,relro',
|
||||
'-Wl,-z,now',
|
||||
@ -41,4 +41,4 @@
|
||||
- '-Wl,--nxcompat',
|
||||
]
|
||||
foreach ldflag : test_ldflags
|
||||
if cc.has_argument(ldflag) and cc.links('int main (void) { return 0; }', args: ldflag)
|
||||
if meson.version().version_compare('>= 0.46.0')
|
||||
|
@ -1,18 +1,18 @@
|
||||
--- plugins/sysinfo/meson.build.orig 2018-05-07 13:58:41 UTC
|
||||
--- plugins/sysinfo/meson.build.orig 2019-12-22 13:48:33 UTC
|
||||
+++ plugins/sysinfo/meson.build
|
||||
@@ -13,13 +13,13 @@ sysinfo_includes = []
|
||||
sysinfo_cargs = []
|
||||
|
||||
system = host_machine.system()
|
||||
-if system == 'linux' or system == 'darwin'
|
||||
+if system == 'linux' or system == 'darwin' or system == 'freebsd'
|
||||
-if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'darwin'
|
||||
+if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'darwin' or system == 'freebsd'
|
||||
sysinfo_includes += 'shared'
|
||||
sysinfo_sources += [
|
||||
'shared/df.c'
|
||||
]
|
||||
|
||||
- if system == 'linux'
|
||||
+ if system == 'linux' or system == 'freebsd'
|
||||
- if system == 'linux' or system == 'gnu' or system.startswith('gnu/')
|
||||
+ if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'freebsd'
|
||||
libpci = dependency('libpci', required: false, method: 'pkg-config')
|
||||
if libpci.found()
|
||||
sysinfo_deps += libpci
|
||||
|
Loading…
Reference in New Issue
Block a user