Update to version 1.2.3

PR:		13960
Submitted by:	maintainer
This commit is contained in:
Chris Piazza 1999-10-01 18:06:34 +00:00
parent b03b8f56d9
commit 55754847d0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22104
7 changed files with 65 additions and 32 deletions

View File

@ -1,5 +1,5 @@
# New ports collection makefile for: bgrab
# Version required: 1.1
# Version required: 1.2.3
# Date created: 27 July 1999
# Whom: Kelly Yancey <kbyanc@posi.net>
#
@ -7,11 +7,20 @@
#
DISTNAME= bgrab
PKGNAME= bgrab-1.1
PKGNAME= bgrab-1.2.3
CATEGORIES= news
MASTER_SITES= http://awwm.linuxberg.com/files/console/network/ \
MASTER_SITES= http://thelamb.dhs.org/~rael/bgrab/ \
http://awwm.linuxberg.com/files/console/network/ \
http://powerlinux.linuxberg.com/files/console/network/
MAINTAINER= kbyanc@posi.net
RUN_DEPENDS= mmencode:${PORTSDIR}/converters/mmencode
post-extract:
@${CP} ${FILESDIR}/Makefile.dist ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bgrab ${PREFIX}/bin
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (bgrab.tar.gz) = 8c41598154b89b2a0195884b43e83ac2
MD5 (bgrab.tar.gz) = a59c008be5f134565b4ba00b5ae511fe

View File

@ -0,0 +1,19 @@
OBJ = main.o server.o screen.o tree.o multipart.o grouplist.o \
findfile.o
CXX ?= g++
CXXFLAGS ?= -O6
LIBS = -lncurses
PREFIX ?= /usr/local
DEST = $(PREFIX)/bin
INSTALL ?= install
bgrab: $(OBJ) Makefile common.h
$(CXX) $(LIBS) -o bgrab $(OBJ)
clean:
rm -f $(OBJ) bgrab
install: bgrab
$(INSTALL) bgrab $(DEST)/bgrab
all: bgrab

View File

@ -1,27 +1,26 @@
diff -u -N ./main.cc ../bgrab/main.cc
--- ./main.cc Mon Feb 1 03:04:23 1999
+++ ../bgrab/main.cc Tue Jul 27 10:38:26 1999
@@ -9,7 +9,6 @@
--- main.cc.orig Thu Sep 30 09:20:30 1999
+++ main.cc Thu Sep 30 09:22:51 1999
@@ -7,7 +7,6 @@
#include <sys/types.h>
#include <sys/wait.h>
#include <stdlib.h>
-#include <curses.h>
}
extern "C++" {
@@ -19,7 +18,7 @@
#include "multipart.h"
}
#include "server.h"
#include "screen.h"
#include "tree.h"
@@ -15,7 +14,7 @@
#include "grouplist.h"
#include "findfile.h"
-#define NNTP_PORT 119
+unsigned NNTP_PORT = 119;
char *NNTP_SERVER = NULL;
char *NNTP_GROUP = NULL;
@@ -194,6 +193,10 @@
fprintf(stderr, "groupname newsgroup to read\n");
fprintf(stderr," -n don't output to stdout\n");
fprintf(stderr," -f fork to background. use only with -n\n");
groupListPointer NNTP_GROUP = new groupList();
@@ -249,6 +248,10 @@
fprintf(stderr," -a user pass Authenticate the login to the server with\n");
fprintf(stderr," 'user' as username and 'pass' as password.\n");
fprintf(stderr," Both username and password must be present.\n");
+ fprintf(stderr,"\nThe hostname or IP address of the news server can be\n");
+ fprintf(stderr,"specified by the NNTPSERVER environment variable, or defaults\n");
+ fprintf(stderr,"to \"news\". The port to connect to can be specified by the\n");
@ -29,8 +28,8 @@ diff -u -N ./main.cc ../bgrab/main.cc
exit(-1);
}
@@ -225,6 +228,8 @@
void main(int argc, char **argv) {
@@ -301,6 +304,8 @@
if (getenv("NNTPSERVER")) NNTP_SERVER = strdup(getenv("NNTPSERVER"));
else NNTP_SERVER = strdup("news");
+

View File

@ -1,10 +1,14 @@
diff -u -N ./screen.h ../bgrab/screen.h
--- ./screen.h Sun Jan 24 03:24:50 1999
+++ ../bgrab/screen.h Tue Jul 27 10:38:40 1999
@@ -1,5 +1,5 @@
extern "C" {
-#include <curses.h>
+#include <ncurses.h>
#include <stdio.h>
--- server.cc.orig Thu Sep 16 16:50:51 1999
+++ server.cc Thu Sep 16 17:00:39 1999
@@ -8,7 +8,10 @@
server::server(char *host, unsigned long port) {
inbuf = 0;
bzero(buf,BUFSIZE+1);
- soc = connectto(host,port);
+ if((soc = connectto(host,port)) == -1) {
+ fprintf(stderr, "Cannot connect to host \"%s\"\n", host);
+ exit(1);
+ }
}
int server::sockfd() {

View File

@ -1 +1 @@
Downloads binaries from newsgroups
Rael's Binary Grabber - downloads binaries from newsgroups

View File

@ -1,5 +1,7 @@
This is an automated binary extraction tool for UseNet newsgroups.
It will log into any newsgroup and download all the binary files.
-kbyanc
WWW: http://thelamb.dhs.org/~rael/bgrab/
-Kelly
kbyanc@posi.net