- Update devel/gmake to 4.2.

- deskutils/tomboy, devel/ocaml-deriving-ocsigen: patch Makefile bug.
- games/0ad: disable make jobs when building bundled Spidermonkey.

PR:		209868
Exp-run by:	antoine
Approved by:	portmgr (antoine)
This commit is contained in:
Tijl Coosemans 2016-06-05 14:35:02 +00:00
parent 380a95c8c8
commit 553ce7bd8e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416393
6 changed files with 39 additions and 12 deletions

View File

@ -36,7 +36,7 @@ EVOLUTION_DESC= Build evolution addin
# Restrict to stable (even) versions, indicated by the second component.
PORTSCOUT= limitw:1,even
.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEVOLUTION}
CONFIGURE_ARGS+=--enable-evolution
@ -51,5 +51,7 @@ PLIST_SUB+= EVOLUTION="@comment "
post-patch:
@${REINPLACE_CMD} 's|/bin/bash|/bin/sh|g' \
${WRKSRC}/Tomboy/tomboy*.in
@${REINPLACE_CMD} 's/(TARGET_NAME$$)/(TARGET_NAME)/' \
${WRKSRC}/Tomboy/Makefile.in
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gmake
PORTVERSION= 4.1
PORTREVISION= 2
PORTVERSION= 4.2
CATEGORIES= devel
MASTER_SITES= GNU/make
DISTNAME= make-${PORTVERSION}
@ -15,10 +14,14 @@ MAINTAINER= tijl@FreeBSD.org
COMMENT= GNU version of 'make' utility
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--program-prefix=g \
CONFIGURE_ARGS= --program-prefix=g \
--without-guile
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
# fmake does not like PO_DEPENDS_ON_POT being undefined
MAKE_ARGS= PO_DEPENDS_ON_POT=
USES= cpe makeinfo tar:bzip2
CPE_VENDOR= gnu
@ -31,8 +34,6 @@ NLS_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG} \
--with-libintl-prefix=${LOCALBASE}
NLS_CONFIGURE_ENABLE= nls
CONFIGURE_ENV+= MAKEINFO="makeinfo --no-split"
INFO= make
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (make-4.1.tar.bz2) = 0bc7613389650ee6a24554b52572a272f7356164fd2c4132b0bcf13123e4fca5
SIZE (make-4.1.tar.bz2) = 1327342
TIMESTAMP = 1464634898
SHA256 (make-4.2.tar.bz2) = 4e5ce3b62fe5d75ff8db92b7f6df91e476d10c3aceebf1639796dc5bfece655f
SIZE (make-4.2.tar.bz2) = 1400539

View File

@ -2,4 +2,4 @@ GNU make is a tool that controls the generation of executables and other
non-source files from source files. Its purpose is the same as that
of the utility make(1).
WWW: http://www.gnu.org/software/make/make.html
WWW: https://www.gnu.org/software/make/

View File

@ -0,0 +1,15 @@
--- syntax/Makefile.orig 2011-12-08 04:46:54 UTC
+++ syntax/Makefile
@@ -39,9 +39,9 @@ ifneq (${TYPECONV},)
MAIN_TC := pa_deriving_tc.ml
endif
-CLASSES_CMO := $(patsubst %.ml,classes/%.cmo$,${CLASSES})
-CLASSES_CMX := $(patsubst %.ml,classes/%.cmx$,${CLASSES})
-CLASSES_DEPS := $(patsubst %.ml,classes/.%.ml.deps$,${CLASSES})
+CLASSES_CMO := $(patsubst %.ml,classes/%.cmo,${CLASSES})
+CLASSES_CMX := $(patsubst %.ml,classes/%.cmx,${CLASSES})
+CLASSES_DEPS := $(patsubst %.ml,classes/.%.ml.deps,${CLASSES})
${CLASSES_CMO} ${CLASSES_CMX} ${CLASSES_DEPS}: \
LIBS+=-syntax camlp4o -package camlp4.quotations.o -I classes

View File

@ -1,6 +1,14 @@
--- libraries/source/spidermonkey/build.sh.orig 2015-01-24 14:46:52 UTC
--- libraries/source/spidermonkey/build.sh.orig 2015-09-30 20:28:13 UTC
+++ libraries/source/spidermonkey/build.sh
@@ -95,6 +95,14 @@ cd mozjs31/js/src
@@ -25,7 +25,6 @@ else
MAKE=${MAKE:="make"}
fi
-MAKE_OPTS="${JOBS}"
CONF_OPTS="--enable-shared-js --enable-gcgenerational --disable-tests --without-intl-api" # --enable-trace-logging"
@@ -82,6 +81,14 @@ cd js/src
rm -rf build-debug
rm -rf build-release