Update port to 0.6.7

PR:		16782
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
Chris D. Faulhaber 2000-02-18 03:24:20 +00:00
parent 21b18ef512
commit 551ac96ffd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25966
3 changed files with 16 additions and 14 deletions

View File

@ -1,12 +1,12 @@
# New ports collection makefile for: xenon
# Version required: 0.6.6
# Version required: 0.6.7
# Date created: 22 October 1999
# Whom: Chris D. Faulhaber <jedgar@fxp.org>
#
# $FreeBSD$
#
DISTNAME= xenon-0.6.6
DISTNAME= xenon-0.6.7
CATEGORIES= editors
MASTER_SITES= ftp://ftp.proximity.com.au/pub/xenon/
@ -25,9 +25,9 @@ do-configure:
@cd ${WRKSRC}; ${LN} -sf makefiles/Makefile.FreeBSD Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/xe ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/xe.1 ${PREFIX}/man/man1
${INSTALL_PROGRAM} ${WRKSRC}/xe ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xe.1 ${PREFIX}/man/man1
@${MKDIR} ${PREFIX}/share/examples/xe
@${INSTALL_DATA} ${WRKSRC}/xerc ${PREFIX}/share/examples/xe/sample.xerc
${INSTALL_DATA} ${WRKSRC}/xerc ${PREFIX}/share/examples/xe/sample.xerc
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (xenon-0.6.6.tar.gz) = c7f628966ea77bfdcb9ea98957e82508
MD5 (xenon-0.6.7.tar.gz) = 66ac7e29b53cbf764d0be3d470a6b188

View File

@ -1,6 +1,6 @@
--- makefiles/Makefile.FreeBSD.orig Fri Oct 22 00:20:20 1999
+++ makefiles/Makefile.FreeBSD Fri Oct 22 18:36:19 1999
@@ -6,18 +6,18 @@
--- makefiles/Makefile.FreeBSD.orig Wed Feb 16 22:55:41 2000
+++ makefiles/Makefile.FreeBSD Wed Feb 16 22:58:34 2000
@@ -6,19 +6,19 @@
include makefiles/Makefile.common
@ -9,22 +9,24 @@
#CC = /usr/local/bin/c++
-OPTIMIZER = -O2
+#OPTIMIZER = -O2
+OPTIMIZER = $(CXXFLAGS)
#ARCH = -b i586-pc-linux-gnulibc1
ARCH =
# For making a dso, add -fPIC
-CCFLAGS = $(OPTIMIZER) -pipe -Wall -fno-exceptions
+CCFLAGS = $(CXXFLAGS) $(CFLAGS)
+CCFLAGS = $(OPTIMIZER)
-INCLUDES = -I$(XEINC)
+INCLUDES = -I$(XEINC) -I/usr/X11R6/include
LIBS = -L/usr/X11R6/lib -lXpm -lX11
-LIBS = -L/usr/X11R6/lib -lXpm -lX11
+INCLUDES = -I$(XEINC) -I${X11BASE}/include
+LIBS = -L${X11BASE}/lib -lXpm -lX11
backup:
cd ..;tar -cvzf xenon.tar.gz $(BACKUP)
@@ -29,4 +29,3 @@
floppy:
cd ..;tar -cvzf /dev/fd0 $(BACKUP)
cd ..;tar -cvzf /dev/fd0 $(BACKUP)
--include $(DEPEND)