mail/postfix-current: update to 3.7-20210424
This commit is contained in:
parent
2cb658fd5d
commit
5511945c4f
@ -1,7 +1,7 @@
|
||||
# Created by: Torsten Blum <torstenb@FreeBSD.org>
|
||||
|
||||
PORTNAME= postfix
|
||||
DISTVERSION= 3.6-20210422
|
||||
DISTVERSION= 3.7-20210424
|
||||
PORTREVISION?= 0
|
||||
PORTEPOCH= 6
|
||||
CATEGORIES= mail
|
||||
@ -26,7 +26,7 @@ LICENSE_NAME_IPL10= IBM PUBLIC LICENSE VERSION 1.0
|
||||
LICENSE_PERMS_IPL10= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
CONFLICTS_INSTALL?= courier-0.* opensmtpd-[0-9]* sendmail-8.* sendmail+*-8.* \
|
||||
postfix-3.* postfix-base-3.* postfix-sasl-3.*
|
||||
postfix35-* postfix-3.* postfix-base-3.* postfix-sasl-3.*
|
||||
|
||||
USERS= postfix
|
||||
GROUPS= mail maildrop postfix
|
||||
@ -93,11 +93,7 @@ BROKEN_FreeBSD_11= error: OpenSSL-1.1.1 is the minimum supported version
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MINST_BASE}
|
||||
.if defined(SASL_SLAVE)
|
||||
PKGNAMESUFFIX= -current-base-sasl2
|
||||
.else
|
||||
PKGNAMESUFFIX= -current-base
|
||||
.endif
|
||||
PREFIX= /usr
|
||||
ETCDIR= /etc/postfix
|
||||
PLIST_SUB+= BMAN="share/"
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1619131050
|
||||
SHA256 (postfix/postfix-3.6-20210422.tar.gz) = 00f022dc4df7f72edd35443d0a704bc77de7f94e073f5ef41a7ae8489e4b77d4
|
||||
SIZE (postfix/postfix-3.6-20210422.tar.gz) = 4737710
|
||||
TIMESTAMP = 1619310933
|
||||
SHA256 (postfix/postfix-3.7-20210424.tar.gz) = c59177e9a7deaf8bc3303d22dd9161ffd8846081d23727217053306a4ea5e74b
|
||||
SIZE (postfix/postfix-3.7-20210424.tar.gz) = 4738620
|
||||
|
@ -1,6 +1,6 @@
|
||||
# PR 225664: support blacklistd on FreeBSD >= 11.0
|
||||
#
|
||||
--- src/smtpd/Makefile.in.orig 2019-01-27 22:17:15 UTC
|
||||
--- src/smtpd/Makefile.in.orig 2021-04-18 20:45:05 UTC
|
||||
+++ src/smtpd/Makefile.in
|
||||
@@ -2,14 +2,14 @@ SHELL = /bin/sh
|
||||
SRCS = smtpd.c smtpd_token.c smtpd_check.c smtpd_chat.c smtpd_state.c \
|
||||
@ -20,9 +20,9 @@
|
||||
TESTSRC = smtpd_token_test.c
|
||||
DEFS = -I. -I$(INC_DIR) -D$(SYSTYPE)
|
||||
CFLAGS = $(DEBUG) $(OPT) $(DEFS)
|
||||
--- src/smtpd/smtpd_sasl_glue.c.orig 2018-08-26 18:48:45 UTC
|
||||
--- src/smtpd/smtpd_sasl_glue.c.orig 2020-08-30 21:03:46 UTC
|
||||
+++ src/smtpd/smtpd_sasl_glue.c
|
||||
@@ -147,6 +147,7 @@
|
||||
@@ -149,6 +149,7 @@
|
||||
#include "smtpd.h"
|
||||
#include "smtpd_sasl_glue.h"
|
||||
#include "smtpd_chat.h"
|
||||
@ -30,7 +30,7 @@
|
||||
|
||||
#ifdef USE_SASL_AUTH
|
||||
|
||||
@@ -331,6 +332,10 @@ int smtpd_sasl_authenticate(SMTPD_ST
|
||||
@@ -350,6 +351,10 @@ int smtpd_sasl_authenticate(SMTPD_STATE *state,
|
||||
else
|
||||
smtpd_chat_reply(state, "535 5.7.8 Error: authentication failed: %s",
|
||||
STR(state->sasl_reply));
|
||||
@ -41,11 +41,11 @@
|
||||
return (-1);
|
||||
}
|
||||
/* RFC 4954 Section 6. */
|
||||
--- src/smtpd/pfilter.h.orig 2018-02-04 15:36:49 UTC
|
||||
--- src/smtpd/pfilter.h.orig 2021-05-06 19:00:00 UTC
|
||||
+++ src/smtpd/pfilter.h
|
||||
@@ -0,0 +1 @@
|
||||
+void pfilter_notify(int, int);
|
||||
--- src/smtpd/pfilter.c.orig 2018-02-04 15:36:49 UTC
|
||||
--- src/smtpd/pfilter.c.orig 2021-05-06 19:00:00 UTC
|
||||
+++ src/smtpd/pfilter.c
|
||||
@@ -0,0 +1,19 @@
|
||||
+#include "pfilter.h"
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- makedefs.orig 2020-09-30 21:22:49 UTC
|
||||
--- makedefs.orig 2021-04-24 20:49:37 UTC
|
||||
+++ makedefs
|
||||
@@ -309,6 +309,24 @@ case "$SYSTEM.$RELEASE" in
|
||||
: ${SHLIB_ENV="LD_LIBRARY_PATH=`pwd`/lib"}
|
||||
: ${PLUGIN_LD="${CC} -shared"}
|
||||
;;
|
||||
+ FreeBSD.13*) SYSTYPE=FREEBSD13
|
||||
+ FreeBSD.13*) SYSTYPE=FREEBSD13
|
||||
+ : ${CC=cc}
|
||||
+ : ${SHLIB_SUFFIX=.so}
|
||||
+ : ${SHLIB_CFLAGS=-fPIC}
|
||||
@ -13,7 +13,7 @@
|
||||
+ : ${SHLIB_ENV="LD_LIBRARY_PATH=`pwd`/lib"}
|
||||
+ : ${PLUGIN_LD="${CC} -shared"}
|
||||
+ ;;
|
||||
+ FreeBSD.14*) SYSTYPE=FREEBSD14
|
||||
+ FreeBSD.14*) SYSTYPE=FREEBSD14
|
||||
+ : ${CC=cc}
|
||||
+ : ${SHLIB_SUFFIX=.so}
|
||||
+ : ${SHLIB_CFLAGS=-fPIC}
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/tls/tls_server.c.orig 2018-12-26 19:21:49 UTC
|
||||
--- src/tls/tls_server.c.orig 2020-07-25 23:49:16 UTC
|
||||
+++ src/tls/tls_server.c
|
||||
@@ -518,7 +518,9 @@ TLS_APPL_STATE *tls_server_init(const TL
|
||||
@@ -502,7 +502,9 @@ TLS_APPL_STATE *tls_server_init(const TLS_SERVER_INIT_
|
||||
* ticket decryption callback already (since 2.11) asks OpenSSL to
|
||||
* avoid issuing new tickets when the presented ticket is re-usable.
|
||||
*/
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- src/util/sys_defs.h.orig 2020-05-21 13:34:23 UTC
|
||||
--- src/util/sys_defs.h.orig 2020-05-21 18:34:23 UTC
|
||||
+++ src/util/sys_defs.h
|
||||
@@ -30,7 +30,8 @@
|
||||
#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
|
||||
|
@ -1,5 +1,6 @@
|
||||
[
|
||||
{
|
||||
type: install
|
||||
message: <<EOM
|
||||
To use postfix instead of sendmail:
|
||||
- clear sendmail queue and stop the sendmail daemons
|
||||
@ -24,9 +25,9 @@ the sasldb file. This is accomplished by adding postfix to group mail and
|
||||
making the %%PREFIX%%/etc/sasldb* file(s) readable by group mail (this should
|
||||
be the default for new installs).
|
||||
EOM
|
||||
type: install
|
||||
}
|
||||
{
|
||||
type: upgrade
|
||||
message: <<EOM
|
||||
If you are upgrading from prior postfix version, please see the README
|
||||
files for recommended changes to your configuration and additional
|
||||
@ -48,13 +49,12 @@ Postfix-internal protocol such as qpsmtpd. Programs that depend on
|
||||
Postfix internal details are not supported.
|
||||
|
||||
EOM
|
||||
type: upgrade
|
||||
}
|
||||
{
|
||||
type: remove
|
||||
message: <<EOM
|
||||
If you remove postfix permanent, adjust / remove the the following file:
|
||||
- %%MC_PREFIX%%/etc/mail/mailer.conf
|
||||
EOM
|
||||
type: remove
|
||||
}
|
||||
]
|
||||
|
Loading…
Reference in New Issue
Block a user