Update to 4.1.3
Fix portaudio build link in setup.py there is no more portaudio2 Reported by: @portscout
This commit is contained in:
parent
d242816bf6
commit
54f3c7f108
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=429198
@ -2,10 +2,10 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= quisk
|
||||
PORTVERSION= 4.0.5
|
||||
PORTVERSION= 4.1.3
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= http://james.ahlstrom.name/quisk/ \
|
||||
LOCAL/shurd
|
||||
LOCAL/db
|
||||
|
||||
MAINTAINER= hamradio@FreeBSD.org
|
||||
COMMENT= Software Defined Radio (SDR)
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (quisk-4.0.5.tar.gz) = fc0a45012f5e47fa86ce11e8a55acecc4d2534e829c965face12f68fd8fc9992
|
||||
SIZE (quisk-4.0.5.tar.gz) = 2072511
|
||||
TIMESTAMP = 1482446629
|
||||
SHA256 (quisk-4.1.3.tar.gz) = 3bb41e3d5dd7feb4c949a6086fe4d2adad12048d5eccb6499ced85b2b46f5999
|
||||
SIZE (quisk-4.1.3.tar.gz) = 2093660
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- microphone.c.orig 2015-11-27 20:43:24 UTC
|
||||
--- microphone.c.orig 2016-10-25 20:57:54 UTC
|
||||
+++ microphone.c
|
||||
@@ -56,7 +56,7 @@ static int timeVOX = 2000; // VOX han
|
||||
|
||||
@ -8,4 +8,4 @@
|
||||
+static complex double TxCorrectDc;
|
||||
|
||||
// Used for the Hermes protocol
|
||||
#define HERMES_TX_BUF_SAMPLES 4800
|
||||
#define HERMES_TX_BUF_SAMPLES 4800 // buffer size in I/Q samples (two shorts)
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- setup.py.orig 2016-02-16 20:10:44 UTC
|
||||
--- setup.py.orig 2016-12-08 22:14:02 UTC
|
||||
+++ setup.py
|
||||
@@ -12,8 +12,8 @@ fp.write("#Quisk version %s\n" % Version
|
||||
fp.close()
|
||||
@ -6,8 +6,8 @@
|
||||
module1 = Extension ('quisk._quisk',
|
||||
- #include_dirs = ['.'],
|
||||
- #library_dirs = ['.'],
|
||||
+ include_dirs = ['%%LOCALBASE%%/include/portaudio2', '%%LOCALBASE%%/include'],
|
||||
+ library_dirs = ['%%LOCALBASE%%/lib/portaudio2', '%%LOCALBASE%%/lib'],
|
||||
+ include_dirs = ['%%LOCALBASE%%/include'],
|
||||
+ library_dirs = ['%%LOCALBASE%%/lib'],
|
||||
libraries = ['asound', 'portaudio', 'pulse', 'fftw3', 'm'],
|
||||
sources = ['quisk.c', 'sound.c', 'sound_alsa.c', 'sound_portaudio.c', 'sound_pulseaudio.c',
|
||||
'is_key_down.c', 'microphone.c', 'utility.c',
|
||||
|
Loading…
Reference in New Issue
Block a user