Adding cyrus-sasl version 1.5.13.
An RFC 2222 SASL (Simple Authentication and Security Layer). PR: 14619 Submitted by: Scot W. Hetzel <hetzels@westbend.net>
This commit is contained in:
parent
94160ce38d
commit
54ea5fa715
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24132
@ -9,6 +9,7 @@
|
||||
SUBDIR += chrootuid
|
||||
SUBDIR += cops
|
||||
SUBDIR += crack
|
||||
SUBDIR += cyrus-sasl
|
||||
SUBDIR += donkey
|
||||
SUBDIR += fakebo
|
||||
SUBDIR += firewalk
|
||||
|
97
security/cyrus-sasl/Makefile
Normal file
97
security/cyrus-sasl/Makefile
Normal file
@ -0,0 +1,97 @@
|
||||
# New ports collection makefile for: cyrus-sasl
|
||||
# Version required: 1.5.13
|
||||
# Date created: Nov 1 1999
|
||||
# Whom: hetzels@westbend.net
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= cyrus-sasl-${SASL_VER}
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
|
||||
http://www.freebsd.org/~stb/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/ \
|
||||
ftp://ftp.hanse.de/sites/transit/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/
|
||||
|
||||
MAINTAINER= hetzels@westbend.net
|
||||
|
||||
SASL_VER= 1.5.13
|
||||
|
||||
Y2K= http://asg.web.cmu.edu/cyrus/imapd/y2k.html
|
||||
|
||||
MAN1= sasl_client.1 sasl_server.1
|
||||
MAN8= saslpasswd.8
|
||||
|
||||
USE_LIBTOOL= YES
|
||||
CONFIGURE_ARGS= \
|
||||
--prefix=${PREFIX} \
|
||||
--sysconfdir=${PREFIX}/etc \
|
||||
--includedir=${PREFIX}/include/sasl \
|
||||
--with-plugindir=${PREFIX}/lib/sasl \
|
||||
--enable-static \
|
||||
--with-dbpath=${PREFIX}/etc/sasldb \
|
||||
--with-sample \
|
||||
--with-rc4
|
||||
|
||||
# --disable-cram
|
||||
|
||||
# Currently, pwcheck doesn't compile
|
||||
#CONFIGURE_ARGS+= \
|
||||
# --with-pwcheck=/var/pwcheck
|
||||
|
||||
# --with-dbpath=PATH set the DB path to use [/etc/sasldb]
|
||||
# --with-pam=DIR use PAM (rooted in DIR) [yes]
|
||||
# --with-pwcheck=DIR enable use of the pwcheck daemonusing statedir DIR
|
||||
# --enable-cram enable CRAM-MD5 authentication [yes]
|
||||
# --enable-scram enable SCRAM-MD5 authentication [no]
|
||||
# --enable-digest enable DIGEST-MD5 authentication [yes]
|
||||
# --enable-krb4 enable KERBEROS_V4 authentication [yes]
|
||||
# --enable-gssapi enable GSSAPI authentication [yes]
|
||||
# --enable-anon enable ANONYMOUS authentication [yes]
|
||||
# --enable-plain enable PLAIN authentication [yes]
|
||||
# --with-rc4=DIR use rc4 (look in DIR) [yes]
|
||||
|
||||
# Sample SASL Client/Server
|
||||
SAMPLES= sample-client sample-server
|
||||
INSTALL_PROG= ${INSTALL} -c -o root -g wheel -m 555
|
||||
|
||||
DOCS= README README.Y2K TODO INSTALL ChangeLog NEWS
|
||||
|
||||
DOC2= draft-newman-auth-scram-03.txt \
|
||||
draft-newman-sasl-anon-00.txt \
|
||||
draft-leach-digest-sasl-03.txt \
|
||||
rfc1321.txt rfc2095.txt rfc2104.txt rfc2222.txt
|
||||
|
||||
HTDOCS= index programming sysadmin
|
||||
|
||||
# Build the SASL library with RC4 support
|
||||
.if defined(USA_RESIDENT) && (${USA_RESIDENT} == YES)
|
||||
LIB_DEPENDS= rc4.0:${PORTSDIR}/security/librc4
|
||||
CONFIGURE_ARGS+= --with-rc4
|
||||
#CONFIGURE_ARGS+= --with-rc4=${PREFIX}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.for file in ${SAMPLES}
|
||||
${INSTALL_PROG} ${WRKSRC}/sample/${file} ${PREFIX}/sbin
|
||||
.endfor
|
||||
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
# ${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/SASL/html
|
||||
.for file in ${DOCS}
|
||||
@${ECHO} share/doc/SASL/${file} >>${TMPPLIST}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SASL
|
||||
.endfor
|
||||
.for file in ${DOC2}
|
||||
@${ECHO} share/doc/SASL/${file} >>${TMPPLIST}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/SASL
|
||||
.endfor
|
||||
.for file in ${HTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/${file}.html ${PREFIX}/share/doc/SASL/html
|
||||
@${ECHO} share/doc/SASL/html/${file}.html >>${TMPPLIST}
|
||||
.endfor
|
||||
@${ECHO} "@dirrm share/doc/SASL/html" >>${TMPPLIST}
|
||||
@${ECHO} "@dirrm share/doc/SASL" >>${TMPPLIST}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/cyrus-sasl/distinfo
Normal file
1
security/cyrus-sasl/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (cyrus-sasl-1.5.13.tar.gz) = 6bfa1ac9f34d30e36cc827667f657521
|
21
security/cyrus-sasl/files/patch-ab
Normal file
21
security/cyrus-sasl/files/patch-ab
Normal file
@ -0,0 +1,21 @@
|
||||
--- lib/Makefile.in.orig Thu Dec 2 14:11:14 1999
|
||||
+++ lib/Makefile.in Sun Dec 26 16:54:42 1999
|
||||
@@ -75,6 +75,7 @@
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
+INSTALL_LIB = @INSTALL_LIB@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
transform = @program_transform_name@
|
||||
|
||||
@@ -190,8 +191,8 @@
|
||||
$(mkinstalldirs) $(DESTDIR)$(libdir)
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
- echo "$(LIBTOOL) --mode=install $(INSTALL) $$p $(DESTDIR)$(libdir)/$$p"; \
|
||||
- $(LIBTOOL) --mode=install $(INSTALL) $$p $(DESTDIR)$(libdir)/$$p; \
|
||||
+ echo "$(LIBTOOL) --mode=install $(INSTALL_LIB) $$p $(DESTDIR)$(libdir)/$$p"; \
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_LIB) $$p $(DESTDIR)$(libdir)/$$p; \
|
||||
else :; fi; \
|
||||
done
|
||||
|
28
security/cyrus-sasl/files/pwcheck.sh
Normal file
28
security/cyrus-sasl/files/pwcheck.sh
Normal file
@ -0,0 +1,28 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
|
||||
PREFIX=/usr/local
|
||||
|
||||
case "$1" in
|
||||
|
||||
start)
|
||||
if [ -x ${PREFIX}/sbin/pwcheck ]
|
||||
then
|
||||
${PREFIX}/sbin/pwcheck & && echo -n " pwcheck"
|
||||
fi
|
||||
;;
|
||||
|
||||
stop)
|
||||
if [ -r /var/run/pwcheck.pid ]
|
||||
then
|
||||
kill `cat /var/run/pwcheck.pid` && echo -n " pwcheck"
|
||||
fi
|
||||
;;
|
||||
|
||||
*)
|
||||
echo "usage: $0 {start|stop}" 1>&2
|
||||
exit 64
|
||||
;;
|
||||
|
||||
esac
|
||||
|
1
security/cyrus-sasl/pkg-comment
Normal file
1
security/cyrus-sasl/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
RFC 2222 SASL (Simple Authentication and Security Layer)
|
11
security/cyrus-sasl/pkg-descr
Normal file
11
security/cyrus-sasl/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
The Cyrus SASL (Simple Authentication and Security Layer)
|
||||
|
||||
SASL is the Simple Authentication and Security Layer, a method
|
||||
for adding authentication support to connection-based protocols.
|
||||
To use SASL, a protocol includes a command for identifying and
|
||||
authenticating a user to a server and for optionally negotiating
|
||||
protection of subsequent protocol interactions. If its use is
|
||||
negotiated, a security layer is inserted between the protocol
|
||||
and the connection.
|
||||
|
||||
WWW: http://asg.web.cmu.edu/sasl/
|
28
security/cyrus-sasl/pkg-plist
Normal file
28
security/cyrus-sasl/pkg-plist
Normal file
@ -0,0 +1,28 @@
|
||||
include/sasl/hmac-md5.h
|
||||
include/sasl/md5.h
|
||||
include/sasl/md5global.h
|
||||
include/sasl/sasl.h
|
||||
include/sasl/saslplug.h
|
||||
include/sasl/saslutil.h
|
||||
@dirrm include/sasl
|
||||
lib/libsasl.a
|
||||
lib/libsasl.so
|
||||
lib/libsasl.so.7
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
lib/sasl/libanonymous.a
|
||||
lib/sasl/libanonymous.so
|
||||
lib/sasl/libanonymous.so.1
|
||||
lib/sasl/libcrammd5.a
|
||||
lib/sasl/libcrammd5.so
|
||||
lib/sasl/libcrammd5.so.1
|
||||
lib/sasl/libdigestmd5.a
|
||||
lib/sasl/libdigestmd5.so
|
||||
lib/sasl/libdigestmd5.so.0
|
||||
lib/sasl/libplain.a
|
||||
lib/sasl/libplain.so
|
||||
lib/sasl/libplain.so.1
|
||||
@dirrm lib/sasl
|
||||
sbin/saslpasswd
|
||||
sbin/sample-client
|
||||
sbin/sample-server
|
97
security/cyrus-sasl2/Makefile
Normal file
97
security/cyrus-sasl2/Makefile
Normal file
@ -0,0 +1,97 @@
|
||||
# New ports collection makefile for: cyrus-sasl
|
||||
# Version required: 1.5.13
|
||||
# Date created: Nov 1 1999
|
||||
# Whom: hetzels@westbend.net
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= cyrus-sasl-${SASL_VER}
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
|
||||
http://www.freebsd.org/~stb/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/ \
|
||||
ftp://ftp.hanse.de/sites/transit/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/
|
||||
|
||||
MAINTAINER= hetzels@westbend.net
|
||||
|
||||
SASL_VER= 1.5.13
|
||||
|
||||
Y2K= http://asg.web.cmu.edu/cyrus/imapd/y2k.html
|
||||
|
||||
MAN1= sasl_client.1 sasl_server.1
|
||||
MAN8= saslpasswd.8
|
||||
|
||||
USE_LIBTOOL= YES
|
||||
CONFIGURE_ARGS= \
|
||||
--prefix=${PREFIX} \
|
||||
--sysconfdir=${PREFIX}/etc \
|
||||
--includedir=${PREFIX}/include/sasl \
|
||||
--with-plugindir=${PREFIX}/lib/sasl \
|
||||
--enable-static \
|
||||
--with-dbpath=${PREFIX}/etc/sasldb \
|
||||
--with-sample \
|
||||
--with-rc4
|
||||
|
||||
# --disable-cram
|
||||
|
||||
# Currently, pwcheck doesn't compile
|
||||
#CONFIGURE_ARGS+= \
|
||||
# --with-pwcheck=/var/pwcheck
|
||||
|
||||
# --with-dbpath=PATH set the DB path to use [/etc/sasldb]
|
||||
# --with-pam=DIR use PAM (rooted in DIR) [yes]
|
||||
# --with-pwcheck=DIR enable use of the pwcheck daemonusing statedir DIR
|
||||
# --enable-cram enable CRAM-MD5 authentication [yes]
|
||||
# --enable-scram enable SCRAM-MD5 authentication [no]
|
||||
# --enable-digest enable DIGEST-MD5 authentication [yes]
|
||||
# --enable-krb4 enable KERBEROS_V4 authentication [yes]
|
||||
# --enable-gssapi enable GSSAPI authentication [yes]
|
||||
# --enable-anon enable ANONYMOUS authentication [yes]
|
||||
# --enable-plain enable PLAIN authentication [yes]
|
||||
# --with-rc4=DIR use rc4 (look in DIR) [yes]
|
||||
|
||||
# Sample SASL Client/Server
|
||||
SAMPLES= sample-client sample-server
|
||||
INSTALL_PROG= ${INSTALL} -c -o root -g wheel -m 555
|
||||
|
||||
DOCS= README README.Y2K TODO INSTALL ChangeLog NEWS
|
||||
|
||||
DOC2= draft-newman-auth-scram-03.txt \
|
||||
draft-newman-sasl-anon-00.txt \
|
||||
draft-leach-digest-sasl-03.txt \
|
||||
rfc1321.txt rfc2095.txt rfc2104.txt rfc2222.txt
|
||||
|
||||
HTDOCS= index programming sysadmin
|
||||
|
||||
# Build the SASL library with RC4 support
|
||||
.if defined(USA_RESIDENT) && (${USA_RESIDENT} == YES)
|
||||
LIB_DEPENDS= rc4.0:${PORTSDIR}/security/librc4
|
||||
CONFIGURE_ARGS+= --with-rc4
|
||||
#CONFIGURE_ARGS+= --with-rc4=${PREFIX}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.for file in ${SAMPLES}
|
||||
${INSTALL_PROG} ${WRKSRC}/sample/${file} ${PREFIX}/sbin
|
||||
.endfor
|
||||
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
# ${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/SASL/html
|
||||
.for file in ${DOCS}
|
||||
@${ECHO} share/doc/SASL/${file} >>${TMPPLIST}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SASL
|
||||
.endfor
|
||||
.for file in ${DOC2}
|
||||
@${ECHO} share/doc/SASL/${file} >>${TMPPLIST}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/SASL
|
||||
.endfor
|
||||
.for file in ${HTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/${file}.html ${PREFIX}/share/doc/SASL/html
|
||||
@${ECHO} share/doc/SASL/html/${file}.html >>${TMPPLIST}
|
||||
.endfor
|
||||
@${ECHO} "@dirrm share/doc/SASL/html" >>${TMPPLIST}
|
||||
@${ECHO} "@dirrm share/doc/SASL" >>${TMPPLIST}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/cyrus-sasl2/distinfo
Normal file
1
security/cyrus-sasl2/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (cyrus-sasl-1.5.13.tar.gz) = 6bfa1ac9f34d30e36cc827667f657521
|
21
security/cyrus-sasl2/files/patch-ab
Normal file
21
security/cyrus-sasl2/files/patch-ab
Normal file
@ -0,0 +1,21 @@
|
||||
--- lib/Makefile.in.orig Thu Dec 2 14:11:14 1999
|
||||
+++ lib/Makefile.in Sun Dec 26 16:54:42 1999
|
||||
@@ -75,6 +75,7 @@
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
+INSTALL_LIB = @INSTALL_LIB@
|
||||
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
transform = @program_transform_name@
|
||||
|
||||
@@ -190,8 +191,8 @@
|
||||
$(mkinstalldirs) $(DESTDIR)$(libdir)
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
- echo "$(LIBTOOL) --mode=install $(INSTALL) $$p $(DESTDIR)$(libdir)/$$p"; \
|
||||
- $(LIBTOOL) --mode=install $(INSTALL) $$p $(DESTDIR)$(libdir)/$$p; \
|
||||
+ echo "$(LIBTOOL) --mode=install $(INSTALL_LIB) $$p $(DESTDIR)$(libdir)/$$p"; \
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_LIB) $$p $(DESTDIR)$(libdir)/$$p; \
|
||||
else :; fi; \
|
||||
done
|
||||
|
28
security/cyrus-sasl2/files/pwcheck.sh
Normal file
28
security/cyrus-sasl2/files/pwcheck.sh
Normal file
@ -0,0 +1,28 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
|
||||
PREFIX=/usr/local
|
||||
|
||||
case "$1" in
|
||||
|
||||
start)
|
||||
if [ -x ${PREFIX}/sbin/pwcheck ]
|
||||
then
|
||||
${PREFIX}/sbin/pwcheck & && echo -n " pwcheck"
|
||||
fi
|
||||
;;
|
||||
|
||||
stop)
|
||||
if [ -r /var/run/pwcheck.pid ]
|
||||
then
|
||||
kill `cat /var/run/pwcheck.pid` && echo -n " pwcheck"
|
||||
fi
|
||||
;;
|
||||
|
||||
*)
|
||||
echo "usage: $0 {start|stop}" 1>&2
|
||||
exit 64
|
||||
;;
|
||||
|
||||
esac
|
||||
|
1
security/cyrus-sasl2/pkg-comment
Normal file
1
security/cyrus-sasl2/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
RFC 2222 SASL (Simple Authentication and Security Layer)
|
11
security/cyrus-sasl2/pkg-descr
Normal file
11
security/cyrus-sasl2/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
The Cyrus SASL (Simple Authentication and Security Layer)
|
||||
|
||||
SASL is the Simple Authentication and Security Layer, a method
|
||||
for adding authentication support to connection-based protocols.
|
||||
To use SASL, a protocol includes a command for identifying and
|
||||
authenticating a user to a server and for optionally negotiating
|
||||
protection of subsequent protocol interactions. If its use is
|
||||
negotiated, a security layer is inserted between the protocol
|
||||
and the connection.
|
||||
|
||||
WWW: http://asg.web.cmu.edu/sasl/
|
28
security/cyrus-sasl2/pkg-plist
Normal file
28
security/cyrus-sasl2/pkg-plist
Normal file
@ -0,0 +1,28 @@
|
||||
include/sasl/hmac-md5.h
|
||||
include/sasl/md5.h
|
||||
include/sasl/md5global.h
|
||||
include/sasl/sasl.h
|
||||
include/sasl/saslplug.h
|
||||
include/sasl/saslutil.h
|
||||
@dirrm include/sasl
|
||||
lib/libsasl.a
|
||||
lib/libsasl.so
|
||||
lib/libsasl.so.7
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
lib/sasl/libanonymous.a
|
||||
lib/sasl/libanonymous.so
|
||||
lib/sasl/libanonymous.so.1
|
||||
lib/sasl/libcrammd5.a
|
||||
lib/sasl/libcrammd5.so
|
||||
lib/sasl/libcrammd5.so.1
|
||||
lib/sasl/libdigestmd5.a
|
||||
lib/sasl/libdigestmd5.so
|
||||
lib/sasl/libdigestmd5.so.0
|
||||
lib/sasl/libplain.a
|
||||
lib/sasl/libplain.so
|
||||
lib/sasl/libplain.so.1
|
||||
@dirrm lib/sasl
|
||||
sbin/saslpasswd
|
||||
sbin/sample-client
|
||||
sbin/sample-server
|
Loading…
Reference in New Issue
Block a user