Update to 0.5.0

Feature safe:	yes
This commit is contained in:
Max Brazhnikov 2010-07-06 20:16:30 +00:00
parent dc51d987bd
commit 54cf1e0339
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=257467
6 changed files with 85 additions and 14 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= rekonq
PORTVERSION= 0.4.0
PORTVERSION= 0.5.0
CATEGORIES= www kde
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/${PORTVERSION}

View File

@ -1,3 +1,3 @@
MD5 (rekonq-0.4.0.tar.bz2) = 607e826131d8ead1e48a7611ba2ef075
SHA256 (rekonq-0.4.0.tar.bz2) = 7e73ee23174101372c284c8078e8eef42567acfa0a5692249f0579ece2fcb7b7
SIZE (rekonq-0.4.0.tar.bz2) = 367179
MD5 (rekonq-0.5.0.tar.bz2) = ffa227236b9e4aa6cca6851cc05855fb
SHA256 (rekonq-0.5.0.tar.bz2) = a8dcf9dc81fa46a042171a29837bc1a53e0d92936afc34f6917740da7734a162
SIZE (rekonq-0.5.0.tar.bz2) = 1155863

View File

@ -0,0 +1,28 @@
--- ./CMakeLists.txt.orig 2010-07-06 01:17:15.000000000 +0400
+++ ./CMakeLists.txt 2010-07-06 22:29:27.282359499 +0400
@@ -28,8 +28,6 @@
INCLUDE(KDE4Defaults)
INCLUDE(MacroLibrary)
-FIND_PACKAGE(PkgConfig)
-PKG_CHECK_MODULES(GTK2 REQUIRED gtk+-2.0>=2.8.0)
# ==================================================================================
# Log messages
@@ -77,13 +75,13 @@
##### FINAL RESULTS #####
-IF(QT4_FOUND AND KDE4_FOUND AND GTK2_FOUND)
+IF(QT4_FOUND AND KDE4_FOUND)
MESSAGE(STATUS " rekonq will be compiled............... YES")
SET(REKONQ_CAN_BE_COMPILED true)
-ELSE(QT4_FOUND AND KDE4_FOUND AND GTK2_FOUND)
+ELSE(QT4_FOUND AND KDE4_FOUND)
MESSAGE(FATAL_ERROR " rekonq will NOT be compiled!")
SET(REKONQ_CAN_BE_COMPILED false)
-ENDIF(QT4_FOUND AND KDE4_FOUND AND GTK2_FOUND)
+ENDIF(QT4_FOUND AND KDE4_FOUND)
MESSAGE(STATUS "")
MESSAGE(STATUS "-----------------------------------------------------------------------")

View File

@ -0,0 +1,18 @@
--- ./src/CMakeLists.txt.orig 2010-07-06 01:13:01.000000000 +0400
+++ ./src/CMakeLists.txt 2010-07-06 22:30:12.672580660 +0400
@@ -90,7 +90,6 @@
${CMAKE_CURRENT_BINARY_DIR}
${KDE4_INCLUDES}
${QT4_INCLUDES}
- ${GTK2_INCLUDE_DIRS}
)
@@ -114,7 +113,6 @@
${KDE4_KIO_LIBS}
${KDE4_KPARTS_LIBS}
${KDE4_THREADWEAVER_LIBRARIES}
- ${GTK2_LIBRARIES}
)

View File

@ -0,0 +1,20 @@
--- ./src/main.cpp.orig 2010-07-06 01:13:01.000000000 +0400
+++ ./src/main.cpp 2010-07-06 22:29:53.933972524 +0400
@@ -23,8 +23,6 @@
*
* ============================================================ */
-// workaround for recent flashplugins
-#include <gtk/gtk.h>
// version include
#include "../version.h"
@@ -45,8 +43,6 @@
extern "C" KDE_EXPORT int kdemain(int argc, char **argv)
{
- // just a hackisch workaround for recent flashplugins
- gtk_init(&argc, &argv);
KAboutData about("rekonq",
0,

View File

@ -6,44 +6,49 @@ share/apps/rekonq/htmls/home.html
share/apps/rekonq/htmls/rekonqinfo.html
share/apps/rekonq/pics/bg.png
share/apps/rekonq/pics/bg2.png
share/apps/rekonq/pics/bot.gif
share/apps/rekonq/pics/busywidget.gif
share/apps/rekonq/pics/button.png
share/apps/rekonq/pics/category.png
share/apps/rekonq/pics/closed.png
share/apps/rekonq/pics/loading.mng
share/apps/rekonq/pics/open.png
share/apps/rekonq/pics/tile.gif
share/apps/rekonq/pics/top.png
share/apps/rekonq/pics/webkit-icon.png
share/config.kcfg/rekonq.kcfg
share/doc/HTML/en/rekonq/automatic_filters.png
share/doc/HTML/en/rekonq/cache.png
share/doc/HTML/en/rekonq/common
share/doc/HTML/en/rekonq/cookies.png
share/doc/HTML/en/rekonq/fonts.png
share/doc/HTML/en/rekonq/general.png
share/doc/HTML/en/rekonq/index.cache.bz2
share/doc/HTML/en/rekonq/index.docbook
share/doc/HTML/en/rekonq/old_screenshot.png
share/doc/HTML/en/rekonq/own_filter.png
share/doc/HTML/en/rekonq/proxy.png
share/doc/HTML/en/rekonq/screenshot.png
share/doc/HTML/en/rekonq/shortcuts.png
share/doc/HTML/en/rekonq/snapshot1.png
share/doc/HTML/en/rekonq/tabs.png
share/doc/HTML/en/rekonq/webkit.png
share/doc/HTML/en/rekonq/webshortcuts.png
share/icons/hicolor/128x128/apps/rekonq.png
share/icons/hicolor/16x16/apps/rekonq.png
share/icons/hicolor/32x32/apps/rekonq.png
share/icons/hicolor/64x64/apps/rekonq.png
share/locale/ca/LC_MESSAGES/rekonq.mo
share/locale/cs/LC_MESSAGES/rekonq.mo
share/locale/da/LC_MESSAGES/rekonq.mo
share/locale/de/LC_MESSAGES/rekonq.mo
share/locale/en_GB/LC_MESSAGES/rekonq.mo
share/locale/es/LC_MESSAGES/rekonq.mo
share/locale/et/LC_MESSAGES/rekonq.mo
share/locale/fr/LC_MESSAGES/rekonq.mo
share/locale/gl/LC_MESSAGES/rekonq.mo
share/locale/hu/LC_MESSAGES/rekonq.mo
share/locale/it/LC_MESSAGES/rekonq.mo
share/locale/lt/LC_MESSAGES/rekonq.mo
share/locale/nds/LC_MESSAGES/rekonq.mo
share/locale/nl/LC_MESSAGES/rekonq.mo
share/locale/pl/LC_MESSAGES/rekonq.mo
share/locale/pt/LC_MESSAGES/rekonq.mo
share/locale/pt_BR/LC_MESSAGES/rekonq.mo
share/locale/ru/LC_MESSAGES/rekonq.mo
share/locale/sr/LC_MESSAGES/rekonq.mo
share/locale/sv/LC_MESSAGES/rekonq.mo
share/locale/tr/LC_MESSAGES/rekonq.mo
share/locale/uk/LC_MESSAGES/rekonq.mo
share/locale/zh_CN/LC_MESSAGES/rekonq.mo
@dirrm share/doc/HTML/en/rekonq