Upgrade mail/libesmtp to 0.8.3.

Change the MAINTAINER to jmcoopr@webmail.bmi.net.
This commit is contained in:
Anton Berezin 2001-07-14 21:38:26 +00:00
parent 26ac1980b1
commit 54983db379
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45128
8 changed files with 73 additions and 15 deletions

View File

@ -4,17 +4,27 @@
#
# $FreeBSD$
#
# Modified for 0.8.3 on Fri July 13 2001
# Whom: jmcoopr@webmail.bmi.net
PORTNAME= libesmtp
PORTVERSION= 0.5
PORTVERSION= 0.8.3
CATEGORIES= mail
MASTER_SITES= http://www.stafford.uklinux.net/libesmtp/ \
http://www.theochem.kth.se/~pawsa/balsa/ \
http://www.tobez.org/download/port-mirrors/mail/libesmtp/
MAINTAINER= tobez@FreeBSD.org
MAINTAINER= jmcoopr@webmail.bmi.net
USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
# the following is required for Balsa-1.17
CONFIGURE_ARGS= --enable-require-all-recipients
post-install:
.ifndef(NOPORTDOCS)

View File

@ -1 +1 @@
MD5 (libesmtp-0.5.tar.gz) = 6650c0cd5d088aa505b219d69ae160bf
MD5 (libesmtp-0.8.3.tar.bz2) = 3074cbc65a1344116b71ea0cdafb5dcd

View File

@ -0,0 +1,11 @@
--- Makefile.in Fri Jul 6 15:00:38 2001
+++ Makefile.in.new Fri Jul 13 13:38:34 2001
@@ -79,7 +79,7 @@
LIBESMTP_VERSION = @LIBESMTP_VERSION@
LIBLTDL = @LIBLTDL@
LIBS = @LIBS@
-LIBTOOL = @LIBTOOL@
+LIBTOOL = ${SHELL} ${top_builddir}/libltdl/libtool
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIB_AGE = @LIB_AGE@
LIB_CURRENT = @LIB_CURRENT@

View File

@ -0,0 +1,11 @@
--- ./crammd5/Makefile.in Fri Jul 6 15:01:17 2001
+++ ./crammd5/Makefile.in.new Fri Jul 13 13:48:31 2001
@@ -78,7 +78,7 @@
LIBESMTP_VERSION = @LIBESMTP_VERSION@
LIBLTDL = @LIBLTDL@
LIBS = @LIBS@
-LIBTOOL = @LIBTOOL@
+LIBTOOL = ${SHELL} ${top_builddir}/libltdl/libtool
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIB_AGE = @LIB_AGE@
LIB_CURRENT = @LIB_CURRENT@

View File

@ -0,0 +1,11 @@
--- ./login/Makefile.in Fri Jul 6 15:01:12 2001
+++ ./login/Makefile.in.new Fri Jul 13 13:51:30 2001
@@ -78,7 +78,7 @@
LIBESMTP_VERSION = @LIBESMTP_VERSION@
LIBLTDL = @LIBLTDL@
LIBS = @LIBS@
-LIBTOOL = @LIBTOOL@
+LIBTOOL = ${SHELL} ${top_builddir}/libltdl/libtool
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIB_AGE = @LIB_AGE@
LIB_CURRENT = @LIB_CURRENT@

View File

@ -0,0 +1,11 @@
--- ./plain/Makefile.in Fri Jul 6 15:01:14 2001
+++ ./plain/Makefile.in.new Fri Jul 13 13:53:39 2001
@@ -78,7 +78,7 @@
LIBESMTP_VERSION = @LIBESMTP_VERSION@
LIBLTDL = @LIBLTDL@
LIBS = @LIBS@
-LIBTOOL = @LIBTOOL@
+LIBTOOL = ${SHELL} ${top_builddir}/libltdl/libtool
LIBTOOL_DEPS = @LIBTOOL_DEPS@
LIB_AGE = @LIB_AGE@
LIB_CURRENT = @LIB_CURRENT@

View File

@ -1,10 +0,0 @@
--- headers.c.orig Wed Feb 21 23:07:41 2001
+++ headers.c Wed Feb 21 23:07:57 2001
@@ -23,6 +23,7 @@
#include <stdarg.h>
#include <string.h>
#include <stdlib.h>
+#include <time.h>
#include "libesmtp-private.h"
#include "headers.h"

View File

@ -1,7 +1,20 @@
bin/libesmtp-config
include/auth-client.h
include/auth-plugin.h
include/libesmtp.h
lib/libesmtp.so.2
lib/libesmtp.so
lib/esmtp/sasl-cram-md5.a
lib/esmtp/sasl-cram-md5.la
lib/esmtp/sasl-cram-md5.so
lib/esmtp/sasl-login.a
lib/esmtp/sasl-login.la
lib/esmtp/sasl-login.so
lib/esmtp/sasl-plain.a
lib/esmtp/sasl-plain.la
lib/esmtp/sasl-plain.so
lib/libesmtp.a
lib/libesmtp.la
lib/libesmtp.so
lib/libesmtp.so.5
%%PORTDOCS%%share/doc/libesmtp/INSTALL
%%PORTDOCS%%share/doc/libesmtp/Notes
%%PORTDOCS%%share/doc/libesmtp/README
@ -10,3 +23,4 @@ lib/libesmtp.a
%%PORTDOCS%%share/examples/libesmtp/test-mail
%%PORTDOCS%%@dirrm share/examples/libesmtp
%%PORTDOCS%%@dirrm share/doc/libesmtp
@unexec rmdir %D/lib/esmtp 2>/dev/null || true