Update to upstream version 3.7.0

Detailed log:
- Update audio/grip to 3.7.0
- Fix LICENSE
- Convert to USES=localbase
- Remove --disable-nls which does nothing
- Trim down the encoders list defined in src/gripcfg.c to those which we
  have ports for and fix a pre-existing offset problem that arose from
  removing one the encoders from the list. Specfically, the "xingmp3enc"
  encoder was removed, but ginfo->selected_encoder was not changed in
  src/grip.c. This caused the program to point to the flac encoder as the
  default instead of oggenc and overwrote the flac settings with the
  settings for oggenc.

PR:		227336
Submitted by:	jhale
Differential Revision:	https://reviews.freebsd.org/D14997
This commit is contained in:
Thomas Zander 2018-04-07 12:32:26 +00:00
parent 16fff94447
commit 548523f6ac
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=466722
4 changed files with 52 additions and 15 deletions

View File

@ -1,17 +1,15 @@
# Created by: kbyanc@posi.net
# $FreeBSD$
# $MCom: ports/audio/grip/Makefile,v 1.4 2007/05/19 21:35:57 marcus Exp $
PORTNAME= grip
PORTVERSION= 3.6.2
PORTREVISION= 1
PORTVERSION= 3.7.0
CATEGORIES= audio
MASTER_SITES= SF/grip/${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= GTK front-end to external cd rippers and audio encoders
LICENSE= GPLv2
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl \
@ -20,13 +18,13 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libid3.so:audio/id3lib \
libpopt.so:devel/popt
USES= gmake libtool pathfix pkgconfig
USES= gmake libtool localbase pathfix pkgconfig
USE_XORG= ice sm x11 xext
USE_GNOME= cairo gdkpixbuf2 gnomeprefix libgnomeui vte
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-werror
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALLS_ICONS= yes
OPTIONS_DEFINE= CDPARANOIA CDDA2WAV LAME VORBIS FAAC FLAC NLS
OPTIONS_DEFAULT= CDPARANOIA VORBIS
@ -45,7 +43,6 @@ FLAC_RUN_DEPENDS= flac:audio/flac
LAME_RUN_DEPENDS= lame:audio/lame
VORBIS_RUN_DEPENDS= ogg123:audio/vorbis-tools
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
.if defined(WITH_CDROM_DEVICE)
DEFAULT_CDROM_DEVICE=${WITH_CDROM_DEVICE}
@ -63,8 +60,5 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
${WRKSRC}/src/grip.c
@${REINPLACE_CMD} -e 's|{"xingmp3enc","-B %b -Q %w","mp3"},||; \
s|{"l3enc","-br %b %w %m","mp3"},|{"faac","--no-midside -w -q 100 --artist %a --album %d --track %t --title %n --year %y --genre %g -b %b %w -o %m", "m4a"},|' \
${WRKSRC}/src/gripcfg.c
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1512459817
SHA256 (grip-3.6.2.tar.gz) = ee191f1eab40da757edfa89cc3fc3e17fac466de06773f8f5952c26d22b77051
SIZE (grip-3.6.2.tar.gz) = 959393
TIMESTAMP = 1523001507
SHA256 (grip-3.7.0.tar.gz) = 9aaef780f4af74a710c82ce445226a76870101a7f7de0c3fb28ee9e4fd916087
SIZE (grip-3.7.0.tar.gz) = 961006

View File

@ -1,4 +1,11 @@
--- src/grip.c.orig 2017-10-29 05:14:15 UTC
Since it is the default, the oggenc encoder was moved to the beginning of the
encoder_defaults list in src/gripcfg.c. We set selected_encoder=0 here to
reflect that change. This also prevents the offset from getting screwed up
if encoders are added or removed from the list.
Fix the oggenc arguments. Input file "%w" should be at the end.
--- src/grip.c.orig 2018-01-31 15:06:36 UTC
+++ src/grip.c
@@ -29,6 +29,7 @@
#include <gdk/gdkx.h>
@ -8,3 +15,14 @@
#include "grip.h"
#include <libgnomeui/gnome-window-icon.h>
#include "discdb.h"
@@ -897,8 +898,8 @@ static void DoLoadConfig(GripInfo *ginfo)
ginfo->stop_between_tracks=FALSE;
*ginfo->wav_filter_cmd='\0';
*ginfo->disc_filter_cmd='\0';
- ginfo->selected_encoder=6;
- strcpy(ginfo->mp3cmdline,"-o %m -a %a -l %d -t %n -b %b %w -N %t -G %G -d %y");
+ ginfo->selected_encoder=0;
+ strcpy(ginfo->mp3cmdline,"-o %m -a %a -l %d -t %n -b %b -N %t -G %G -d %y %w");
FindExeInPath("oggenc", ginfo->mp3exename, sizeof(ginfo->mp3exename));
strcpy(ginfo->mp3fileformat,"~/ogg/%A/%d/%t_%n.%x");
strcpy(ginfo->mp3fileformat_multi,"~/ogg/%A/%d/%t_%a_%n.%x");

View File

@ -0,0 +1,25 @@
Adjust the encoder list to contain only those we have ports for.
Move oggenc to the beginning of the list since it is the default and to
prevent future offset errors if other encoders are added or removed.
--- src/gripcfg.c.orig 2018-04-06 23:41:51 UTC
+++ src/gripcfg.c
@@ -47,16 +47,9 @@ static Ripper ripper_defaults[]={
{"",""}
};
-static MP3Encoder encoder_defaults[]={{"bladeenc","-%b -QUIT %w %m","mp3"},
+static MP3Encoder encoder_defaults[]={{"oggenc","-o %m -a %a -l %d -t %n -b %b -N %t -G %G -d %y %w","ogg"},
{"lame","-h --add-id3v2 --tt \"%n\" --ta \"%a\" --tl \"%d\" --ty \"%y\" --tn \"%t\" --tg \"%G\" -b %b %w %m","mp3"},
- {"l3enc","-br %b %w %m","mp3"},
- {"xingmp3enc","-B %b -Q %w","mp3"},
- {"mp3encode","-p 2 -l 3 -b %b %w %m",
- "mp3"},
- {"gogo","-b %b %w %m","mp3"},
- {"oggenc",
- "-o %m -a %a -l %d -t %n -b %b -N %t -G %G -d %y %w",
- "ogg"},
+ {"faac","--no-midside -w -q 100 --artist %a --album %d --track %t --title %n --year %y --genre %g -b %b %w -o %m", "m4a"},
{"flac","--best --replay-gain -T title=\"%n\" -T artist=\"%a\" -T album=\"%d\" -T date=\"%y\" -T tracknumber=\"%t\" -T genre=\"%G\" -o %m %w","flac"},
{"other","",""},
{"",""}