multimedia/butt: update 0.1.22 -> 0.1.25
PR: 250993 Submitted by: Per Gunnarsson <per.gunnarsson@yandex.com> Relnotes: https://danielnoethen.de/butt/Changelog.html
This commit is contained in:
parent
c8e4144ef6
commit
5468b4d6b0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=554880
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= butt
|
||||
PORTVERSION= 0.1.22
|
||||
PORTVERSION= 0.1.25
|
||||
CATEGORIES= multimedia graphics
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1596361487
|
||||
SHA256 (butt-0.1.22.tar.gz) = 71e7fcd89d97f803f05197caa743de4fcf8ab67ec3f3af0a54c2e895d660f62c
|
||||
SIZE (butt-0.1.22.tar.gz) = 979710
|
||||
TIMESTAMP = 1604949832
|
||||
SHA256 (butt-0.1.25.tar.gz) = 7c9f44227584e30040315a5c86419bf3e654bd3523634d34b18c9017206334cb
|
||||
SIZE (butt-0.1.25.tar.gz) = 983685
|
||||
|
@ -1,65 +1,64 @@
|
||||
--- configure.ac.orig 2020-04-20 14:40:46 UTC
|
||||
+++ configure.ac
|
||||
@@ -64,6 +64,7 @@ AM_CONDITIONAL(WINDOWS, test "$host_os" = "windows")
|
||||
|
||||
|
||||
--- configure.ac.orig 2020-11-09 19:04:41.803234000 +0100
|
||||
+++ configure.ac 2020-11-09 19:48:22.239576000 +0100
|
||||
@@ -66,6 +66,7 @@
|
||||
build_linux=no
|
||||
+build_freebsd=no
|
||||
build_windows=no
|
||||
build_mac=no
|
||||
+build_freebsd=no
|
||||
|
||||
@@ -88,6 +89,25 @@ case "${host_os}" in
|
||||
)
|
||||
])
|
||||
# Detect the target system
|
||||
case "${host_os}" in
|
||||
@@ -102,6 +103,25 @@
|
||||
build_mac=yes
|
||||
AC_MSG_NOTICE([MacOS detected])
|
||||
;;
|
||||
+ freebsd*)
|
||||
+ build_freebsd=yes
|
||||
+ AC_MSG_NOTICE([FreeBSD detected])
|
||||
+
|
||||
+ AS_IF([test "x$enable_aac" != "xno"],
|
||||
+ [
|
||||
+ AC_CHECK_LIB([fdk-aac], [aacEncOpen], [],
|
||||
+ [AC_MSG_ERROR([**** Could not find libfdk-aac ****])]
|
||||
+ )
|
||||
+ ])
|
||||
+ AS_IF([test "x$enable_ssl" != "xno"], [
|
||||
+ AC_CHECK_LIB([crypto], [EVP_EncryptInit], [],
|
||||
+ [AC_MSG_ERROR([**** Could not find libcrypto ****])]
|
||||
+ )
|
||||
+ AC_CHECK_LIB([ssl], [SSL_CTX_new], [],
|
||||
+ [AC_MSG_ERROR([**** Could not find libssl ****])]
|
||||
+ )
|
||||
+ ])
|
||||
+ AS_IF([test "x$enable_aac" != "xno"],
|
||||
+ [
|
||||
+ AC_CHECK_LIB([fdk-aac], [aacEncOpen], [],
|
||||
+ [AC_MSG_ERROR([**** Could not find libfdk-aac ****])]
|
||||
+ )
|
||||
+ ])
|
||||
+ AS_IF([test "x$enable_ssl" != "xno"], [
|
||||
+ AC_CHECK_LIB([ssl], [SSL_CTX_new], [],
|
||||
+ [AC_MSG_ERROR([**** Could not find libssl ****])]
|
||||
+ )
|
||||
+ AC_CHECK_LIB([crypto], [EVP_EncryptInit], [],
|
||||
+ [AC_MSG_ERROR([**** Could not find libcrypto ****])]
|
||||
+ )
|
||||
+ ])
|
||||
+ ;;
|
||||
cygwin*|mingw*|windows)
|
||||
build_windows=yes
|
||||
AC_MSG_NOTICE([Windows detected])
|
||||
@@ -109,6 +129,7 @@ esac
|
||||
|
||||
# Pass the conditionals to automake
|
||||
*)
|
||||
AC_MSG_ERROR(["OS $host_os is not supported"])
|
||||
;;
|
||||
@@ -111,6 +131,7 @@
|
||||
AM_CONDITIONAL([LINUX], [test "$build_linux" = "yes"])
|
||||
+AM_CONDITIONAL([FreeBSD], [test "$build_freebsd" = "yes"])
|
||||
AM_CONDITIONAL([WINDOWS], [test "$build_windows" = "yes"])
|
||||
AM_CONDITIONAL([OSX], [test "$build_mac" = "yes"])
|
||||
+AM_CONDITIONAL([FREEBSD], [test "$build_freebsd" = "yes"])
|
||||
|
||||
@@ -129,6 +150,20 @@ fi
|
||||
AC_CHECK_PROG([FLTKCONFIG],[fltk-config], [fltk-config])
|
||||
|
||||
@@ -141,6 +162,19 @@
|
||||
])
|
||||
fi
|
||||
|
||||
#Add dbus library for Linux
|
||||
if test "$build_linux" = "yes"; then
|
||||
+ AC_MSG_NOTICE([])
|
||||
+ PKG_CHECK_MODULES([DBUS], [dbus-1], [
|
||||
+ AC_DEFINE([HAVE_DBUS], [1], [Use dbus to get current tracks])
|
||||
+ LIBS="$LIBS $DBUS_LIBS"
|
||||
+ CFLAGS="$CFLAGS $LIBS $DBUS_CFLAGS"
|
||||
+ CXXFLAGS="$CXXFLAGS $DBUS_CFLAGS"
|
||||
+ ], [
|
||||
+ AC_DEFINE([HAVE_DBUS], [0], [Use dbus to get current tracks])
|
||||
+ AC_MSG_ERROR([**** Coud not find dbus dev files])
|
||||
+ ])
|
||||
+fi
|
||||
+
|
||||
+#Add dbus library for FreeBSD
|
||||
+if test "$build_freebsd" = "yes"; then
|
||||
AC_MSG_NOTICE([])
|
||||
PKG_CHECK_MODULES([DBUS], [dbus-1], [
|
||||
AC_DEFINE([HAVE_DBUS], [1], [Use dbus to get current tracks])
|
||||
+ AC_MSG_NOTICE([])
|
||||
+ PKG_CHECK_MODULES([DBUS], [dbus-1], [
|
||||
+ AC_DEFINE([HAVE_DBUS], [1], [Use dbus to get current tracks])
|
||||
+ LIBS="$LIBS $DBUS_LIBS"
|
||||
+ CFLAGS="$CFLAGS $LIBS $DBUS_CFLAGS"
|
||||
+ CXXFLAGS="$CXXFLAGS $DBUS_CFLAGS"
|
||||
+ ], [
|
||||
+ AC_DEFINE([HAVE_DBUS], [0], [Use dbus to get current tracks])
|
||||
+ AC_MSG_ERROR([**** Coud not find dbus dev files])
|
||||
+ ])
|
||||
+fi
|
||||
# Checks for header files.
|
||||
AC_PATH_X
|
||||
AC_CHECK_HEADERS([fcntl.h limits.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/FLTK/fl_funcs.cpp.orig 2020-07-26 17:47:54 UTC
|
||||
+++ src/FLTK/fl_funcs.cpp
|
||||
@@ -147,7 +147,7 @@ void fill_cfg_widgets(void)
|
||||
--- src/FLTK/fl_funcs.cpp.orig 2020-11-09 19:05:50.529619000 +0100
|
||||
+++ src/FLTK/fl_funcs.cpp 2020-11-09 19:14:30.905597000 +0100
|
||||
@@ -155,7 +155,7 @@
|
||||
fl_g->choice_cfg_app->add("VOX");
|
||||
fl_g->check_cfg_use_app->value(cfg.main.app_update);
|
||||
fl_g->choice_cfg_app->value(cfg.main.app_update_service);
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- src/Makefile.am.orig 2020-04-21 11:35:33 UTC
|
||||
+++ src/Makefile.am
|
||||
@@ -34,6 +34,10 @@ if LINUX
|
||||
--- src/Makefile.am.orig 2020-11-09 19:05:11.378421000 +0100
|
||||
+++ src/Makefile.am 2020-11-09 19:12:12.772675000 +0100
|
||||
@@ -34,6 +34,10 @@
|
||||
butt_SOURCES += currentTrack.h currentTrackLinux.cpp
|
||||
endif
|
||||
|
||||
+if FreeBSD
|
||||
+if FREEBSD
|
||||
+butt_SOURCES += currentTrack.h currentTrackLinux.cpp
|
||||
+endif
|
||||
+
|
||||
|
Loading…
Reference in New Issue
Block a user