Add textproc/elixir-sweet_xml, a wrapper around xmerl for Elixir.

This commit is contained in:
Jimmy Olgeni 2015-07-15 14:31:54 +00:00
parent 4a7db12f49
commit 544f7c8af3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=392150
6 changed files with 41 additions and 0 deletions

View File

@ -152,6 +152,7 @@
SUBDIR += elixir-earmark
SUBDIR += elixir-ex_doc
SUBDIR += elixir-funnel
SUBDIR += elixir-sweet_xml
SUBDIR += emacs-wiki
SUBDIR += en-aspell
SUBDIR += en-hunspell

View File

@ -0,0 +1,17 @@
# $FreeBSD$
PORTNAME= sweet_xml
PORTVERSION= 0.2.1
CATEGORIES= textproc
PKGNAMEPREFIX= elixir-
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Wrapper around xmerl application for Elixir
LICENSE= MIT
USES= elixir
USE_GITHUB= yes
GH_ACCOUNT= gniquil
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
SHA256 (gniquil-sweet_xml-0.2.1_GH0.tar.gz) = cec2c401bfe336d1151f3996f7d38b7afad527b7e1c6967f7dcbc40a668ad3f5
SIZE (gniquil-sweet_xml-0.2.1_GH0.tar.gz) = 66589

View File

@ -0,0 +1,11 @@
--- mix.exs.orig 2015-07-15 14:25:56 UTC
+++ mix.exs
@@ -26,8 +26,6 @@ defmodule SweetXml.Mixfile do
defp deps do
[
- {:ex_doc, "~> 0.7", only: :dev},
- {:markdown, github: "devinus/markdown"}
]
end
end

View File

@ -0,0 +1,5 @@
SweetXml is a thin wrapper around :xmerl. It allows you to converts
a string or xmlElement record as defined in :xmerl to an elixir
value such as map, list, char_list, or any combination of these.
WWW: https://github.com/gniquil/sweet_xml

View File

@ -0,0 +1,5 @@
lib/elixir/lib/sweet_xml/ebin/Elixir.SweetXml.beam
lib/elixir/lib/sweet_xml/ebin/Elixir.SweetXpath.beam
lib/elixir/lib/sweet_xml/ebin/sweet_xml.app
lib/elixir/lib/sweet_xml/lib/sweet_xml.ex
%%PORTDOCS%%%%DOCSDIR%%/README.md