- Fix build with gcc 4.2

PR:		117732
Submitted by:	Dmitry Marakasov <amdmi3@amdmi3.ru>
Approved by:	portmgr (pav), maintainer
This commit is contained in:
Martin Wilke 2007-11-05 11:18:07 +00:00
parent 3e0e7c4116
commit 543d7d41ba
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202517
2 changed files with 12 additions and 7 deletions

View File

@ -36,10 +36,4 @@ do-install:
${CHOWN} -R root:games ${MALIB}/*
${CHOWN} ${SHAREOWN}:${SHAREGRP} ${MALIB}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- server/netserver.c.orig 2001-01-02 04:02:10.000000000 +0000
+++ server/netserver.c 2007-11-01 04:27:06.000000000 +0000
@@ -98,7 +98,7 @@
(*drain_receive[256])(int ind);
int login_in_progress;
static int num_logins, num_logouts;
-static long Id;
+long Id;
int NumPlayers;
int MetaSocket = -1;