Upgrade, 6.1.0 -> 6.2.0.

This commit is contained in:
Satoshi Asami 1996-11-01 13:43:31 +00:00
parent 95de57f81b
commit 542f5a6aca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=4238
6 changed files with 40 additions and 104 deletions

View File

@ -1,18 +1,24 @@
# New ports collection makefile for: kterm
# Version required: 6.1
# Version required: 6.2
# Date created: 18 November 1994
# Whom: asami
#
# $Id: Makefile,v 1.9 1996/06/03 02:17:23 asami Exp $
# $Id: Makefile,v 1.10 1996/09/19 04:38:22 asami Exp $
#
DISTNAME= kterm-6.1.0
PKGNAME= jp-kterm-6.1.0
DISTNAME= kterm-6.2.0
PKGNAME= jp-kterm-6.2.0
CATEGORIES+= japanese x11
MASTER_SITES= ftp://freefall.freebsd.org/pub/FreeBSD/LOCAL_PORTS/
MASTER_SITES= ftp://ftp.x.org/contrib/applications/
MAINTAINER= asami@FreeBSD.ORG
USE_IMAKE= yes
.if exists(/usr/X11R6/lib/libXaw3d.a) && !defined(PACKAGE_BUILDING)
post-patch:
@${ECHO_MSG} "===> Applying Xaw3d scrollbar patch"
@${PATCH} ${PATCH_ARGS} < ${FILESDIR}/patch-0
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (kterm-6.1.0.tar.gz) = b70155465a62217b2a170cdeea441a23
MD5 (kterm-6.2.0.tar.gz) = 9cc72841b50dfba92bce01dbbebf3039

View File

@ -1,49 +1,11 @@
--- ./main.c.org Sat Jun 4 08:44:11 1994
+++ ./main.c Tue Nov 15 20:59:40 1994
@@ -284,22 +284,34 @@
#ifdef UTMP_FILE
#define UTMP_FILENAME UTMP_FILE
#else
+#ifdef _PATH_UTMP
+#define UTMP_FILENAME _PATH_UTMP
+#else
#define UTMP_FILENAME "/etc/utmp"
#endif
#endif
+#endif
--- ./Imakefile.org Thu Jul 11 22:01:04 1996
+++ ./Imakefile Fri Nov 1 05:32:20 1996
@@ -80,7 +80,7 @@
SpecialCObjectRule(charproc,$(_NOOP_),$(MISC_DEFINES))
#ifndef LASTLOG_FILENAME
+#ifdef _PATH_LASTLOG
+#define LASTLOG_FILENAME _PATH_LASTLOG
+#else
#define LASTLOG_FILENAME "/usr/adm/lastlog" /* only on BSD systems */
#endif
+#endif
#ifndef WTMP_FILENAME
#ifdef WTMP_FILE
#define WTMP_FILENAME WTMP_FILE
#if InstallXtermSetUID
-SetUIDProgramTarget(kterm,$(OBJS1),$(DEPLIBS1),XkbClientLibs XawClientLibs,$(TERMCAPLIB) $(PTYLIB))
+SetUIDProgramTarget(kterm,$(OBJS1),$(DEPLIBS1),XkbClientLibs XawClientLibs,$(TERMCAPLIB) $(PTYLIB) -lxpg4)
#else
+#ifdef _PATH_WTMP
+#define WTMP_FILENAME _PATH_WTMP
+#else
#ifdef SYSV
#define WTMP_FILENAME "/etc/wtmp"
#else
#define WTMP_FILENAME "/usr/adm/wtmp"
+#endif
NormalProgramTarget(kterm,$(OBJS1),$(DEPLIBS1),XkbClientLibs XawClientLibs,$(TERMCAPLIB) $(PTYLIB))
#endif
#endif
#endif
--- ./misc.c.org Mon Mar 28 15:27:03 1994
+++ ./misc.c Tue Nov 15 21:06:54 1994
@@ -765,7 +765,9 @@
char *SysErrorMsg (n)
int n;
{
+#ifndef __FreeBSD__
extern char *sys_errlist[];
+#endif
extern int sys_nerr;
return ((n >= 0 && n < sys_nerr) ? sys_errlist[n] : "unknown error");

View File

@ -1,18 +1,24 @@
# New ports collection makefile for: kterm
# Version required: 6.1
# Version required: 6.2
# Date created: 18 November 1994
# Whom: asami
#
# $Id: Makefile,v 1.9 1996/06/03 02:17:23 asami Exp $
# $Id: Makefile,v 1.10 1996/09/19 04:38:22 asami Exp $
#
DISTNAME= kterm-6.1.0
PKGNAME= jp-kterm-6.1.0
DISTNAME= kterm-6.2.0
PKGNAME= jp-kterm-6.2.0
CATEGORIES+= japanese x11
MASTER_SITES= ftp://freefall.freebsd.org/pub/FreeBSD/LOCAL_PORTS/
MASTER_SITES= ftp://ftp.x.org/contrib/applications/
MAINTAINER= asami@FreeBSD.ORG
USE_IMAKE= yes
.if exists(/usr/X11R6/lib/libXaw3d.a) && !defined(PACKAGE_BUILDING)
post-patch:
@${ECHO_MSG} "===> Applying Xaw3d scrollbar patch"
@${PATCH} ${PATCH_ARGS} < ${FILESDIR}/patch-0
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (kterm-6.1.0.tar.gz) = b70155465a62217b2a170cdeea441a23
MD5 (kterm-6.2.0.tar.gz) = 9cc72841b50dfba92bce01dbbebf3039

View File

@ -1,49 +1,11 @@
--- ./main.c.org Sat Jun 4 08:44:11 1994
+++ ./main.c Tue Nov 15 20:59:40 1994
@@ -284,22 +284,34 @@
#ifdef UTMP_FILE
#define UTMP_FILENAME UTMP_FILE
#else
+#ifdef _PATH_UTMP
+#define UTMP_FILENAME _PATH_UTMP
+#else
#define UTMP_FILENAME "/etc/utmp"
#endif
#endif
+#endif
--- ./Imakefile.org Thu Jul 11 22:01:04 1996
+++ ./Imakefile Fri Nov 1 05:32:20 1996
@@ -80,7 +80,7 @@
SpecialCObjectRule(charproc,$(_NOOP_),$(MISC_DEFINES))
#ifndef LASTLOG_FILENAME
+#ifdef _PATH_LASTLOG
+#define LASTLOG_FILENAME _PATH_LASTLOG
+#else
#define LASTLOG_FILENAME "/usr/adm/lastlog" /* only on BSD systems */
#endif
+#endif
#ifndef WTMP_FILENAME
#ifdef WTMP_FILE
#define WTMP_FILENAME WTMP_FILE
#if InstallXtermSetUID
-SetUIDProgramTarget(kterm,$(OBJS1),$(DEPLIBS1),XkbClientLibs XawClientLibs,$(TERMCAPLIB) $(PTYLIB))
+SetUIDProgramTarget(kterm,$(OBJS1),$(DEPLIBS1),XkbClientLibs XawClientLibs,$(TERMCAPLIB) $(PTYLIB) -lxpg4)
#else
+#ifdef _PATH_WTMP
+#define WTMP_FILENAME _PATH_WTMP
+#else
#ifdef SYSV
#define WTMP_FILENAME "/etc/wtmp"
#else
#define WTMP_FILENAME "/usr/adm/wtmp"
+#endif
NormalProgramTarget(kterm,$(OBJS1),$(DEPLIBS1),XkbClientLibs XawClientLibs,$(TERMCAPLIB) $(PTYLIB))
#endif
#endif
#endif
--- ./misc.c.org Mon Mar 28 15:27:03 1994
+++ ./misc.c Tue Nov 15 21:06:54 1994
@@ -765,7 +765,9 @@
char *SysErrorMsg (n)
int n;
{
+#ifndef __FreeBSD__
extern char *sys_errlist[];
+#endif
extern int sys_nerr;
return ((n >= 0 && n < sys_nerr) ? sys_errlist[n] : "unknown error");