graphics/p5-ming: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
This commit is contained in:
parent
1e3bd4139d
commit
5407477bf7
@ -19,7 +19,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
|
||||
libming.so:graphics/ming \
|
||||
libpng.so:graphics/png
|
||||
|
||||
USES= autoreconf bison gmake libtool localbase perl5 shebangfix
|
||||
USES= autoreconf bison gmake libtool localbase perl5 pkgconfig shebangfix
|
||||
|
||||
CONFIGURE_ARGS= --enable-perl
|
||||
GNU_CONFIGURE= yes
|
||||
@ -38,6 +38,8 @@ SHEBANG_FILES= perl_ext/examples/*.cgi
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES
|
||||
|
||||
BINARY_ALIAS= freetype-config=true
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/ming_is_compiled()/ s|^|#|; /LIBS/d' ${WRKSRC}/perl_ext/Makefile.PL
|
||||
@${REINPLACE_CMD} -e 's|\.3pm|.3|g' ${WRKSRC}/perl_ext/Makefile.PL ${WRKSRC}/perl_ext/mkdoc
|
||||
|
13
graphics/p5-ming/files/patch-configure.in
Normal file
13
graphics/p5-ming/files/patch-configure.in
Normal file
@ -0,0 +1,13 @@
|
||||
--- configure.in.orig 2021-08-10 14:43:41 UTC
|
||||
+++ configure.in
|
||||
@@ -272,8 +272,8 @@ if test "$freetype_support" = "yes"; then
|
||||
ft_config="$freetype_config"
|
||||
fi
|
||||
|
||||
- FREETYPE_CFLAGS="`$ft_config --cflags`"
|
||||
- FREETYPE_LIBS="`$ft_config --libs`"
|
||||
+ FREETYPE_CFLAGS="`pkg-config freetype2 --cflags`"
|
||||
+ FREETYPE_LIBS="`pkg-config freetype2 --libs`"
|
||||
|
||||
AC_SUBST(FREETYPE_LIBS)
|
||||
AC_SUBST(FREETYPE_CFLAGS)
|
Loading…
Reference in New Issue
Block a user