change the maintainer's e-mail address.

support ip-base virtual with -DWITH_IPVIRTUAL.

PR:		30025
Submitted by:	MAINTAINER
This commit is contained in:
Ying-Chieh Liao 2001-08-24 12:47:54 +00:00
parent faaac255b5
commit 53fc6e797a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46782
2 changed files with 52 additions and 3 deletions

View File

@ -1,6 +1,6 @@
# New ports collection makefile for: gslin
# Date created: 24 August 2001
# Whom: Gea-Suan Lin (gslin.am88@nctu.edu.tw)
# Whom: Gea-Suan Lin (gslin@ccca.nctu.edu.tw)
#
# $FreeBSD$
#
@ -11,16 +11,36 @@ CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= system/mail/pop
MAINTAINER= gslin.am88@nctu.edu.tw
MAINTAINER= gslin@ccca.nctu.edu.tw
GNU_CONFIGURE= yes
.if defined(WITH_IPVIRTUAL)
CONFIGURE_ARGS+= --enable-ip-based-virtual
.endif
MAN8= vm-pop3d.8
DOCS= AUTHORS CHANGES COPYING FAQ INSTALL README
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@${ECHO} ""
@${ECHO} " WITH_IPVIRTUAL enable IP-based virtual passwd files and spool directories."
@${ECHO} ""
post-patch:
@${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/vm-pop3d.h
post-install:
${INSTALL_MAN} ${WRKSRC}/vm-pop3d.8 ${MAN8PREFIX}/man/man8
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${WRKSRC}/CHANGES ${WRKSRC}/COPYING ${WRKSRC}/FAQ ${WRKSRC}/INSTALL ${WRKSRC}/README ${DOCSDIR}
.for FILE in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
@${ECHO} "Documentation installed in ${DOCSDIR}."
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,29 @@
--- vm-pop3d.h.orig Fri Aug 24 19:28:57 2001
+++ vm-pop3d.h Fri Aug 24 19:29:59 2001
@@ -63,7 +63,7 @@
/* APOP password file, without .db or .passwd, which are added based on file
type automatically */
-#define APOP_PASSFILE "/etc/apop"
+#define APOP_PASSFILE "%%PREFIX%%/etc/apop"
/* Size of the MD5 digest for APOP */
#define APOP_DIGEST 70
@@ -77,7 +77,7 @@
The mailboxes for virtual domains do not have corresponding Unix
accounts; they do not have unique UIDs; so they could be owned
by one VIRTUAL_UID. */
-#define VIRTUAL_UID 8
+#define VIRTUAL_UID 65534
/* VIRTUAL_MAILDIR is the path to the sub-directories containing
the mailboxes for each virtual domain (or realm). It has a host,
@@ -92,7 +92,7 @@
the sub-directories containing the password files for each virtual
domain. By default, this is /etc/virtual.) */
-#define VIRTUAL_PASSWORDS_PATH "/etc/virtual"
+#define VIRTUAL_PASSWORDS_PATH "%%PREFIX%%/etc/virtual"
/* VIRTUAL_PASSWORD_FNAME is the file name (or suffix) for the virtual
domain's password file. (By default, this is "passwd". It could be set