Update (?) to version 0.4.
PR: 7554 Submitted by: maintainer
This commit is contained in:
parent
8996680053
commit
53eec05a5f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=12429
@ -1,28 +1,32 @@
|
||||
# New ports collection makefile for: gemdropx
|
||||
# Version required: 1.0b3
|
||||
# Version required: 0.4
|
||||
# Date created: 9 March 1998
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# $Id: Makefile,v 1.2 1998/07/27 23:24:38 asami Exp $
|
||||
# $Id: Makefile,v 1.3 1998/08/05 09:30:53 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gemdropx
|
||||
PKGNAME= gemdropx-1.0b3
|
||||
DISTNAME= gemdropx.0.4
|
||||
PKGNAME= gemdropx-0.4
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://zippy.sonoma.edu/kendrick/nbs/unix/x/gemdropx/
|
||||
MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/gemdropx/
|
||||
|
||||
MAINTAINER= andy@icc.surw.chel.su
|
||||
|
||||
ALL_TARGET= gemdropx
|
||||
MAKEFILE= makefile
|
||||
USE_X_PREFIX= yes
|
||||
WRKSRC= ${WRKDIR}/gemdropx
|
||||
|
||||
do-install:
|
||||
@ ${INSTALL_PROGRAM} ${WRKSRC}/gemdropx ${PREFIX}/bin
|
||||
@ ${MKDIR} ${PREFIX}/share/gemdropx/gfx
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/gfx/*.xbm ${PREFIX}/share/gemdropx/gfx
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/gfx/* ${PREFIX}/share/gemdropx/gfx
|
||||
@ ${MKDIR} ${PREFIX}/share/gemdropx/sounds
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/sounds/*.au ${PREFIX}/share/gemdropx/sounds
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/sounds/* ${PREFIX}/share/gemdropx/sounds
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ ${MKDIR} ${PREFIX}/share/doc/gemdropx
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gemdropx
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/README.txt ${PREFIX}/share/doc/gemdropx
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gemdropx.tar.gz) = c12aef7ad4cee538f6fb42a88ea9dcbc
|
||||
MD5 (gemdropx.0.4.tar.gz) = 06b07dd55aa315fd4b77adb990ef8986
|
||||
|
@ -1,15 +1,23 @@
|
||||
--- makefile.orig Sat Nov 22 01:56:59 1997
|
||||
+++ makefile Mon Apr 27 00:42:53 1998
|
||||
@@ -10,10 +10,10 @@
|
||||
# X Window version: November 5, 1997 - November 21, 1997
|
||||
--- makefile Thu Jul 30 19:53:32 1998
|
||||
+++ /home/andy/tmp/wrk/makefile Mon Aug 10 18:03:04 1998
|
||||
@@ -11,14 +11,16 @@
|
||||
# X Window Updates: July 29, 1998- July 29, 1998
|
||||
|
||||
|
||||
-CC=gcc
|
||||
+CC+=${CFLAGS} -I$(X11BASE)/include -DPREFIX=\"${PREFIX}\"
|
||||
POSTPROCESS=strip
|
||||
+CC?=gcc
|
||||
+PREFIX?=/usr/X11R6
|
||||
+X11BASE?=/usr/X11R6
|
||||
|
||||
-XLIB=-lX11
|
||||
+XLIB=-L$(X11BASE)/lib -lX11 -lcompat
|
||||
# XLIB=-L/usr/openwin/lib -lX11
|
||||
# XLIB=-L/usr/X11/lib -lX11
|
||||
-INSTALLROOT= $(PREFIX)
|
||||
+INSTALLROOT= $(PREFIX)/share/gemdropx
|
||||
GFX= $(INSTALLROOT)/gfx
|
||||
SOUNDS= $(INSTALLROOT)/sounds
|
||||
|
||||
-XLIB= $(RPATH) -L$(PREFIX)/lib -lX11 -lm
|
||||
-XINC= -I$(PREFIX)/include
|
||||
+XLIB= $(RPATH) -L$(X11BASE)/lib -lX11 -lm
|
||||
+XINC= -I$(X11BASE)/include
|
||||
CFLAGS= $(XINC) -DSOUNDS=\"$(SOUNDS)\" -DGFX=\"$(GFX)\"
|
||||
|
||||
all: gemdropx
|
||||
|
@ -16,3 +16,5 @@ heard of it more than the others (except Tetris, of course!))
|
||||
top is a random assortment of colored shapes ("gems"). As time goes
|
||||
on, more gems appear at the very top of the screen, pushing the
|
||||
rest downwards. The game is over when the gems reach the bottom.
|
||||
|
||||
http://www.sonic.net/~nbs/unix/x/gemdropx
|
||||
|
@ -1,28 +1,28 @@
|
||||
bin/gemdropx
|
||||
share/doc/gemdropx/README
|
||||
share/gemdropx/gfx/author.xbm
|
||||
share/gemdropx/gfx/block.xbm
|
||||
share/gemdropx/gfx/bomb.xbm
|
||||
share/gemdropx/gfx/brick.xbm
|
||||
share/gemdropx/gfx/diamond.xbm
|
||||
share/gemdropx/gfx/disc.xbm
|
||||
share/gemdropx/gfx/dot.xbm
|
||||
share/gemdropx/gfx/explode0.xbm
|
||||
share/gemdropx/gfx/explode1.xbm
|
||||
share/gemdropx/gfx/explode2.xbm
|
||||
share/gemdropx/gfx/explode3.xbm
|
||||
share/gemdropx/gfx/face.xbm
|
||||
share/gemdropx/gfx/fuji.xbm
|
||||
share/gemdropx/gfx/happy.xbm
|
||||
share/gemdropx/gfx/sad.xbm
|
||||
share/gemdropx/gfx/star.xbm
|
||||
share/gemdropx/gfx/stopwatch.xbm
|
||||
share/gemdropx/gfx/title.xbm
|
||||
share/gemdropx/gfx/triangle.xbm
|
||||
share/gemdropx/gfx/warning.xbm
|
||||
share/gemdropx/gfx/wildcard.xbm
|
||||
share/gemdropx/gfx/win1.xbm
|
||||
share/gemdropx/gfx/win2.xbm
|
||||
share/doc/gemdropx/README.txt
|
||||
share/gemdropx/gfx/author.ppm
|
||||
share/gemdropx/gfx/block.ppm
|
||||
share/gemdropx/gfx/bomb.ppm
|
||||
share/gemdropx/gfx/brick.ppm
|
||||
share/gemdropx/gfx/diamond.ppm
|
||||
share/gemdropx/gfx/disc.ppm
|
||||
share/gemdropx/gfx/dot.ppm
|
||||
share/gemdropx/gfx/explode0.ppm
|
||||
share/gemdropx/gfx/explode1.ppm
|
||||
share/gemdropx/gfx/explode2.ppm
|
||||
share/gemdropx/gfx/explode3.ppm
|
||||
share/gemdropx/gfx/face.ppm
|
||||
share/gemdropx/gfx/fuji.ppm
|
||||
share/gemdropx/gfx/happy.ppm
|
||||
share/gemdropx/gfx/sad.ppm
|
||||
share/gemdropx/gfx/star.ppm
|
||||
share/gemdropx/gfx/stopwatch.ppm
|
||||
share/gemdropx/gfx/title.ppm
|
||||
share/gemdropx/gfx/triangle.ppm
|
||||
share/gemdropx/gfx/warning.ppm
|
||||
share/gemdropx/gfx/wildcard.ppm
|
||||
share/gemdropx/gfx/win1.ppm
|
||||
share/gemdropx/gfx/win2.ppm
|
||||
share/gemdropx/sounds/begin.au
|
||||
share/gemdropx/sounds/bomb.au
|
||||
share/gemdropx/sounds/clock.au
|
||||
|
Loading…
Reference in New Issue
Block a user