Update to 0.7.

This commit is contained in:
Maxim Sobolev 2000-11-29 14:37:46 +00:00
parent 5deb789452
commit 53c1d88058
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35511
4 changed files with 4 additions and 41 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= heroes
PORTVERSION= 0.6
PORTVERSION= 0.7
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -38,7 +38,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE}
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
LIBS="-L${LOCALBASE}/lib -lgnugetopt -pthread -lsmpeg -lgcc_r"
LIBS="-L${LOCALBASE}/lib -lgnugetopt -pthread -lsmpeg -lgcc_r" \
CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN6= heroes.6

View File

@ -1,4 +1,4 @@
MD5 (heroes-0.6.tar.gz) = 83251d6253df55b27ae4b7e72579faec
MD5 (heroes-0.7.tar.gz) = 05b3f3a177c2edd3c548c2bdccd8b5f1
MD5 (heroes-data-1.0.tar.gz) = b8efaf361c6258713fc8778039b3b3ae
MD5 (heroes-sound-effects-1.0.tar.gz) = f4defb80baf765fceac034a408f7ad2e
MD5 (heroes-sound-tracks-1.0.tar.gz) = bcde6137a4b21b7395fd3d84b42b7888

View File

@ -1,18 +0,0 @@
--- configure 2000/09/28 13:06:54 1.1
+++ configure 2000/09/28 13:07:43
@@ -894,10 +894,11 @@
# The aliases save the names the user supplied, while $host etc.
# will get canonicalized.
-test -n "$target_alias" &&
- test "$program_prefix$program_suffix$program_transform_name" = \
- NONENONEs,x,x, &&
- program_prefix=${target_alias}-
+# I H A T E A U T O C R A P!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+#test -n "$target_alias" &&
+# test "$program_prefix$program_suffix$program_transform_name" = \
+# NONENONEs,x,x, &&
+# program_prefix=${target_alias}-
# Find a good install program. We prefer a C program (faster),
# so one script is as good as another. But avoid the broken or

View File

@ -1,20 +0,0 @@
--- lib/Makefile.in 2000/09/28 12:23:33 1.1
+++ lib/Makefile.in 2000/09/28 12:24:16
@@ -109,7 +109,7 @@
INCLUDES = -I../src
# These files are always compiled
-libheroes_a_SOURCES = getopt.c getopt1.c getshline.c
+libheroes_a_SOURCES = getshline.c
# Additional files to compile, when functions are missing.
@@ -125,7 +125,7 @@
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
-libheroes_a_OBJECTS = getopt.o getopt1.o getshline.o
+libheroes_a_OBJECTS = getshline.o
AR = ar
CFLAGS = @CFLAGS@
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)