- define MAXPATHLEN in confix.X so that names of backup files are not

limited to 14 chars.
- suppress messages about non existing files in make install.

PR:		ports/64700
Submitted by:	Jeremy Chadwick <freebsd@jdc.parodius.com>
This commit is contained in:
Jean-Marc Zucconi 2004-03-25 19:02:12 +00:00
parent 350d3dde30
commit 536e500670
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105257
2 changed files with 20 additions and 15 deletions

View File

@ -7,7 +7,7 @@
PORTNAME?= ispell
PORTVERSION?= 3.2.06
PORTREVISION?= 4
PORTREVISION?= 5
CATEGORIES+= textproc
MASTER_SITES= http://fmg-www.cs.ucla.edu/geoff/tars/
DISTNAME= ispell-3.2.06 # needed for slave ports / options
@ -289,7 +289,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/languages/american/english.med+ \
${DATADIR}/english.dict
.endif
.if defined(ISPELL_DENEU) || defined(ISPELL_DEALT) || defined(ISPELL_FI) || defined(ISPELL_PL)
@-${INSTALL_DATA} ${WRKDIR}/*/*.aff ${WRKDIR}/*/*.hash ${DATADIR}
.endif
.if defined(ISPELL_IT)
@${CAT} ${MASTERDIR}/pkg-plist.it >> ${TMPPLIST}
.endif

View File

@ -1,14 +1,17 @@
*** config.X.bak Mon Jan 23 21:28:24 1995
--- config.X Tue Dec 16 18:49:29 1997
***************
*** 107,115 ****
#include <sys/param.h>
#include <sys/types.h>
- #ifndef USG
- #include <sys/dir.h>
- #endif /* USG */
/*
** Things that normally go in a Makefile. Define these just like you
--- 107,112 ----
--- config.X.orig Wed Jul 25 23:51:45 2001
+++ config.X Thu Mar 25 19:54:53 2004
@@ -168,9 +168,11 @@
#include <sys/param.h>
#include <sys/types.h>
-#ifndef USG
-#include <sys/dir.h>
-#endif /* USG */
+
+/* Support MAXNAMLEN greater than 14 on FreeBSD; this is not in
+ * sys/param.h for obvious reasons.
+ */
+#include <dirent.h>
/*
** Things that normally go in a Makefile. Define these just like you