Correct check for FreeBSD version that has libpcap 0.9+.
This commit is contained in:
parent
83015f7ae3
commit
53563bc198
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=155960
@ -44,13 +44,10 @@ DYNAMIPS_ARCH= "amd64"
|
||||
DYNAMIPS_ARCH= "nojit"
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
.if ${OSVERSION} < 600029
|
||||
#
|
||||
# Requires libpcap 0.9+
|
||||
USE_REINPLACE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's/^HAS_PCAP=1/HAS_PCAP=0/' ${WRKSRC}/Makefile
|
||||
MAKE_ENV= HAS_PCAP=0
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.orig Thu Feb 2 00:08:41 2006
|
||||
+++ Makefile Tue Feb 14 01:26:49 2006
|
||||
@@ -3,7 +3,7 @@
|
||||
+++ Makefile Tue Feb 14 01:53:31 2006
|
||||
@@ -3,26 +3,26 @@
|
||||
|
||||
# Replace x86 by amd64 for a build on x86_64.
|
||||
# Use "nojit" for architectures that are not x86 or x86_64.
|
||||
@ -9,7 +9,12 @@
|
||||
|
||||
# Change this to 0 if your system doesn't support RFC 2553 extensions
|
||||
HAS_RFC2553=1
|
||||
@@ -15,14 +15,14 @@
|
||||
|
||||
# Change this to 1 if your system has libpcap-0.9.4 or better
|
||||
# (WinPcap is used for Cygwin)
|
||||
-HAS_PCAP=1
|
||||
+HAS_PCAP?=1
|
||||
|
||||
# Current dynamips release
|
||||
VERSION=0.2.3c
|
||||
|
||||
|
@ -44,13 +44,10 @@ DYNAMIPS_ARCH= "amd64"
|
||||
DYNAMIPS_ARCH= "nojit"
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
.if ${OSVERSION} < 600029
|
||||
#
|
||||
# Requires libpcap 0.9+
|
||||
USE_REINPLACE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's/^HAS_PCAP=1/HAS_PCAP=0/' ${WRKSRC}/Makefile
|
||||
MAKE_ENV= HAS_PCAP=0
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.orig Thu Feb 2 00:08:41 2006
|
||||
+++ Makefile Tue Feb 14 01:26:49 2006
|
||||
@@ -3,7 +3,7 @@
|
||||
+++ Makefile Tue Feb 14 01:53:31 2006
|
||||
@@ -3,26 +3,26 @@
|
||||
|
||||
# Replace x86 by amd64 for a build on x86_64.
|
||||
# Use "nojit" for architectures that are not x86 or x86_64.
|
||||
@ -9,7 +9,12 @@
|
||||
|
||||
# Change this to 0 if your system doesn't support RFC 2553 extensions
|
||||
HAS_RFC2553=1
|
||||
@@ -15,14 +15,14 @@
|
||||
|
||||
# Change this to 1 if your system has libpcap-0.9.4 or better
|
||||
# (WinPcap is used for Cygwin)
|
||||
-HAS_PCAP=1
|
||||
+HAS_PCAP?=1
|
||||
|
||||
# Current dynamips release
|
||||
VERSION=0.2.3c
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user