New port: cad/lepton-eda

The Lepton EDA suite provides schematic capture, netlisting, bill
of materials generation, and many other features.  It was forked
from the gEDA/gaf suite in late 2016.  It's in active development
and well supported.

WWW: https://github.com/lepton-eda/lepton-eda

PR:		232076
Submitted by:	dmn <graahnul.grom@gmail.com>
This commit is contained in:
Tobias Kortkamp 2019-02-23 13:49:27 +00:00
parent 218e845d9f
commit 533deb0287
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=493674
13 changed files with 2635 additions and 0 deletions

View File

@ -58,6 +58,7 @@
SUBDIR += layouteditor
SUBDIR += ldraw
SUBDIR += leocad
SUBDIR += lepton-eda
SUBDIR += libopencad
SUBDIR += librecad
SUBDIR += libredwg

88
cad/lepton-eda/Makefile Normal file
View File

@ -0,0 +1,88 @@
# $FreeBSD$
PORTNAME= lepton-eda
PORTVERSION= 1.9.7
DISTVERSIONSUFFIX= -20181211
CATEGORIES= cad
MAINTAINER= graahnul.grom@gmail.com
COMMENT= Lepton Electronic Design Automation
LICENSE= GPLv2+
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgc-threaded.so:devel/boehm-gc-threaded \
libguile-2.0.so:lang/guile2 \
libpng.so:graphics/png \
libstroke.so:devel/libstroke
USES= autoreconf desktop-file-utils gettext-tools gnome groff:build \
libtool localbase makeinfo pathfix perl5 pkgconfig python:run \
shared-mime-info shebangfix
USE_GITHUB= yes
USE_GNOME= cairo gtk20
USE_LDCONFIG= yes
SHEBANG_FILES= utils/scripts/lepton-tragesym \
utils/scripts/lepton-archive.py \
utils/gxyrs/lepton-xyrs.pl \
utils/scripts/gschupdate \
utils/scripts/gsymupdate \
utils/scripts/lepton-pcb_backannotate \
utils/scripts/lepton-refdes_renum \
utils/scripts/lepton-symfix \
examples/lightning_detector/bom \
contrib/scripts/mk_char_tab.pl \
contrib/scripts/pads_backannotate \
contrib/scripts/sarlacc_sym
PORTEXAMPLES= examples/*
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
INSTALLS_ICONS= yes
INFO= lepton-scheme
OPTIONS_DEFINE= DOCS EXAMPLES NLS
OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
# work around for errors while running
# build-tools/icon-theme-installer:
#
# Cannot find 'install -m 0644'; You probably want to pass -x $(INSTALL_DATA)
#
# for 3 dirs (attrib/data, liblepton/data, schematic/data)
# the following lines should be in the generated Makefile:
#
# INSTALL = /usr/bin/install -c
# INSTALL_DATA = ${INSTALL} -m 644
# INSTALL_PROGRAM = ${INSTALL}
# INSTALL_SCRIPT = ${INSTALL}
#
# but instead you got:
#
# INSTALL = /usr/bin/install -c
# INSTALL_DATA = install -m 0644
# INSTALL_PROGRAM = install -s -m 555
# INSTALL_SCRIPT = install -m 555
#
# this is so only when building a port (when building from
# git sources and install to the home folder, there are
# no errors)
#
pre-build:
${REINPLACE_CMD} \
-e 's,^\(INSTALL_DATA = \)install\(.*\),\1$${INSTALL}\2,' \
-e 's,^\(INSTALL_PROGRAM = \)install\(.*\),\1$${INSTALL}\2,' \
-e 's,^\(INSTALL_SCRIPT = \)install\(.*\),\1$${INSTALL}\2,' \
${WRKSRC}/attrib/data/Makefile \
${WRKSRC}/liblepton/data/Makefile \
${WRKSRC}/schematic/data/Makefile
.include <bsd.port.mk>

3
cad/lepton-eda/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1544669359
SHA256 (lepton-eda-lepton-eda-1.9.7-20181211_GH0.tar.gz) = dd62e038e57c6223b2575da5ab68628a5df3387c2cf312eecba689536fdf41bb
SIZE (lepton-eda-lepton-eda-1.9.7-20181211_GH0.tar.gz) = 8636846

View File

@ -0,0 +1,24 @@
--- examples/Makefile.am.orig 2019-02-23 08:55:55 UTC
+++ examples/Makefile.am
@@ -1,9 +1,9 @@
SUBDIRS = gTAG lightning_detector RF_Amp TwoStageAmp
-exampledir = $(docdir)/examples/
+exampledir = $(datadir)/examples/lepton-eda/
-example_DATA = README
+example_DATA = README
EXTRA_DIST = ChangeLog ChangeLog-1.0 $(example_DATA)
@@ -16,7 +16,7 @@ ChangeLog: $(top_builddir)/stamp-git
) > $@
endif HAVE_GIT_REPO
-MOSTLYCLEANFILES = *.log core FILE *~
-CLEANFILES = *.log core FILE *~
+MOSTLYCLEANFILES = *.log core FILE *~
+CLEANFILES = *.log core FILE *~
DISTCLEANFILES = *.log core FILE *~
MAINTAINERCLEANFILES = *.log core FILE *~ Makefile.in ChangeLog

View File

@ -0,0 +1,11 @@
--- examples/RF_Amp/Makefile.am.orig 2019-02-23 08:55:55 UTC
+++ examples/RF_Amp/Makefile.am
@@ -1,7 +1,7 @@
SUBDIRS = model sym
-exampledir = $(docdir)/examples/RF_Amp/
+exampledir = $(datadir)/examples/lepton-eda/RF_Amp/
example_DATA = 5980-2396E.pdf MSA-2643.cir MSA-2643.sch \
Q1.cir Q1.sch Q2.cir Q2.sch README Simulation.cmd gafrc

View File

@ -0,0 +1,12 @@
--- examples/RF_Amp/model/Makefile.am.orig 2019-02-23 08:55:55 UTC
+++ examples/RF_Amp/model/Makefile.am
@@ -1,7 +1,7 @@
-exampledir = $(docdir)/examples/RF_Amp/model/
+exampledir = $(datadir)/examples/lepton-eda/RF_Amp/model/
example_DATA = BJTM1_Q1.mod BJTM1_Q2.mod DiodeM1_Q1.mod DiodeM1_Q2.mod \
- DiodeM2_Q1.mod DiodeM2_Q2.mod DiodeM3_Q1.mod DiodeM3_Q2.mod
+ DiodeM2_Q1.mod DiodeM2_Q2.mod DiodeM3_Q1.mod DiodeM3_Q2.mod
EXTRA_DIST = $(example_DATA)

View File

@ -0,0 +1,8 @@
--- examples/RF_Amp/sym/Makefile.am.orig 2019-02-23 08:55:55 UTC
+++ examples/RF_Amp/sym/Makefile.am
@@ -1,4 +1,4 @@
-exampledir = $(docdir)/examples/RF_Amp/sym/
+exampledir = $(datadir)/examples/lepton-eda/RF_Amp/sym/
example_DATA = BJT_Model.sym Q_Model.sym spice-subcircuit-IO-1.sym \
spice-subcircuit-LL-1.sym

View File

@ -0,0 +1,8 @@
--- examples/TwoStageAmp/Makefile.am.orig 2019-02-23 08:55:55 UTC
+++ examples/TwoStageAmp/Makefile.am
@@ -1,4 +1,4 @@
-exampledir = $(docdir)/examples/TwoStageAmp/
+exampledir = $(datadir)/examples/lepton-eda/TwoStageAmp/
nobase_example_DATA = \
Simulation.cmd TwoStageAmp.sch spice.netlist gafrc \

View File

@ -0,0 +1,8 @@
--- examples/gTAG/Makefile.am.orig 2019-02-23 08:55:55 UTC
+++ examples/gTAG/Makefile.am
@@ -1,4 +1,4 @@
-exampledir = $(docdir)/examples/gTAG/
+exampledir = $(datadir)/examples/lepton-eda/gTAG/
example_DATA = 7414-1.sym attribs gafrc copyleft.sym crdist.sh \
cy7c64603-52nc.sym gTAG-consio.ps gTAG-consio.sch \

View File

@ -0,0 +1,16 @@
--- examples/lightning_detector/Makefile.am.orig 2019-02-23 08:55:55 UTC
+++ examples/lightning_detector/Makefile.am
@@ -1,11 +1,11 @@
-exampledir = $(docdir)/examples/lightning_detector/
+exampledir = $(datadir)/examples/lepton-eda/lightning_detector/
nobase_example_DATA = \
bom bom.readme lightning.net lightning.pcb lightning.sch \
lightning.sch.bom gafrc \
sym/2N4401.sym sym/2N4403.sym
-EXTRA_DIST = $(nobase_example_DATA)
+EXTRA_DIST = $(nobase_example_DATA)
MOSTLYCLEANFILES = gschem.log *~
CLEANFILES = gschem.log *~

View File

@ -0,0 +1,11 @@
--- version.h.orig 2018-12-13 02:49:55 UTC
+++ version.h
@@ -0,0 +1,8 @@
+/* Date part of package version string. */
+#define PACKAGE_DATE_VERSION "20181211"
+
+/* Dotted part of package version string. */
+#define PACKAGE_DOTTED_VERSION "1.9.7"
+
+/* Current git commit. */
+#define PACKAGE_GIT_COMMIT "f3a8714fdfd6dae491ebfff69f0fd9aa4899f9a6"

6
cad/lepton-eda/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
The Lepton EDA suite provides schematic capture, netlisting, bill
of materials generation, and many other features. It was forked
from the gEDA/gaf suite in late 2016. It's in active development
and well supported.
WWW: https://github.com/lepton-eda/lepton-eda

2439
cad/lepton-eda/pkg-plist Normal file

File diff suppressed because it is too large Load Diff