Add bsdbktr_tvtune, an command line TV channel tuner for Brooktree based
TV capture cards. PR: ports/60945 Submitted by: Mina Naguib <webmaster@topfx.com>
This commit is contained in:
parent
0bb764c0bb
commit
532d11741d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=97402
@ -7,6 +7,7 @@
|
||||
SUBDIR += avifile
|
||||
SUBDIR += avinfo
|
||||
SUBDIR += beep-media-player
|
||||
SUBDIR += bsdbktr_tvtune
|
||||
SUBDIR += camserv
|
||||
SUBDIR += dtv
|
||||
SUBDIR += dumpmpeg
|
||||
|
22
multimedia/bsdbktr_tvtune/Makefile
Normal file
22
multimedia/bsdbktr_tvtune/Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
# New ports collection makefile for: bsdbktr_tvtune
|
||||
# Date created: Sun Jan 4 17:49:00 EST 2004
|
||||
# Whom: Mina Naguib <webmaster@topfx.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= bsdbktr_tvtune
|
||||
PORTVERSION= 0.01
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://www.topfx.com/dist/
|
||||
|
||||
MAINTAINER= webmaster@topfx.com
|
||||
COMMENT= A console Brooktree (bktr) TV tuner
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
ALL_TARGET= bsdbktr_tvtune
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bsdbktr_tvtune ${PREFIX}/bin/
|
||||
|
||||
.include <bsd.port.mk>
|
1
multimedia/bsdbktr_tvtune/distinfo
Normal file
1
multimedia/bsdbktr_tvtune/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (bsdbktr_tvtune-0.01.tar.gz) = 49f979a86581eb3adf5d26c6ad898257
|
67
multimedia/bsdbktr_tvtune/files/patch-bsdbktr_tvtune.c
Normal file
67
multimedia/bsdbktr_tvtune/files/patch-bsdbktr_tvtune.c
Normal file
@ -0,0 +1,67 @@
|
||||
--- bsdbktr_tvtune.c.orig Sun Jan 4 23:43:58 2004
|
||||
+++ bsdbktr_tvtune.c Mon Jan 5 21:19:01 2004
|
||||
@@ -159,35 +159,35 @@
|
||||
* Shows propper utility usage then exits
|
||||
*/
|
||||
void show_usage(char *programname) {
|
||||
- printf("
|
||||
-
|
||||
-Usage:
|
||||
- %s [-d TVTUNERDEVICE] [-s CHANNELSET] -c CHANNEL
|
||||
- %s -h
|
||||
- %s -l
|
||||
- %s -v
|
||||
-
|
||||
-Where:
|
||||
-
|
||||
- -c
|
||||
- The channel to tune to
|
||||
-
|
||||
- -d
|
||||
- The device to open for tuning. If unspecified defaults to /dev/tuner0
|
||||
-
|
||||
- -h
|
||||
- This help you're seeing
|
||||
-
|
||||
- -l
|
||||
- List all valid CHANNELSETs you could pass to the -s option
|
||||
-
|
||||
- -s
|
||||
- The channel set configuration to use. If unspecified defaults to NABCST
|
||||
-
|
||||
- -v
|
||||
- Show program version
|
||||
-
|
||||
-", programname, programname, programname, programname);
|
||||
+ printf("\n"\
|
||||
+" \n"\
|
||||
+"Usage:\n"\
|
||||
+" %s [-d TVTUNERDEVICE] [-s CHANNELSET] -c CHANNEL\n"\
|
||||
+" %s -h\n"\
|
||||
+" %s -l\n"\
|
||||
+" %s -v\n"\
|
||||
+"\n"\
|
||||
+"Where:\n"\
|
||||
+"\n"\
|
||||
+" -c\n"\
|
||||
+" The channel to tune to\n"\
|
||||
+"\n"\
|
||||
+" -d\n"\
|
||||
+" The device to open for tuning. If unspecified defaults to /dev/tuner0\n"\
|
||||
+"\n"\
|
||||
+" -h\n"\
|
||||
+" This help you're seeing\n"\
|
||||
+"\n"\
|
||||
+" -l\n"\
|
||||
+" List all valid CHANNELSETs you could pass to the -s option\n"\
|
||||
+"\n"\
|
||||
+" -s\n"\
|
||||
+" The channel set configuration to use. If unspecified defaults to NABCST\n"\
|
||||
+"\n"\
|
||||
+" -v\n"\
|
||||
+" Show program version\n"\
|
||||
+"\n"\
|
||||
+"\n", programname, programname, programname, programname);
|
||||
exit(1);
|
||||
}
|
||||
|
10
multimedia/bsdbktr_tvtune/pkg-descr
Normal file
10
multimedia/bsdbktr_tvtune/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
This is a commandline / console TV channel tuner for Brooktree-based TV capture
|
||||
cards running under FreeBSD using the bktr driver
|
||||
|
||||
It does not require any other utilities (fxtv/xawtv) and does NOT require
|
||||
XFree86
|
||||
|
||||
WWW: http://www.topfx.com
|
||||
|
||||
- Mina Naguib
|
||||
webmaster@topfx.com
|
1
multimedia/bsdbktr_tvtune/pkg-plist
Normal file
1
multimedia/bsdbktr_tvtune/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
bin/bsdbktr_tvtune
|
Loading…
Reference in New Issue
Block a user